1

Temat: Modemy LTE w OpenWrt CC

W sumie temat wałkowany jest cały czas, ale zawsze ktoś ma problemy. Ustawienia popularnych modemów LTE do działania pod OpenWrt CC. Testy na wersji luci:

                   _            _____ _____
                  | |          / ____|_   _|
                  | |    _   _| |      | |
                  | |   | | | | |      | |
                  | |___| |_| | |____ _| |_
                  |______\__,_|\_____|_____|

 ----------------------------------------------------------------
 |                                                              |
 | OpenWrt Chaos Calmer 15.05 (r47196)                          |
 | Build time: 2015-10-17 12:15 CEST                            |
 |                                                              |
 | Cezary Jackiewicz (obsy), [url]http://eko.one.pl[/url]                  |
 |                                                              |
 ----------------------------------------------------------------
 | Machine: TP-Link TL-WR1043N/ND v1                            |
 | Uptime: 0d, 00:06:12                                         |
 | Load: 0.01 0.18 0.13                                         |
 | Flash: total: 1.6MB, free: 1.3MB, used: 14%                  |
 | Memory: total: 27.9MB, free: 13.2MB, used: 52%               |
 | WAN:                                                         |
 | LAN: 192.168.1.1                                             |
 ----------------------------------------------------------------

Huawei E3372 Hilink

Sprzęt: E3372s-153
Dystrybucja: Play
Hardware version: CL1E3372SM
Software version: 22.298.03.02.965
Web UI version: 17.100.05.06.965

Magistrala USB:

T:  Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 27 Spd=480  MxCh= 0
D:  Ver= 2.10 Cls=02(comm.) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=12d1 ProdID=14dc Rev= 1.02
S:  Manufacturer=HUAWEI_MOBILE
S:  Product=HUAWEI_MOBILE
C:* #Ifs= 3 Cfg#= 1 Atr=c0 MxPwr=  2mA
I:* If#= 0 Alt= 0 #EPs= 1 Cls=02(comm.) Sub=06 Prot=00 Driver=cdc_ether
E:  Ad=83(I) Atr=03(Int.) MxPS=  64 Ivl=2ms
I:* If#= 1 Alt= 0 #EPs= 2 Cls=0a(data ) Sub=06 Prot=00 Driver=cdc_ether
E:  Ad=82(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=02(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
I:* If#= 2 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
E:  Ad=84(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=03(O) Atr=02(Bulk) MxPS= 512 Ivl=125us
root@OpenWrt:/# logread | grep cdc_ether
Wed Nov  4 19:21:15 2015 kern.info kernel: [ 3650.810000] cdc_ether 1-1:1.0 eth1: register 'cdc_ether' at usb-ehci-platform-1, CDC Ethernet Device, 0c:5b:8f:xx:xx:xx

Ustawienia:

config interface 'wan'
        option proto 'dhcp'
        option ifname 'eth1'

Huawei E3372

Sprzęt: Huawei E3372s-153
Dystrybucja: Play

Wersja i ustawienie portów:

ati
Manufacturer: huawei
Model: E3372
Revision: 21.286.03.00.264

at^setport?
^SETPORT:A1,A2;12,1,16,A1,A2

Magistrala USB:

T:  Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 11 Spd=480  MxCh= 0
D:  Ver= 2.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=12d1 ProdID=1506 Rev= 1.02
S:  Manufacturer=HUAWEI_MOBILE
S:  Product=HUAWEI_MOBILE
C:* #Ifs= 5 Cfg#= 1 Atr=c0 MxPwr=  2mA
I:* If#= 0 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=02 Prot=12 Driver=option
E:  Ad=82(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=02(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
I:* If#= 1 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=02 Prot=01 Driver=option
E:  Ad=84(I) Atr=03(Int.) MxPS=  10 Ivl=32ms
E:  Ad=83(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=03(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
I:  If#= 2 Alt= 0 #EPs= 1 Cls=ff(vend.) Sub=02 Prot=16 Driver=huawei_cdc_ncm
E:  Ad=86(I) Atr=03(Int.) MxPS=  16 Ivl=2ms
I:* If#= 2 Alt= 1 #EPs= 3 Cls=ff(vend.) Sub=02 Prot=16 Driver=huawei_cdc_ncm
E:  Ad=86(I) Atr=03(Int.) MxPS=  16 Ivl=2ms
E:  Ad=85(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=04(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
I:* If#= 3 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
E:  Ad=87(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=05(O) Atr=02(Bulk) MxPS= 512 Ivl=125us
I:* If#= 4 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
E:  Ad=88(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=06(O) Atr=02(Bulk) MxPS= 512 Ivl=125us

Ustawienia:

config interface 'wan'
        option proto 'ncm'
        option device '/dev/ttyUSB0'
        option apn 'internet'
        option pincode '1111'

Huawei E3272

Sprzęt: Huawei E3272s-153
Dystrybucja: Play

Wersja i ustawienie portów:

ati
Manufacturer: huawei
Model: E3272
Revision: 21.436.11.00.264

at^setport?
^SETPORT:A1,A2;10,12,16,A1,A2

Magistrala USB:

T:  Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  3 Spd=480  MxCh= 0
D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=12d1 ProdID=1506 Rev= 1.02
S:  Manufacturer=HUAWEI Technology
S:  Product=HUAWEI Mobile
C:* #Ifs= 5 Cfg#= 1 Atr=80 MxPwr=500mA
I:* If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=02 Prot=10 Driver=option
E:  Ad=81(I) Atr=03(Int.) MxPS=  64 Ivl=2ms
E:  Ad=82(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=01(O) Atr=02(Bulk) MxPS= 512 Ivl=4ms
I:* If#= 1 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=02 Prot=12 Driver=option
E:  Ad=83(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=02(O) Atr=02(Bulk) MxPS= 512 Ivl=4ms
I:  If#= 2 Alt= 0 #EPs= 1 Cls=ff(vend.) Sub=02 Prot=16 Driver=huawei_cdc_ncm
E:  Ad=84(I) Atr=03(Int.) MxPS=  64 Ivl=2ms
I:* If#= 2 Alt= 1 #EPs= 3 Cls=ff(vend.) Sub=02 Prot=16 Driver=huawei_cdc_ncm
E:  Ad=84(I) Atr=03(Int.) MxPS=  64 Ivl=2ms
E:  Ad=85(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=03(O) Atr=02(Bulk) MxPS= 512 Ivl=4ms
I:* If#= 3 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
E:  Ad=04(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=86(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
I:* If#= 4 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
E:  Ad=05(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=87(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms

Ustawienia:

config interface 'wan'
        option proto 'ncm'
        option device '/dev/ttyUSB1'
        option apn 'internet'
        option pincode '1111'

Huawei E3276

Sprzęt: Huawei E3276s-151
Dystrybucja: Orange

Wersja i ustawienie portów:

ati
Manufacturer: huawei
Model: E3276
Revision: 21.263.03.00.159

at^setport?
^SETPORT:A1,A2;10,12,16,A2

Magistrala USB:

T:  Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 13 Spd=480  MxCh= 0
D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=12d1 ProdID=156c Rev= 1.02
S:  Manufacturer=HUAWEI Technology
S:  Product=HUAWEI Mobile
C:* #Ifs= 4 Cfg#= 1 Atr=80 MxPwr=500mA
I:* If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=02 Prot=10 Driver=option
E:  Ad=81(I) Atr=03(Int.) MxPS=  64 Ivl=2ms
E:  Ad=82(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=01(O) Atr=02(Bulk) MxPS= 512 Ivl=4ms
I:* If#= 1 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=02 Prot=12 Driver=option
E:  Ad=83(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=02(O) Atr=02(Bulk) MxPS= 512 Ivl=4ms
I:  If#= 2 Alt= 0 #EPs= 1 Cls=ff(vend.) Sub=02 Prot=16 Driver=huawei_cdc_ncm
E:  Ad=84(I) Atr=03(Int.) MxPS=  64 Ivl=2ms
I:* If#= 2 Alt= 1 #EPs= 3 Cls=ff(vend.) Sub=02 Prot=16 Driver=huawei_cdc_ncm
E:  Ad=84(I) Atr=03(Int.) MxPS=  64 Ivl=2ms
E:  Ad=85(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=03(O) Atr=02(Bulk) MxPS= 512 Ivl=4ms
I:* If#= 3 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
E:  Ad=04(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=86(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms

Ustawienia:

config interface 'wan'
        option proto 'ncm'
        option device '/dev/ttyUSB1'
        option apn 'internet'
        option pincode '1111'

ZTE MF821

Sprzęt: ZTE MF821
Dystrybucja: Plus

Wersja:

ati
Manufacturer: ZTE Corporation
Model: MF821
Revision: M9200B-SCAQDBZD-3.3.330080T  1  [Mar 12 2012 09:00:00]
SVN: 01

Magistrala USB:

T:  Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 29 Spd=480  MxCh= 0
D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=19d2 ProdID=0167 Rev= 0.00
S:  Manufacturer=ZTE,Incorporated
S:  Product=ZTE LTE Technologies MSM
S:  SerialNumber=MF821_FFFS111111
C:* #Ifs= 6 Cfg#= 1 Atr=c0 MxPwr=500mA
I:* If#= 0 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=option
E:  Ad=81(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=01(O) Atr=02(Bulk) MxPS= 512 Ivl=4ms
I:* If#= 1 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=option
E:  Ad=82(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=02(O) Atr=02(Bulk) MxPS= 512 Ivl=4ms
I:* If#= 2 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=option
E:  Ad=83(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=03(O) Atr=02(Bulk) MxPS= 512 Ivl=4ms
I:* If#= 3 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=option
E:  Ad=84(I) Atr=03(Int.) MxPS=  64 Ivl=2ms
E:  Ad=85(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=04(O) Atr=02(Bulk) MxPS= 512 Ivl=4ms
I:* If#= 4 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=qmi_wwan
E:  Ad=86(I) Atr=03(Int.) MxPS=  64 Ivl=2ms
E:  Ad=87(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=05(O) Atr=02(Bulk) MxPS= 512 Ivl=4ms
I:* If#= 5 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
E:  Ad=06(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=88(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms

Ustawienia:

config interface 'wan'
        option proto 'qmi'
        option device '/dev/cdc-wdm0'
        option apn 'internet'
        option pincode '1111'
Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

2

Odp: Modemy LTE w OpenWrt CC

Nie posiadam. Masz, działa - dopisz się.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

3

Odp: Modemy LTE w OpenWrt CC

Mam pytanie jaka maksymalna predkosc mozna uzyskac uzywajac modemu na usb podpietego pod tplinka 4300. Co bedzie waskim gardlem?

4

Odp: Modemy LTE w OpenWrt CC

Cezary napisał/a:

Nie posiadam. Masz, działa - dopisz się.


D-Link DWM-221 nie działa sad

Huawei E3131 przedstawiający się jaki 12d1:1506

config interface 'wan'
    option 'proto' 'ncm'
        option 'device' '/dev/cdc-wdm0'
        option 'pincode' '1111'
        option 'apn' 'internet'

5

Odp: Modemy LTE w OpenWrt CC

Ale E3131 nie jest LTE smile Sam E3131 Jest obsługiwany, dawno już to pisałem: http://eko.one.pl/forum/viewtopic.php?p … 12#p127712

Pokaż cat /sys/kernel/debug/usb/devices z tym dlinkiem.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

6 (edytowany przez build000 2015-11-06 17:02:20)

Odp: Modemy LTE w OpenWrt CC

kilgor napisał/a:

Mam pytanie jaka maksymalna predkosc mozna uzyskac uzywajac modemu na usb podpietego pod tplinka 4300. Co bedzie waskim gardlem?

wydajność prądowa a jednym złączu usb (max. ~2.5 W ~= ~500mA x ~5V - stąd ten znak "~", że wartości są takimi maksymalnie, ale faktycznie mogą być w jakiejś tolerancji) , chyba że jakimś kabelkiem Y to podepniesz, a najlepiej na zew., aktywnym hubie, dobrze zasilanym lub innym hubem z modowanym zasilaniem, które będzie odcięte od routera. Biorąc pod uwagę, że być może coś innego jeszcze jednocześnie chciałbyś podpiąć, warto by to dodatkowe zasilanie dawało >= 2-2.5 A - sam tylko modem, przy niekorzystnych warunkach propagacji fal może nawet pociągnąć do 1-1.5 A.

7

Odp: Modemy LTE w OpenWrt CC

build000 napisał/a:

chyba że jakimś kabelkiem Y to podepniesz, a najlepiej na zew., aktywnym hubie, dobrze zasilanym lub innym hubem z modowanym zasilaniem, które będzie odcięte od routera. Biorąc pod uwagę, że być może coś innego jeszcze jednocześnie chciałbyś podpiąć, warto by to dodatkowe zasilanie dawało >= 2-2.5 A - sam tylko modem, przy niekorzystnych warunkach propagacji fal może nawet pociągnąć do 1-1.5 A.

Zgadza się, lecz nie demonizujmy tego-to jest zależne od wielu czynników, z których te najistotniejsze występują indywidualnie w konkretnym miejscu użycia modemu (poziom sygnału, obciążenie nadajnika, rodzaj wykupionej usługi/operator). USB 3.0 z zapasem zabezpiecza zapotrzebowanie na energię modemu, producent ma większą wiedzę na ten temat i podaje wart. max.

 Power supply
4.75V-5.25V / 800mA 

(tj. dla E398), to że niekiedy chwilowe wartości są przekraczane, oznacza jedynie że są inne przyczyny, nad których eliminacją powinniśmy się zastanowić, jeżeli chcemy aby modem łączył się w technologii LTE. (standardowo przy prawidłowej pracy modemu i stabilnej, utrzymywanej wydajności zasilania USB 2.0 jest w stanie go obsłużyć, zawsze jednak możemy udowodnić że jest inaczej np. obciążając godzinami na full speed modem, który przy wysokich transferach będzie pobierał więcej). smile        http://eko.one.pl/forum/viewtopic.php?id=12379

8 (edytowany przez build000 2015-11-07 16:36:24)

Odp: Modemy LTE w OpenWrt CC

A co po tzw. wiedzy producenta, jak zwyczajnie - standardy opisane specyfikacjami to jedno, a faktyczne wykonanie/wydajność USB w danym modelu to drugie - w praktyce zawsze trzeba każdy modem/router indywidualnie przetestować pod tym względem...i nie mam tu na myśli określonej czy nawet dopuszczonej tolerancji wykonania/działania takich złączy.
Bierzesz po prostu co kupiłeś i sprawdzasz...to samo zresztą się tyczy konkretnego egzemplarza modemu.
wink
Jeszcze się nie zdarzyło, żeby jakikolwiek producent w jakimkolwiek urządzeniu elektronicznym podawał na 100 % prawdziwe dane. Zawsze jest w jakiejś gwarancji czy instrukcji info, że parametry mogą odbiegać od ogólnie podanych bo (w rzeczywistości) np. zmieniła się seria produkcyjna A i weszła do produkcji seria B tej samej podwersji jakiegoś urządzenia, bo np. na giełdzie cena akcji danej firmy spadła, więc zakupił do serii B gorsze elementy...i cała ta dokładna dokumentacja techniczna okazuje się bliżej nieokreśloną "prognozą życzeń"...

9 (edytowany przez Lameleck 2015-11-17 12:11:58)

Odp: Modemy LTE w OpenWrt CC

Cezary napisał/a:

Ale E3131 nie jest LTE smile Sam E3131 Jest obsługiwany, dawno już to pisałem: http://eko.one.pl/forum/viewtopic.php?p … 12#p127712

Pokaż cat /sys/kernel/debug/usb/devices z tym dlinkiem.

T:  Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=480  MxCh= 1
B:  Alloc=  0/800 us ( 0%), #Int=  1, #Iso=  0
D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=01 MxPS=64 #Cfgs=  1
P:  Vendor=1d6b ProdID=0002 Rev= 3.18
S:  Manufacturer=Linux 3.18.21 ehci_hcd
S:  Product=EHCI Host Controller
S:  SerialNumber=ehci-platform
C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=  0mA
I:* If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   4 Ivl=256ms

T:  Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  2 Spd=480  MxCh= 4
D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=01 MxPS=64 #Cfgs=  1
P:  Vendor=05e3 ProdID=0608 Rev=77.64
S:  Product=USB2.0 Hub
C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=100mA
I:* If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   1 Ivl=256ms

T:  Bus=01 Lev=02 Prnt=02 Port=00 Cnt=01 Dev#=  4 Spd=480  MxCh= 0
D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=2001 ProdID=a401 Rev= 2.32
S:  Manufacturer=Mobile Connect
S:  Product=Mobile Connect
S:  SerialNumber=0123456789ABCDEF
C:* #Ifs= 1 Cfg#= 1 Atr=80 MxPwr=500mA
I:* If#= 0 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
E:  Ad=81(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=01(O) Atr=02(Bulk) MxPS= 512 Ivl=125us

T:  Bus=01 Lev=02 Prnt=02 Port=01 Cnt=02 Dev#=  3 Spd=480  MxCh= 0
D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=04e8 ProdID=0111 Rev= 2.00
S:  Manufacturer=0       
S:  Product=USB DRIVE       
S:  SerialNumber=0000000000003AAC
C:* #Ifs= 1 Cfg#= 1 Atr=80 MxPwr=200mA
I:* If#= 0 Alt= 0 #EPs= 3 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
E:  Ad=81(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=02(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=83(I) Atr=03(Int.) MxPS=   2 Ivl=125us

root@OpenWrt:/etc/config# lsusb
Bus 001 Device 003: ID 04e8:0111 Samsung Electronics Co., Ltd Connect3D Flash Drive
Bus 001 Device 005: ID 2001:a401 D-Link Corp.
Bus 001 Device 002: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

10

Odp: Modemy LTE w OpenWrt CC

Nie jest przełączany, usbmodeswitch go nie zna. Przeczytaj to: http://www.draisberghof.de/usb_modeswit … p;start=15 i zobacz czy kody będą działać, ew w /etc/usb-mode.json odszukaj linię "2001:a403" i zamień to na 2001:a401. Zapisz, zrestartuj i zobacz co będzie.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

11 (edytowany przez GIENEK 2015-11-30 22:21:41)

Odp: Modemy LTE w OpenWrt CC

Ja również proszę o poradę.
Sygnał ciągły 100%. LTE. Modem 3372 (nie hi-link)
prędkość down ok 7  up ok 11 ( max ok 15/15)
ustawienie ^SETPORT:A1,A2;10,16,12,A1,A2

strasznie miernie

cat /sys/kernel/debug/usb/devices

T:  Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=480  MxCh= 1
B:  Alloc=  0/800 us ( 0%), #Int=  0, #Iso=  0
D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=01 MxPS=64 #Cfgs=  1
P:  Vendor=1d6b ProdID=0002 Rev= 3.18
S:  Manufacturer=Linux 3.18.23 ehci_hcd
S:  Product=EHCI Host Controller
S:  SerialNumber=ehci-platform
C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=  0mA
I:* If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   4 Ivl=256ms

T:  Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  3 Spd=480  MxCh= 0
D:  Ver= 2.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=12d1 ProdID=1506 Rev= 1.02
S:  Manufacturer=HUAWEI_MOBILE
S:  Product=HUAWEI_MOBILE
C:* #Ifs= 5 Cfg#= 1 Atr=80 MxPwr=  2mA
I:* If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=02 Prot=10 Driver=option
E:  Ad=83(I) Atr=03(Int.) MxPS=  10 Ivl=32ms
E:  Ad=82(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=02(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
I:  If#= 1 Alt= 0 #EPs= 1 Cls=ff(vend.) Sub=02 Prot=16 Driver=huawei_cdc_ncm
E:  Ad=85(I) Atr=03(Int.) MxPS=  16 Ivl=2ms
I:* If#= 1 Alt= 1 #EPs= 3 Cls=ff(vend.) Sub=02 Prot=16 Driver=huawei_cdc_ncm
E:  Ad=85(I) Atr=03(Int.) MxPS=  16 Ivl=2ms
E:  Ad=84(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=03(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
I:* If#= 2 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=02 Prot=12 Driver=option
E:  Ad=86(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=04(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
I:* If#= 3 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
E:  Ad=87(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=05(O) Atr=02(Bulk) MxPS= 512 Ivl=125us
I:* If#= 4 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
E:  Ad=88(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=06(O) Atr=02(Bulk) MxPS= 512 Ivl=125us

12

Odp: Modemy LTE w OpenWrt CC

Ale jaką chcesz poradę? Podłącz pod silny router, zmień operatora?

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

13 (edytowany przez GIENEK 2015-11-30 22:24:14)

Odp: Modemy LTE w OpenWrt CC

Cezary napisał/a:

Ale jaką chcesz poradę? Podłącz pod silny router, zmień operatora?

mam mikrotika 951 - sprzęt raczej dobry, w miare blisko od nadajnika

CSQ:31 RSSI:>= -51 dBm Profil UMTS QoS:0 kbps DOWN | 0 kbps UP MCC MNC:260 06 LAC:00C7 (199) LCID:00123C16 (1195030) eNB:00123C (4668) CID:0016 (22) RSCP:-145 dBm Ec/IO:-32 dB RSRP:-71 dBm RSRQ:-8 dB   Urządzenie:huawei E3372

14

Odp: Modemy LTE w OpenWrt CC

Może  być tak że ten bts jest po prostu obciążony. W innej lokalizacji, o innych porach dnia sprawdzałeś? Modem w ogóle chodzi Ci w ndisie czy ppp?

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

15

Odp: Modemy LTE w OpenWrt CC

Cezary napisał/a:

Może  być tak że ten bts jest po prostu obciążony. W innej lokalizacji, o innych porach dnia sprawdzałeś? Modem w ogóle chodzi Ci w ndisie czy ppp?

nie sprawdzałem
config interface 'wan'
         option proto 'ncm'
         option device /dev/ttyUSB1
         option apn internet
z zależności od pór dnia nocy zmienia siętrochę ale nie az tak żeby było np 100/30

16

Odp: Modemy LTE w OpenWrt CC

Tyle to nie uzyskasz smile

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

17

Odp: Modemy LTE w OpenWrt CC

Cezary napisał/a:

Tyle to nie uzyskasz smile

Wiem ale nie 10 mb downloadu
choć ze 30

18

Odp: Modemy LTE w OpenWrt CC

GIENEK napisał/a:

Ja również proszę o poradę.
Sygnał ciągły 100%. LTE. Modem 3372 (nie hi-link)

GIENEK napisał/a:

mam mikrotika 951 - sprzęt raczej dobry, w miare blisko od nadajnika

CSQ:31 RSSI:>= -51 dBm Profil UMTS QoS:0 kbps DOWN | 0 kbps UP MCC MNC:260 06 LAC:00C7 (199) LCID:00123C16 (1195030) eNB:00123C (4668) CID:0016 (22) RSCP:-145 dBm Ec/IO:-32 dB RSRP:-71 dBm RSRQ:-8 dB   Urządzenie:huawei E3372

RSCP nie występuje w LTE. To jest tylko w UMTS. (zresztą napisał Ci to Profil UMTS) U mnie jest  RSSI: -63dBm RSCP: -73dBm ECIO: -10. Z anteną zewnętrzną Sorensena DUAL. U Ciebie  strasznie zły jest parametr RSCP:-145 dBm i w odróżnieniu do mnie nie pokrywa się ze wzorem:

RSSI [dBm] = RSCP [dBm] – Ec/I0 [dB]

Po przełączeniu na LTE u mnie parametry są inne: RSSI: -57dBm PCI: 7 RSRQ: -7dBm RSRP: -77dBm SINR: 6dBm

Tylko czasem nie pomyśl, że tym postem chcę Ci udowodnić, że kłamiesz  czy coś w tym stylu, ale to że, modem przełącza się na UMTS a Ty o tym nie wiesz....

* WR1043v1 16MB@64MB * || * WT3020-16MB * || * Xiaomi Miwifi Mini *
* E3276 HiLink + RTL2832 + IT9135 + Siano + EC103 *

19 (edytowany przez GIENEK 2015-11-30 23:05:25)

Odp: Modemy LTE w OpenWrt CC

mar_w napisał/a:
GIENEK napisał/a:

Ja również proszę o poradę.
Sygnał ciągły 100%. LTE. Modem 3372 (nie hi-link)

GIENEK napisał/a:

mam mikrotika 951 - sprzęt raczej dobry, w miare blisko od nadajnika

CSQ:31 RSSI:>= -51 dBm Profil UMTS QoS:0 kbps DOWN | 0 kbps UP MCC MNC:260 06 LAC:00C7 (199) LCID:00123C16 (1195030) eNB:00123C (4668) CID:0016 (22) RSCP:-145 dBm Ec/IO:-32 dB RSRP:-71 dBm RSRQ:-8 dB   Urządzenie:huawei E3372

RSCP nie występuje w LTE. To jest tylko w UMTS. (zresztą napisał Ci to Profil UMTS) U mnie jest  RSSI: -63dBm RSCP: -73dBm ECIO: -10. Z anteną zewnętrzną Sorensena DUAL. U Ciebie  strasznie zły jest parametr RSCP:-145 dBm i w odróżnieniu do mnie nie pokrywa się ze wzorem:

RSSI [dBm] = RSCP [dBm] – Ec/I0 [dB]

Po przełączeniu na LTE u mnie parametry są inne: RSSI: -57dBm PCI: 7 RSRQ: -7dBm RSRP: -77dBm SINR: 6dBm

Tylko czasem nie pomyśl, że tym postem chcę Ci udowodnić, że kłamiesz  czy coś w tym stylu, ale to że, modem przełącza się na UMTS a Ty o tym nie wiesz....

takiej odpowiedzi oczekiwałem ( że coś jest nie tak)
W informacji 3ginfo mam tryb pracy lte a jak biorę szczegóły to pokazuje sieto co wysłałem.
najnowsza wersja z luci  pobrana z portalu. Dziwi mnie jeszcze że upload  mam dwa razy większy niż download

20

Odp: Modemy LTE w OpenWrt CC

Wykonaj 3ginfo-test, będziesz miał surowy output z modemu.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

21

Odp: Modemy LTE w OpenWrt CC

3ginfo-test

+CSQ: 31,99
^SYSINFOEX:2,3,0,1,,6,"LTE",101,"LTE"
^CSNR: -145,-32
^LTERSRP:-71,-11
^SYSINFO:2,3,0,5,1,,4
+COPS: 0,2,"26006",7
+CREG: 2,1,"00C7","00123C16"
+CGREG: 2,1,"00C7","00123C16"
+CGEQNEG: 1,4,0,0,0,0,2,0,"0E0","0E0",3,0,0
DEVICE:huawei E3372
---------------------------------------------------------------
/dev/tty      /dev/ttyS11   /dev/ttyS15   /dev/ttyS5    /dev/ttyS9
/dev/ttyS0    /dev/ttyS12   /dev/ttyS2    /dev/ttyS6    /dev/ttyUSB0
/dev/ttyS1    /dev/ttyS13   /dev/ttyS3    /dev/ttyS7    /dev/ttyUSB1
/dev/ttyS10   /dev/ttyS14   /dev/ttyS4    /dev/ttyS8
---------------------------------------------------------------

T:  Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=480  MxCh= 1
B:  Alloc=  0/800 us ( 0%), #Int=  0, #Iso=  0
D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=01 MxPS=64 #Cfgs=  1
P:  Vendor=1d6b ProdID=0002 Rev= 3.18
S:  Manufacturer=Linux 3.18.23 ehci_hcd
S:  Product=EHCI Host Controller
S:  SerialNumber=ehci-platform
C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=  0mA
I:* If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   4 Ivl=256ms

T:  Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  3 Spd=480  MxCh= 0
D:  Ver= 2.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=12d1 ProdID=1506 Rev= 1.02
S:  Manufacturer=HUAWEI_MOBILE
S:  Product=HUAWEI_MOBILE
C:* #Ifs= 5 Cfg#= 1 Atr=80 MxPwr=  2mA
I:* If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=02 Prot=10 Driver=option
E:  Ad=83(I) Atr=03(Int.) MxPS=  10 Ivl=32ms
E:  Ad=82(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=02(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
I:  If#= 1 Alt= 0 #EPs= 1 Cls=ff(vend.) Sub=02 Prot=16 Driver=huawei_cdc_ncm
E:  Ad=85(I) Atr=03(Int.) MxPS=  16 Ivl=2ms
I:* If#= 1 Alt= 1 #EPs= 3 Cls=ff(vend.) Sub=02 Prot=16 Driver=huawei_cdc_ncm
E:  Ad=85(I) Atr=03(Int.) MxPS=  16 Ivl=2ms
E:  Ad=84(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=03(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
I:* If#= 2 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=02 Prot=12 Driver=option
E:  Ad=86(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=04(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
I:* If#= 3 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
E:  Ad=87(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=05(O) Atr=02(Bulk) MxPS= 512 Ivl=125us
I:* If#= 4 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
E:  Ad=88(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=06(O) Atr=02(Bulk) MxPS= 512 Ivl=125us
---------------------------------------------------------------
3ginfo.@3ginfo[0]=3ginfo
3ginfo.@3ginfo[0].http_port='81'
3ginfo.@3ginfo[0].language='pl'
3ginfo.@3ginfo[0].device='/dev/ttyUSB1'

22 (edytowany przez Sigma 2015-12-01 11:40:20)

Odp: Modemy LTE w OpenWrt CC

3ginfo tak interpretuje RSCP przy LTE. U mnie jest (e3372 niehilink, wndr4300, Orange):

CSQ:27 
RSSI:-59 dBm 
Profil UMTS QoS:0 kbps DOWN | 0 kbps UP 
MCC MNC:260 03 
LAC:D548 (54600) 
LCID:03C10B02 (62982914) 
eNB:03C10B (246027) 
CID:0002 (2) 
RSCP:-145 dBm 
Ec/IO:-32 dB 
RSRP:-81 dBm 
RSRQ:-11 dB   
Urządzenie:huawei E3372

I osiąga 45/25 w godzinach szczytu, 100/30 poza godzinami szczytu. Obstawiałbym mimo wszystko nadajnik smile

LEDE Reboot 17.01-SNAPSHOT r3435-65eec8b: YunCore SR3200/NETGEAR WNDR4300/TP-Link TL-WDR4300 v1
Gargoyle 1.9.1 TP-Link TL-WR841N/ND v9
Tomato by Shibby 140 K26 USB: Netgear WNR3500L
Modem 3g: Huawei e3372h / NAS: DNS-320LW

23

Odp: Modemy LTE w OpenWrt CC

Pogratulować osiągów, też tak kiedyś miałem.
Od czasu wprowadzenia pakietów "bez limitu LTE" prędkość stale spada.
Teraz np. Play w godzinach wieczornych typowo to 5/20 ,a Plus 10/10 . sad

Czy z tych parametrów 3ginfo da się ustalić do jakiego nadajnika LTE jest podłączony modem??

24

Odp: Modemy LTE w OpenWrt CC

LAC/CID o tym mówi. Jak go znajdziesz w btsearch bo czesto to jest niekompletne lub ma inne dane.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

25

Odp: Modemy LTE w OpenWrt CC

Właśnie dlatego pytam, bo w przypadku nadajnika LTE, btsearch (u mnie) nic sensownego nie podaje,
najczęściej to: "Nie znaleziono rekordów spełniających kryteria wyszukiwania!".
Gdzieś czytałem że to eNB ma identyfikować nadajnik, ale i to już na mapie btsearch się mi nie zgadza. sad