26

Odp: 3ginfo ze wsparciem dla modemów Huawei HiLink

A co macie w konfigu: http://192.168.8.1/config/deviceinformation/config.xml ?

It is I, Leclerc cool

27

Odp: 3ginfo ze wsparciem dla modemów Huawei HiLink

<config>
<devicename>1</devicename>
<serialnumber>0</serialnumber>
<imei>1</imei>
<imsi>1</imsi>
<iccid>0</iccid>
<msisdn>1</msisdn>
<hardwareversion>1</hardwareversion>
<softwareversion>1</softwareversion>
<webuiversion>1</webuiversion>
<macaddress1>1</macaddress1>
<macaddress2>0</macaddress2>
<productfamily>0</productfamily>
<classify>0</classify>
<wanipaddress>1</wanipaddress>
<wanipv6address>0</wanipv6address>
<esn>0</esn>
<meid>0</meid>
<pci>0</pci>
<sc>0</sc>
<cell_id>0</cell_id>
<rsrq>0</rsrq>
<rsrp>0</rsrp>
<rssi>0</rssi>
<sinr>0</sinr>
<rscp>0</rscp>
<ecio>0</ecio>
</config>
Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

28

Odp: 3ginfo ze wsparciem dla modemów Huawei HiLink

No to to może być przyczyną braku danych wartości. U mnie jest:

<config>
<devicename>1</devicename>
<serialnumber>1</serialnumber>
<imei>1</imei>
<imsi>1</imsi>
<iccid>1</iccid>
<msisdn>1</msisdn>
<hardwareversion>1</hardwareversion>
<softwareversion>1</softwareversion>
<webuiversion>1</webuiversion>
<macaddress1>0</macaddress1>
<macaddress2>0</macaddress2>
<productfamily>0</productfamily>
<classify>0</classify>
<wanipaddress>1</wanipaddress>
<wanipv6address>0</wanipv6address>
<primarydns>1</primarydns>
<secondarydns>1</secondarydns>
<esn>1</esn>
<meid>1</meid>
<pci>1</pci>
<sc>1</sc>
<lac>1</lac>
<cell_id>1</cell_id>
<rsrq>1</rsrq>
<rsrp>1</rsrp>
<rssi>1</rssi>
<sinr>1</sinr>
<rscp>1</rscp>
<ecio>1</ecio>
</config>

Żeby to zmienić trzeba albo odblokować adb/telnet w modemie (metoda nie sprawdzona do końca, bazująca na tłumaczeniu z ruskiego: http://www.bez-kabli.pl/viewtopic.php?p=502357#502357 ) tyle, że nie wiem czy czegoś jeszcze nie trzeba gdzieś w configach fw zmienić. Albo wgrać oprogramowanie już zmodowane.

It is I, Leclerc cool

29

Odp: 3ginfo ze wsparciem dla modemów Huawei HiLink

Teoria dobra, choć ecio/rscp/rssi/sinr/rsrq wyświetla u mnie, mimo że są zera.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

30

Odp: 3ginfo ze wsparciem dla modemów Huawei HiLink

No to tak jak mówię, może jeszcze gdzieś coś siedzi, żeby dawało całość informacji. Ten config co podałem dotyczy chyba tylko WebUI, a czy wpływa na wyświetlanie to nie wiem nie próbowałem na czystym modemie tego sam robić tongue

It is I, Leclerc cool

31

Odp: 3ginfo ze wsparciem dla modemów Huawei HiLink

Na sofcie Z LMT miałem to samo co Cezary pod http://192.168.8.1/config/deviceinformation/config.xml. Zaktualizowałem modem do wersji E3372Update_22.286.53.01.161_S_ADB_TLN_02 i mam to co Sanjuro. Informacje w 3ginfo się pokazały.

CSQ:14 
RSSI:-85 dBm 
MCC MNC:260 06 
LAC:0013 (19) 
LCID:0017F41C (1569820) 
eNB:0017F4 (6132) 
CID:001C (28) 
RSCP:-145 dBm 
Ec/IO:-32 dB 
RSRP:-113 dBm 
RSRQ:-10 dB   
Urządzenie:huawei E3372 HiLink 

P.S.
Po aktualizacji zauważyłem lepszy zasięg, troszkę szybszy na speed teście, pingi bez zmiany.

32 (edytowany przez SLiDer 2015-05-06 17:43:55)

Odp: 3ginfo ze wsparciem dla modemów Huawei HiLink

Hej,

mam ten sam problem chcialem wgrac nowy firmware ale pyta mnie o jakies haslo zostala mi tylko jedna proba ktos wie skad moge wziac haslo do upgradeu firmwareu w Huawei e3372s-153??

dzieki

update: Juz dziala !!!! Rzeczywiscie trzeba zmienic firmware zeby informacje sie wyswietlaly teraz wszystko smiga az milo. smile

dzieki!

33

Odp: 3ginfo ze wsparciem dla modemów Huawei HiLink

Na http://dl.eko.one.pl/projekty/hilink/ umieściłem skrypt do podania pinu dla modemów HiLink. Działa dla obu wersji firmware (cookie i token, patrz pierwszy post), sprawdzone na E3372s-153.

Aby działało:

wget -O /etc/hotplug.d/iface/99-hilink-pin.sh http://dl.eko.one.pl/projekty/hilink/99-hilink-pin.sh

Pin trzeba podać w sekcji wan network, czyli np.

uci set network.wan.pincode=1234
uci commit

Tak samo jak dla smsów - dla tokenu wystarczy zwykły wget, dla cookie trzeba zainstalować wget-nossl (i najlepiej w skrypcie zmienić WGET=wget na WGET=wget-nossl)

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

34

Odp: 3ginfo ze wsparciem dla modemów Huawei HiLink

Szanowni a jak to na prawdę jest z trybem HiLink i OpenWrt... Jest podwójny NAT czy OpenWrt robi czysty routing przez WAN do swojego default gateway?

No bo jak jest podwójny NAT to aż się prosi o zmianę nie wspominając o zbędnym podwójnym firewall (bo hilinki przecież też filtruja ruch).

Kto wie jak to jest?

MvincM

35

Odp: 3ginfo ze wsparciem dla modemów Huawei HiLink

Jest podwójny nat. Czemu się prosi? W czym Ci to przeszkadza?

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

36

Odp: 3ginfo ze wsparciem dla modemów Huawei HiLink

Z moich doświadczeń/wiedzy jest to po prostu zbędny narzut na każdy pakiet, zbędne filtrowanie przez iptables. Ale to jest "tylko" narzut (nadmiarowy = zbędny) a praktycznie nie ma szans na portforwarding (publiczne IP jest w LTE do osiągnięcia) bo HiLink nie ma pojęcia o sieci lokalnej bo widzi tylko jeden przykryty IP. Dodatkowo zauważyłem ze OpenVPN (udp) mniej stabilnie działa (instalowany na OpenWrt który jest gateway dla sieci lokalnej przez hilink). No i minimalnie ale rośnie ping (pewnie wynika to z narzutu o którym na wstępie).

P. S.
W niektórych modemach da się przejść z hilink na normalny a w innych nie ma takiej opcji (brak alternatywnego firmware).

MvincM

37

Odp: 3ginfo ze wsparciem dla modemów Huawei HiLink

Pingi są do zniesienia. Forward portu też możesz zrobić, nie ma z tym problemu. Mi w ogóle hilink nie przeszkadza.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

38

Odp: 3ginfo ze wsparciem dla modemów Huawei HiLink

Hej,

Modem E3272 HiLink na Play.
Wykonanie:

opkg update
opkg install wget-nossl

Było obowiązkowe.

Niestety LAC niewidoczne.
http://192.168.1.1/config/deviceinformation/config.xml podobne do Cezarego a nawet jeszcze mniej opcji na oryginalnym sofcie.
Postanowiłem zaktualizować modem do E3272Update_22.436.07.04.1202_ADB i WebUI do WEBUI_17.100.06.00.03_Hilink_forE3272_Mod1.0, modem przeżył :-).
Teraz w config.xml

<config>
<devicename>1</devicename>
<serialnumber>1</serialnumber>
<imei>1</imei>
<imsi>1</imsi>
<iccid>1</iccid>
<msisdn>1</msisdn>
<hardwareversion>1</hardwareversion>
<softwareversion>1</softwareversion>
<webuiversion>1</webuiversion>
<macaddress1>0</macaddress1>
<macaddress2>0</macaddress2>
<productfamily>0</productfamily>
<classify>0</classify>
<wanipaddress>1</wanipaddress>
<wanipv6address>0</wanipv6address>
<primarydns>1</primarydns>
<secondarydns>1</secondarydns>
<esn>1</esn>
<meid>1</meid>
<pci>1</pci>
<sc>1</sc>
<lac>1</lac>
<cell_id>1</cell_id>
<rsrq>1</rsrq>
<rsrp>1</rsrp>
<rssi>1</rssi>
<sinr>1</sinr>
<rscp>1</rscp>
<ecio>1</ecio>
</config>

Niestety LAC nadal brak, co widać to:

Status: Połączony
Czas polaczenia: 0d, 00:36:59
Przeslano danych: 37.6 MiB / 21.7 MiB
Operator: Play
Tryb pracy: LTE
Sila sygnalu: 70%
Urzadzenie: huawei E3272 HiLink
MCC MNC: 260 06
LAC: - (-)
LCID: - (-)
RNC: - (-)
eNB: - (-)
CID: - (-)
CSQ: 22
RSSI: -69 dBm
RSCP: -145 dBm
Ec/IO: -32 dB
RSRP: -95 dBm
RSRQ: - dB

Więc pewnikiem coś jeszcze trzeba konretnego zrobić bo chyba Play tego nie blokuje?
Swoją drogą mam dla

3ginfo-test

taki wynik

Brak urzadzenia 192.168.1.1!

To normalne?

39

Odp: 3ginfo ze wsparciem dla modemów Huawei HiLink

Patrz w pierwszym poście jak uzyskać informacje diagnostyczne dla hilinka. I pokaż pliki czy masz w nich lac czy nie.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

40

Odp: 3ginfo ze wsparciem dla modemów Huawei HiLink

LAC niestety nie występuje.

device-information

<response>
<DeviceName>E3272</DeviceName>
<SerialNumber>*</SerialNumber>
<Imei>*</Imei>
<Imsi>*</Imsi>
<Iccid>*</Iccid>
<Msisdn></Msisdn>
<HardwareVersion>CH1E3272SM</HardwareVersion>
<SoftwareVersion>22.436.07.04.1202</SoftwareVersion>
<WebUIVersion>17.100.06.00.03_Mod1.0</WebUIVersion>
<MacAddress1>00:0D:87:8E:4B:AC</MacAddress1>
<MacAddress2></MacAddress2>
<ProductFamily>LTE</ProductFamily>
<Classify>hilink</Classify>
</response>

device-signal

<response>
<mode>4</mode>
<rssi>-65dBm</rssi>
<rscp></rscp>
<rsrp>-92dBm</rsrp>
</response>

monitoring-status

<response>
<ConnectionStatus>901</ConnectionStatus>
<WifiConnectionStatus></WifiConnectionStatus>
<SignalStrength>70</SignalStrength>
<SignalIcon>4</SignalIcon>
<CurrentNetworkType>19</CurrentNetworkType>
<CurrentServiceDomain>3</CurrentServiceDomain>
<RoamingStatus>0</RoamingStatus>
<BatteryStatus></BatteryStatus>
<BatteryLevel></BatteryLevel>
<BatteryPercent></BatteryPercent>
<simlockStatus>0</simlockStatus>
<WanIPAddress>109.243.30.13</WanIPAddress>
<WanIPv6Address></WanIPv6Address>
<PrimaryDns>89.108.202.20</PrimaryDns>
<SecondaryDns>89.108.195.20</SecondaryDns>
<PrimaryIPv6Dns></PrimaryIPv6Dns>
<SecondaryIPv6Dns></SecondaryIPv6Dns>
<CurrentWifiUser></CurrentWifiUser>
<TotalWifiUser></TotalWifiUser>
<ServiceStatus>2</ServiceStatus>
<SimStatus>1</SimStatus>
<WifiStatus></WifiStatus>
</response>

net-current-plmn

<response>
<State>0</State>
<FullName>Play</FullName>
<ShortName>Play</ShortName>
<Numeric>26006</Numeric>
<Rat>7</Rat>
</response>

net-signal-para

<response>
<Rscp>-145</Rscp>
<Ecio>-32</Ecio>
</response>

webserver-token

<error>
<code>100002</code>
<message></message>
</error>

41

Odp: 3ginfo ze wsparciem dla modemów Huawei HiLink

Też nie masz. Inną wersję softu możesz sprawdzić.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

42 (edytowany przez bastvera 2015-05-17 20:26:32)

Odp: 3ginfo ze wsparciem dla modemów Huawei HiLink

Dobra pobawiłem się trochę i dla

fw E3276s_Update_22.470.13.00.00_ADB_TLN_01
sw Update_WEBUI_17.100.03.01.03_Hilink_V7R1_V3R2_Mod1.4

Ciągle nie ma LAC ... ale pojawiło się CID w device signal

<response>
<pci>418</pci>
<sc></sc>
<cell_id>3287620</cell_id>
<rsrq>-10dB</rsrq>
<rsrp>-92dBm</rsrp>
<rssi>-67dBm</rssi>
<sinr>14dB</sinr>
<rscp></rscp>
<ecio></ecio>
<mode>7</mode>
</response>

Niestety nadal się nic nie pojawiało więc podejrzałem skrypty. Dla debug wynik jest taki

...
+CREG: 2,1,"","322A44"
...

Nie chciało mi się wnikać zbytnio ale po poniższej komendzie CID jest pusty. Pewnie dlatego, że LAC jest puste ale mogę się mylić bo nie sprawdzałem empirycznie.

CID=$(echo "$O" | awk -F[,] '/\'$CREG'/ {printf "%s", toupper($4)}' | sed 's/[^A-F0-9]//g')

Przypisałem beszczelnie za tym poleceniem na próbe CID zmienione do hex  które jest w device signal i wszysztko ładnie poszło.
Komenda 3ginfo ożyła pokazuje wszystko co powinna poza LAC.
Dodatkowo na stronce można kliknąć na przekierowanie do btsearch.
Tylko, że nie zabardzo coś znajduje bo pewnie dlatego że to LTE.
Dla pewności przepiołem się na UMTS, przepisałem CID, znów na siłe wcisnąłem w skrypt i tym razem perfekcyjnie przekierowanie znalazło co trzeba.

43

Odp: 3ginfo ze wsparciem dla modemów Huawei HiLink

Tak, skrypty oczekują obecności i lac i cid.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

44 (edytowany przez Sanjuro 2015-06-16 22:42:53)

Odp: 3ginfo ze wsparciem dla modemów Huawei HiLink

Cezary napisał/a:

Kolejny problem - w zależności od oprogramowania, dostęp do danych przez API Hilinka odbywa się albo przez token albo przez cookie. O ile w pierwszym przypadku nie ma większego problemu, o tyle w drugim przypadku trzeba zainstalować również pełny wget np.

opkg update
opkg install wget-nossl

Bo bez tego nie można czytać i używać ciasteczek przy wget

Cezary jak się okazuje mając SessionID (pobieramy z adresu /api/webserver/SesTokInfo) nie trzeba używać cookie. Można przesłać nagłówkiem "Cookie" dla wget byłoby to:

--header "Cookie: SessionID=<tu_ten_długi_hash_identyfikatora_sesji>"

>>Tu<< wstępnie bardziej szczegółowo opisałem swoje boje z identyfikatorem sesji (specjalnie po to zmieniłem oprogramowanie w modemie tongue ).

It is I, Leclerc cool

45

Odp: 3ginfo ze wsparciem dla modemów Huawei HiLink

Witam
U mnie jest LAC
<config><devicename>1</devicename><serialnumber>1</serialnumber><imei>1</imei><imsi>1</imsi><iccid>1</iccid><msisdn>1</msisdn><hardwareversion>1</hardwareversion><softwareversion>1</softwareversion><webuiversion>1</webuiversion><macaddress1>0</macaddress1><macaddress2>0</macaddress2><productfamily>0</productfamily><classify>0</classify><wanipaddress>1</wanipaddress><wanipv6address>0</wanipv6address><primarydns>1</primarydns><secondarydns>1</secondarydns><esn>1</esn><meid>1</meid><pci>1</pci><sc>1</sc><lac>1</lac><cell_id>1</cell_id><rsrq>1</rsrq><rsrp>1</rsrp><rssi>1</rssi><sinr>1</sinr><rscp>1</rscp><ecio>1</ecio></config>


3ginfo
Status: Brak informacji
Czas polaczenia: -
Przeslano danych: - / -
Operator: Orange
Tryb pracy: LTE
Sila sygnalu: 41%
Urzadzenie: huawei E3372 HiLink
MCC MNC: 260 03
LAC: CEAF (52911)
LCID: 037BEF01 (58453761)
RNC: - (-)
eNB: 037BEF (228335)
CID: 0001 (1)
CSQ: 13
RSSI: -87 dBm
RSCP: -145 dBm
Ec/IO: -32 dB
RSRP: -109 dBm
RSRQ: -8 dB
ale PINu nadal nie umie obsłużyć

Przeszło:
opkg install wget-nossl
opkg install 3ginfo

Mój modem w systemie jest jako eth1
HardwareVersion CL1E3372SM Ver.A
SoftwareVersion 22.286.03.00.00
WebUIVersion 16.100.05.00.03

Co mam pozmieniać żeby zadziałało automatyczne podawanie PINu ?

46

Odp: 3ginfo ze wsparciem dla modemów Huawei HiLink

Dodać skrypt po prostu.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

47

Odp: 3ginfo ze wsparciem dla modemów Huawei HiLink

Zrobiłem wg wskazówek:

wget -O /etc/hotplug.d/iface/99-hilink-pin.sh http://dl.eko.one.pl/projekty/hilink/99-hilink-pin.sh
Pin trzeba podać w sekcji wan network, czyli np.
uci set network.wan.pincode=1234
uci commit
Tak samo jak dla smsów - dla tokenu wystarczy zwykły wget, dla cookie trzeba zainstalować wget-nossl (i najlepiej w skrypcie zmienić WGET=wget na WGET=wget-nossl)

Czy w skrypcie też zmieniać na eth2 ?

48

Odp: 3ginfo ze wsparciem dla modemów Huawei HiLink

W skrypcie  nic nie ma o żadnym ethx. Wan jest za to.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

49

Odp: 3ginfo ze wsparciem dla modemów Huawei HiLink

Tylko ja nie mam żadnego WANa
/etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd23:92eb:7a12::/48'

config interface 'lan'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option _orig_ifname 'eth0.1 radio0.network1'
        option _orig_bridge 'true'
        option ifname 'eth0.1 eth1'
        option ipaddr '192.168.8.2'
        option pincode '1234'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 5t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0 5t'



/etc/config/3ginfo
config 3ginfo
        option http_port '81'
        option qos '0'
        option language 'pl'
        option device '192.168.8.1'
        option network 'eth1'


Co u mnie jest nie tak?

50

Odp: 3ginfo ze wsparciem dla modemów Huawei HiLink

To nie zadziała. Skrypt jest przeznaczony do działania z wanem, a ty masz zrobionego bridge na lanie z jakiego powodu.

PS - w 3ginfo ma być adres ip a nie eth1.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.