226

Odp: Nowe wersje skryptów HSO, NDIS i QMI dla modemów 3G/LTE

Z eko.one.pl. Nie z pierwszego postu na tej stronie.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

227

Odp: Nowe wersje skryptów HSO, NDIS i QMI dla modemów 3G/LTE

dziwne, korzystam z Internetu i doświadczam jakby zawieszenie się modemu.
Aktualnie mam tak zrobione.
W Gargoyle mam ustawione połączenie jako: Modem 3G/LTE (NDIS)
przy starcie routera z /etc/rc.local dokonuje wykonanie

ifdown wan
uqmi -d /dev/cdc-wdm0 --set-device-operating-mode offline
uqmi -d /dev/cdc-wdm0 --set-device-operating-mode reset
sleep 20
uqmi -d /dev/cdc-wdm0 --set-device-operating-mode online
sleep 20
ifup wan


i działa, działa.. aż się zawiesza i trzeba ponownie uruchomić w/w polecenia

da się jakoś to naprawić?

228

Odp: Nowe wersje skryptów HSO, NDIS i QMI dla modemów 3G/LTE

Zdarza się. Ot taki urok modemu/połączenia czy czego tam jeszcze.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

229

Odp: Nowe wersje skryptów HSO, NDIS i QMI dla modemów 3G/LTE

więc telepatycznie sugerujesz żeby wpisać te polecenia do skryptu i włączyć monitor połączenia?

230

Odp: Nowe wersje skryptów HSO, NDIS i QMI dla modemów 3G/LTE

Dokładnie smile

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

231

Odp: Nowe wersje skryptów HSO, NDIS i QMI dla modemów 3G/LTE

no dobra, i tak nie ma innego wyjścia

232

Odp: Nowe wersje skryptów HSO, NDIS i QMI dla modemów 3G/LTE

Obecnie Huawei E398 + TP-Link WR1043ND v2 w trybie NDIS działa doskonale. Jednakże w porównaniu do RAS czas połączenia jest znaczny. Modem łączy się automatycznie po 4 minutach tzn. 4 minuty od wykrycia podłączenia rutera przez LAN przez komputer. W 3Ginfo widzę już po 1,5 minuty od wykrycia portu LAN sygnał z modemu. Próbuje pewnych zmian z monitorem połączenia i nic nie wychodzi. Opóźnienie na starcie miało wartość domyślną, później 90 a na końcu 5 jednakże nic to nie daje. Jakie wartości optymalnie wpisać aby czas połączenia uległ poprawie ?

233

Odp: Nowe wersje skryptów HSO, NDIS i QMI dla modemów 3G/LTE

Żadnych w sumie. Dodaj sobie na starcie jakąś pętle żeby po wykryciu odpowiedniego urządzenia w /dev/ i rejestracji w sieci nawiązał połączenie (ifup wan).

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

234

Odp: Nowe wersje skryptów HSO, NDIS i QMI dla modemów 3G/LTE

Jakiś przykład skryptu ?

235

Odp: Nowe wersje skryptów HSO, NDIS i QMI dla modemów 3G/LTE

#!/bin/sh
while true; do
if [ -e /dev/cdc-wdm0 ]; then
  sleep 2
  ifup wan
  exit
fi
done


itd. Jeszcze rejestracja w sieci - gcomem lub uqmi

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

236

Odp: Nowe wersje skryptów HSO, NDIS i QMI dla modemów 3G/LTE

Postawiłem Openwrt na WDR4300. Mam wan1 na pppoe oraz wan2 na Huawei E398. Chciałbym mieć loadbalancing zrobiony z wwan3. Wczoraj wlaczylem uqmi i działa. Natomiast chciałbym, żeby połączeniu NDIS/QMI było podtrzymywane/odnawiane.

Jak skonfigurować w "gołym" Openwrt z Luci jakiś monitor połączenia, który by podnosił QMI kiedy padnie? Bo na razie to wan2 padnie, to wwan3 go wyłącza z loadbalancu i trzeba go recznie podnosić. Czy ten skrypt wlasnie do tego sluzy? Gdzie go wpakować?

#!/bin/sh
while true; do
if [ -e /dev/cdc-wdm0 ]; then
  sleep 2
  ifup wan
  exit
fi
done

Dziękuję

237

Odp: Nowe wersje skryptów HSO, NDIS i QMI dla modemów 3G/LTE

Nie służy to tego, tym bardziej że masz wan2 a nie wan. Jak masz czyste openwrt to musisz pingowować dany interfejs i jak nie ma odpowiedzi to wykonywać skrypt od połączenia (np. qmi.sh)

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

238 (edytowany przez Sigma 2014-08-07 17:20:32)

Odp: Nowe wersje skryptów HSO, NDIS i QMI dla modemów 3G/LTE

Wgrałem eksperymentalnie BB i postawić na nogi połączenia przez qmi nie mogę. Wrzucam sekcję wan z proto qmi, daję ifup wan i.... cisza. Logread pusty, połączenia nie zestawia...

QMI działa poprawnie, bo połączenie zestawione starym skryptem działa jak trzeba.

OpenWrt 19.07-SNAPSHOT: EA6350v3 || OpenWrt 18.06-SNAPSHOT: SR3200/R6220 || W szufladzie: WNDR4300/TL-WDR4300/WT3020H

239

Odp: Nowe wersje skryptów HSO, NDIS i QMI dla modemów 3G/LTE

Zrestartowałeś router? Bo netifd będzie widział nowy protokół dopiero po restarcie. I czy uqmi zainstalowałeś z repo trunka czy mojego AA?

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

240 (edytowany przez Sigma 2014-08-07 19:31:54)

Odp: Nowe wersje skryptów HSO, NDIS i QMI dla modemów 3G/LTE

src/gz barrier_breaker http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages
src/gz eko1 http://dl.eko.one.pl/barrier_breaker/ar71xx/packages

Wygląda mi to na repo trunka smile Spróbuje jeszcze raz to zestawić i zrestartować. I zobaczymy. btw. Obraz sporo zmalał, można by się pokusić o uqmi i sterownik od razu w obrazie w kolejnych wersjach smile

OpenWrt 19.07-SNAPSHOT: EA6350v3 || OpenWrt 18.06-SNAPSHOT: SR3200/R6220 || W szufladzie: WNDR4300/TL-WDR4300/WT3020H

241

Odp: Nowe wersje skryptów HSO, NDIS i QMI dla modemów 3G/LTE

Dla czystych obrazów BB? Nie, czemu miał by się tam znaleźć?

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

242

Odp: Nowe wersje skryptów HSO, NDIS i QMI dla modemów 3G/LTE

Cezary napisał/a:

Dla czystych obrazów BB? Nie, czemu miał by się tam znaleźć?

No nie, w Twoich obrazach LuCI smile Z tego co pamiętam, to wcześniej też były trochę zmodyfikowane względem oryginału smile

A wracając do meritum. Nic z tego. Logread po restarcie:

Thu Aug  7 19:17:24 2014 kern.err kernel: [    8.100000] sd 2:0:0:0: [sdb] No Caching mode page found
Thu Aug  7 19:17:24 2014 kern.err kernel: [    8.110000] sd 2:0:0:0: [sdb] Assuming drive cache: write through
Thu Aug  7 19:17:24 2014 kern.err kernel: [    8.120000] sd 2:0:0:0: [sdb] No Caching mode page found
Thu Aug  7 19:17:24 2014 kern.err kernel: [    8.120000] sd 2:0:0:0: [sdb] Assuming drive cache: write through
Thu Aug  7 19:17:24 2014 kern.info kernel: [    8.490000]  sdb: sdb1
Thu Aug  7 19:17:24 2014 kern.err kernel: [    8.500000] sd 2:0:0:0: [sdb] No Caching mode page found
Thu Aug  7 19:17:24 2014 kern.err kernel: [    8.500000] sd 2:0:0:0: [sdb] Assuming drive cache: write through
Thu Aug  7 19:17:24 2014 kern.notice kernel: [    8.510000] sd 2:0:0:0: [sdb] Attached SCSI disk
Thu Aug  7 19:17:24 2014 kern.notice kernel: [    9.750000] jffs2: notice: (438) jffs2_build_xattr_subsystem: complete building xattr subsystem, 1 of xdatum (1 unchecked, 0 orphan) and 42 of xref (0 dead, 17 orphan) found.
Thu Aug  7 19:17:24 2014 kern.notice kernel: [    9.820000] jffs2: notice: (435) jffs2_build_xattr_subsystem: complete building xattr subsystem, 1 of xdatum (1 unchecked, 0 orphan) and 42 of xref (0 dead, 17 orphan) found.
Thu Aug  7 19:17:24 2014 kern.info kernel: [    9.860000] eth0: link down
Thu Aug  7 19:17:24 2014 kern.info kernel: [   13.420000] NET: Registered protocol family 10
Thu Aug  7 19:17:24 2014 kern.info kernel: [   13.450000] l2tp_core: L2TP core driver, V2.0
Thu Aug  7 19:17:24 2014 kern.info kernel: [   13.450000] l2tp_netlink: L2TP netlink interface
Thu Aug  7 19:17:24 2014 kern.info kernel: [   13.470000] gre: GRE over IPv4 demultiplexor driver
Thu Aug  7 19:17:24 2014 kern.info kernel: [   13.490000] ip_gre: GRE over IPv4 tunneling driver
Thu Aug  7 19:17:24 2014 kern.info kernel: [   13.510000] nf_conntrack version 0.5.0 (1974 buckets, 7896 max)
Thu Aug  7 19:17:24 2014 kern.info kernel: [   13.530000] ip6_tables: (C) 2000-2006 Netfilter Core Team
Thu Aug  7 19:17:24 2014 kern.info kernel: [   13.550000] Loading modules backported from Linux version master-2014-05-22-0-gf2032ea
Thu Aug  7 19:17:24 2014 kern.info kernel: [   13.560000] Backport generated by backports.git backports-20140320-37-g5c33da0
Thu Aug  7 19:17:24 2014 kern.info kernel: [   13.660000] cfg80211: Calling CRDA to update world regulatory domain
Thu Aug  7 19:17:24 2014 kern.info kernel: [   13.660000] cfg80211: World regulatory domain updated:
Thu Aug  7 19:17:24 2014 kern.info kernel: [   13.670000] cfg80211:  DFS Master region: unset
Thu Aug  7 19:17:24 2014 kern.info kernel: [   13.670000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
Thu Aug  7 19:17:24 2014 kern.info kernel: [   13.680000] cfg80211:   (2400000 KHz - 2483000 KHz @ 40000 KHz), (N/A, 3000 mBm), (N/A)
Thu Aug  7 19:17:24 2014 kern.info kernel: [   13.690000] cfg80211:   (5140000 KHz - 5860000 KHz @ 40000 KHz), (N/A, 3000 mBm), (N/A)
Thu Aug  7 19:17:24 2014 kern.info kernel: [   13.780000] u32 classifier
Thu Aug  7 19:17:24 2014 kern.info kernel: [   13.780000]     input device check on
Thu Aug  7 19:17:24 2014 kern.info kernel: [   13.790000]     Actions configured
Thu Aug  7 19:17:24 2014 kern.info kernel: [   13.800000] Mirror/redirect action on
Thu Aug  7 19:17:24 2014 kern.info kernel: [   13.820000] fuse init (API version 7.22)
Thu Aug  7 19:17:24 2014 kern.info kernel: [   13.890000] usbcore: registered new interface driver cdc_acm
Thu Aug  7 19:17:24 2014 kern.info kernel: [   13.890000] cdc_acm: USB Abstract Control Model driver for USB modems and ISDN adapters
Thu Aug  7 19:17:24 2014 kern.info kernel: [   13.910000] usbcore: registered new interface driver cdc_wdm
Thu Aug  7 19:17:24 2014 kern.info kernel: [   13.930000] ip_tables: (C) 2000-2006 Netfilter Core Team
Thu Aug  7 19:17:24 2014 kern.info kernel: [   13.990000] usblp 1-1.1.1:1.0: usblp0: USB Bidirectional printer dev 5 if 0 alt 0 proto 2 vid 0x04E8 pid 0x3413
Thu Aug  7 19:17:24 2014 kern.info kernel: [   14.000000] usbcore: registered new interface driver usblp
Thu Aug  7 19:17:24 2014 kern.info kernel: [   14.030000] usbcore: registered new interface driver usbserial
Thu Aug  7 19:17:24 2014 kern.info kernel: [   14.040000] usbcore: registered new interface driver usbserial_generic
Thu Aug  7 19:17:24 2014 kern.info kernel: [   14.040000] usbserial: USB Serial support registered for generic
Thu Aug  7 19:17:24 2014 kern.info kernel: [   14.130000] xt_time: kernel timezone is -0000
Thu Aug  7 19:17:24 2014 kern.info kernel: [   14.150000] usbcore: registered new interface driver cdc_ether
Thu Aug  7 19:17:24 2014 kern.info kernel: [   14.170000] usbcore: registered new interface driver cdc_ncm
Thu Aug  7 19:17:24 2014 kern.info kernel: [   14.190000] PPP generic driver version 2.4.2
Thu Aug  7 19:17:24 2014 kern.info kernel: [   14.210000] PPP MPPE Compression module registered
Thu Aug  7 19:17:24 2014 kern.info kernel: [   14.210000] NET: Registered protocol family 24
Thu Aug  7 19:17:24 2014 kern.info kernel: [   14.220000] PPTP driver version 0.8.5
Thu Aug  7 19:17:24 2014 kern.info kernel: [   14.230000] usbcore: registered new interface driver qmi_wwan
Thu Aug  7 19:17:24 2014 kern.info kernel: [   14.240000] usbcore: registered new interface driver sierra
Thu Aug  7 19:17:24 2014 kern.info kernel: [   14.250000] usbserial: USB Serial support registered for Sierra USB modem
Thu Aug  7 19:17:24 2014 kern.debug kernel: [   14.280000] ath: EEPROM regdomain: 0x0
Thu Aug  7 19:17:24 2014 kern.debug kernel: [   14.280000] ath: EEPROM indicates default country code should be used
Thu Aug  7 19:17:24 2014 kern.debug kernel: [   14.280000] ath: doing EEPROM country->regdmn map search
Thu Aug  7 19:17:24 2014 kern.debug kernel: [   14.280000] ath: country maps to regdmn code: 0x3a
Thu Aug  7 19:17:24 2014 kern.debug kernel: [   14.280000] ath: Country alpha2 being used: US
Thu Aug  7 19:17:24 2014 kern.debug kernel: [   14.280000] ath: Regpair used: 0x3a
Thu Aug  7 19:17:24 2014 kern.debug kernel: [   14.290000] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
Thu Aug  7 19:17:24 2014 kern.info kernel: [   14.300000] cfg80211: Calling CRDA for country: US
Thu Aug  7 19:17:24 2014 kern.info kernel: [   14.310000] ieee80211 phy0: Atheros AR9340 Rev:0 mem=0xb8100000, irq=47
Thu Aug  7 19:17:24 2014 kern.warn kernel: [   14.310000] PCI: Enabling device 0000:00:00.0 (0000 -> 0002)
Thu Aug  7 19:17:24 2014 kern.debug kernel: [   14.330000] ath: EEPROM regdomain: 0x0
Thu Aug  7 19:17:24 2014 kern.debug kernel: [   14.330000] ath: EEPROM indicates default country code should be used
Thu Aug  7 19:17:24 2014 kern.debug kernel: [   14.330000] ath: doing EEPROM country->regdmn map search
Thu Aug  7 19:17:24 2014 kern.debug kernel: [   14.330000] ath: country maps to regdmn code: 0x3a
Thu Aug  7 19:17:24 2014 kern.debug kernel: [   14.330000] ath: Country alpha2 being used: US
Thu Aug  7 19:17:24 2014 kern.debug kernel: [   14.330000] ath: Regpair used: 0x3a
Thu Aug  7 19:17:24 2014 kern.info kernel: [   14.330000] cfg80211: Regulatory domain changed to country: US
Thu Aug  7 19:17:24 2014 kern.info kernel: [   14.340000] cfg80211:  DFS Master region: unset
Thu Aug  7 19:17:24 2014 kern.info kernel: [   14.340000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
Thu Aug  7 19:17:24 2014 kern.info kernel: [   14.350000] cfg80211:   (2400000 KHz - 2483000 KHz @ 40000 KHz), (N/A, 3000 mBm), (N/A)
Thu Aug  7 19:17:24 2014 kern.info kernel: [   14.360000] cfg80211:   (5140000 KHz - 5860000 KHz @ 40000 KHz), (N/A, 3000 mBm), (N/A)
Thu Aug  7 19:17:24 2014 kern.debug kernel: [   14.370000] ieee80211 phy1: Selected rate control algorithm 'minstrel_ht'
Thu Aug  7 19:17:24 2014 kern.info kernel: [   14.380000] ieee80211 phy1: Atheros AR9300 Rev:4 mem=0xb0000000, irq=40
Thu Aug  7 19:17:24 2014 kern.info kernel: [   14.390000] l2tp_ppp: PPPoL2TP kernel driver, V2.0
Thu Aug  7 19:17:24 2014 kern.info kernel: [   14.400000] usbcore: registered new interface driver option
Thu Aug  7 19:17:24 2014 kern.info kernel: [   14.410000] usbserial: USB Serial support registered for GSM modem (1-port)
Thu Aug  7 19:17:24 2014 kern.info kernel: [   14.610000] EXT4-fs (sdb1): mounted filesystem with ordered data mode. Opts:
Thu Aug  7 19:17:25 2014 user.emerg syslog: Error: Failed to connect to ubus
Thu Aug  7 19:17:27 2014 user.emerg syslog: this file has been obseleted. please call "/sbin/block mount" directly
Thu Aug  7 19:17:27 2014 kern.info kernel: [   19.610000] usb 1-1.2: USB disconnect, device number 4
Thu Aug  7 19:17:28 2014 user.err syslog: /dev/mtdblock3 is already mounted
Thu Aug  7 19:17:28 2014 user.err syslog: /dev/sdb1 is already mounted
Thu Aug  7 19:17:28 2014 user.emerg syslog: block: /dev/mtdblock3 is already mounted
Thu Aug  7 19:17:28 2014 user.emerg syslog: block: /dev/sdb1 is already mounted
Thu Aug  7 19:17:30 2014 kern.info kernel: [   22.400000] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
Thu Aug  7 19:17:30 2014 kern.info kernel: [   22.400000] IPv6: ADDRCONF(NETDEV_UP): eth0.1: link is not ready
Thu Aug  7 19:17:30 2014 kern.info kernel: [   22.420000] device eth0.1 entered promiscuous mode
Thu Aug  7 19:17:30 2014 kern.info kernel: [   22.420000] device eth0 entered promiscuous mode
Thu Aug  7 19:17:30 2014 daemon.notice netifd: Interface 'lan' is enabled
Thu Aug  7 19:17:30 2014 daemon.notice netifd: Interface 'lan' is setting up now
Thu Aug  7 19:17:30 2014 daemon.notice netifd: Interface 'lan' is now up
Thu Aug  7 19:17:30 2014 kern.info kernel: [   22.440000] IPv6: ADDRCONF(NETDEV_UP): br-lan: link is not ready
Thu Aug  7 19:17:30 2014 daemon.notice netifd: Interface 'loopback' is enabled
Thu Aug  7 19:17:30 2014 daemon.notice netifd: Interface 'loopback' is setting up now
Thu Aug  7 19:17:30 2014 daemon.notice netifd: Interface 'loopback' is now up
Thu Aug  7 19:17:30 2014 daemon.notice netifd: Network device 'lo' link is up
Thu Aug  7 19:17:30 2014 daemon.notice netifd: Interface 'loopback' has link connectivity
Thu Aug  7 19:17:31 2014 kern.info kernel: [   23.590000] cfg80211: Calling CRDA for country: PL
Thu Aug  7 19:17:31 2014 kern.info kernel: [   23.590000] cfg80211: Regulatory domain changed to country: PL
Thu Aug  7 19:17:31 2014 kern.info kernel: [   23.600000] cfg80211:  DFS Master region: ETSI
Thu Aug  7 19:17:31 2014 kern.info kernel: [   23.600000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
Thu Aug  7 19:17:31 2014 kern.info kernel: [   23.610000] cfg80211:   (2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
Thu Aug  7 19:17:31 2014 kern.info kernel: [   23.620000] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
Thu Aug  7 19:17:31 2014 kern.info kernel: [   23.630000] cfg80211:   (5250000 KHz - 5330000 KHz @ 80000 KHz), (N/A, 2000 mBm), (0 s)
Thu Aug  7 19:17:31 2014 kern.info kernel: [   23.640000] cfg80211:   (5490000 KHz - 5710000 KHz @ 80000 KHz), (N/A, 2700 mBm), (0 s)
Thu Aug  7 19:17:31 2014 kern.info kernel: [   23.650000] cfg80211:   (57240000 KHz - 65880000 KHz @ 2160000 KHz), (N/A, 4000 mBm), (N/A)
Thu Aug  7 19:17:32 2014 authpriv.warn dropbear[1449]: Failed listening on '22': Error listening: Cannot assign requested address
Thu Aug  7 19:17:32 2014 authpriv.info dropbear[1449]: Not backgrounding
Thu Aug  7 19:17:32 2014 kern.info kernel: [   24.240000] eth0: link up (1000Mbps/Full duplex)
Thu Aug  7 19:17:32 2014 kern.info kernel: [   24.260000] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
Thu Aug  7 19:17:32 2014 daemon.notice netifd: Network device 'eth0' link is up
Thu Aug  7 19:17:32 2014 daemon.notice netifd: VLAN 'eth0.1' link is up
Thu Aug  7 19:17:32 2014 kern.info kernel: [   24.290000] br-lan: port 1(eth0.1) entered forwarding state
Thu Aug  7 19:17:32 2014 kern.info kernel: [   24.290000] br-lan: port 1(eth0.1) entered forwarding state
Thu Aug  7 19:17:32 2014 kern.info kernel: [   24.300000] IPv6: ADDRCONF(NETDEV_CHANGE): eth0.1: link becomes ready
Thu Aug  7 19:17:32 2014 kern.info kernel: [   24.310000] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
Thu Aug  7 19:17:32 2014 daemon.notice netifd: Bridge 'br-lan' link is up
Thu Aug  7 19:17:32 2014 daemon.notice netifd: Interface 'lan' has link connectivity
Thu Aug  7 19:17:32 2014 user.notice firewall: Reloading firewall due to ifup of lan (br-lan)
Thu Aug  7 19:17:34 2014 kern.info kernel: [   26.030000] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Thu Aug  7 19:17:34 2014 kern.info kernel: [   26.040000] device wlan0 entered promiscuous mode
Thu Aug  7 19:17:34 2014 kern.info kernel: [   26.150000] IPv6: ADDRCONF(NETDEV_UP): wlan1: link is not ready
Thu Aug  7 19:17:34 2014 kern.info kernel: [   26.180000] device wlan1 entered promiscuous mode
Thu Aug  7 19:17:34 2014 kern.info kernel: [   26.190000] br-lan: port 3(wlan1) entered forwarding state
Thu Aug  7 19:17:34 2014 kern.info kernel: [   26.190000] br-lan: port 3(wlan1) entered forwarding state
Thu Aug  7 19:17:34 2014 kern.info kernel: [   26.290000] br-lan: port 1(eth0.1) entered forwarding state
Thu Aug  7 19:17:35 2014 user.info syslog: module is already loaded - xt_comment
Thu Aug  7 19:17:35 2014 kern.emerg already loaded - xt_comment
Thu Aug  7 19:17:35 2014 kern.info kernel: [   27.040000] br-lan: port 3(wlan1) entered disabled state
Thu Aug  7 19:17:35 2014 kern.info kernel: [   27.420000] br-lan: port 3(wlan1) entered forwarding state
Thu Aug  7 19:17:35 2014 kern.info kernel: [   27.430000] br-lan: port 3(wlan1) entered forwarding state
Thu Aug  7 19:17:35 2014 kern.info kernel: [   27.440000] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready
Thu Aug  7 19:17:35 2014 daemon.notice netifd: Network device 'wlan1' link is up
Thu Aug  7 19:17:36 2014 user.info syslog: module is already loaded - xt_comment
Thu Aug  7 19:17:36 2014 kern.emerg already loaded - xt_comment
Thu Aug  7 19:17:37 2014 kern.info kernel: [   29.230000] usb 1-1.2: new high-speed USB device number 7 using ehci-platform
Thu Aug  7 19:17:37 2014 kern.info kernel: [   29.430000] br-lan: port 3(wlan1) entered forwarding state
Thu Aug  7 19:17:37 2014 kern.info kernel: [   29.520000] option 1-1.2:1.0: GSM modem (1-port) converter detected
Thu Aug  7 19:17:37 2014 kern.info kernel: [   29.520000] usb 1-1.2: GSM modem (1-port) converter now attached to ttyUSB0
Thu Aug  7 19:17:37 2014 kern.info kernel: [   29.530000] option 1-1.2:1.1: GSM modem (1-port) converter detected
Thu Aug  7 19:17:37 2014 kern.info kernel: [   29.560000] usb 1-1.2: GSM modem (1-port) converter now attached to ttyUSB1
Thu Aug  7 19:17:37 2014 kern.info kernel: [   29.570000] option 1-1.2:1.2: GSM modem (1-port) converter detected
Thu Aug  7 19:17:37 2014 kern.info kernel: [   29.610000] usb 1-1.2: GSM modem (1-port) converter now attached to ttyUSB2
Thu Aug  7 19:17:37 2014 kern.info kernel: [   29.630000] qmi_wwan 1-1.2:1.3: cdc-wdm0: USB WDM device
Thu Aug  7 19:17:37 2014 kern.info kernel: [   29.630000] qmi_wwan 1-1.2:1.3 wwan0: register 'qmi_wwan' at usb-ehci-platform-1.2, WWAN/QMI device, 00:a0:c6:00:00:00
Thu Aug  7 19:17:39 2014 daemon.info dnsmasq[1958]: started, version 2.71 cachesize 150
Thu Aug  7 19:17:39 2014 daemon.info dnsmasq[1958]: compile time options: IPv6 GNU-getopt no-DBus no-i18n no-IDN DHCP no-DHCPv6 no-Lua TFTP no-conntrack no-ipset no-auth no-DNSSEC
Thu Aug  7 19:17:39 2014 daemon.info dnsmasq-dhcp[1958]: DHCP, IP range 192.168.1.100 -- 192.168.1.249, lease time 12h
Thu Aug  7 19:17:39 2014 daemon.info dnsmasq[1958]: using local addresses only for domain lan
Thu Aug  7 19:17:39 2014 daemon.warn dnsmasq[1958]: no servers found in /tmp/resolv.conf.auto, will retry
Thu Aug  7 19:17:39 2014 daemon.info dnsmasq[1958]: read /etc/hosts - 1 addresses
Thu Aug  7 19:17:39 2014 daemon.info dnsmasq-dhcp[1958]: read /etc/ethers - 0 addresses
Thu Aug  7 19:17:40 2014 daemon.crit xl2tpd[2013]: setsockopt recvref[30]: Protocol not available
Thu Aug  7 19:17:40 2014 daemon.info xl2tpd[2013]: Using l2tp kernel support.
Thu Aug  7 19:17:40 2014 daemon.info xl2tpd[2015]: xl2tpd version xl2tpd-1.3.6 started on WDR4300 PID:2015
Thu Aug  7 19:17:40 2014 daemon.info xl2tpd[2015]: Written by Mark Spencer, Copyright (C) 1998, Adtran, Inc.
Thu Aug  7 19:17:40 2014 daemon.info xl2tpd[2015]: Forked by Scott Balmos and David Stipp, (C) 2001
Thu Aug  7 19:17:40 2014 daemon.info xl2tpd[2015]: Inherited by Jeff McAdams, (C) 2002
Thu Aug  7 19:17:40 2014 daemon.info xl2tpd[2015]: Forked again by Xelerance (www.xelerance.com) (C) 2006
Thu Aug  7 19:17:40 2014 daemon.info xl2tpd[2015]: Listening on IP address 0.0.0.0, port 1701
Thu Aug  7 19:17:41 2014 user.notice upnp daemon: external interface not found, not starting
Thu Aug  7 19:17:43 2014 kern.info kernel: [   35.580000] br-lan: port 2(wlan0) entered forwarding state
Thu Aug  7 19:17:43 2014 kern.info kernel: [   35.590000] br-lan: port 2(wlan0) entered forwarding state
Thu Aug  7 19:17:43 2014 kern.info kernel: [   35.590000] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Thu Aug  7 19:17:44 2014 daemon.notice netifd: Network device 'wlan0' link is up
Thu Aug  7 19:17:45 2014 kern.info kernel: [   37.590000] br-lan: port 2(wlan0) entered forwarding state
Thu Aug  7 19:18:31 2014 user.emerg syslog: setting up led WLAN2G
Thu Aug  7 19:18:31 2014 user.emerg syslog: setting up led WWAN
Thu Aug  7 19:18:31 2014 user.info watchcat: starting all tasks
Thu Aug  7 19:18:31 2014 user.info wathchat: started task (mode=ping;period=21600;pinghosts=8.8.8.8;pingperiod=1080;forcedelay=30)
Thu Aug  7 19:18:31 2014 user.info watchcat: all tasks started
Thu Aug  7 19:18:34 2014 user.emerg syslog: - init complete -
Thu Aug  7 19:18:35 2014 daemon.err transmission-daemon[2588]: UDP Failed to set receive buffer: requested 4194304, got 327680 (tr-udp.c:78)
Thu Aug  7 19:18:35 2014 daemon.err transmission-daemon[2588]: UDP Failed to set send buffer: requested 1048576, got 327680 (tr-udp.c:89)
Thu Aug  7 19:18:37 2014 daemon.info hostapd: wlan1: STA 00:24:d7:84:8a:38 IEEE 802.11: authenticated
Thu Aug  7 19:18:37 2014 daemon.info hostapd: wlan1: STA 00:24:d7:84:8a:38 IEEE 802.11: associated (aid 1)
Thu Aug  7 19:18:37 2014 daemon.info hostapd: wlan1: STA 00:24:d7:84:8a:38 WPA: pairwise key handshake completed (RSN)
Thu Aug  7 19:18:37 2014 daemon.info dnsmasq-dhcp[1958]: DHCPREQUEST(br-lan) 192.168.1.100 00:24:d7:84:8a:38
Thu Aug  7 19:18:37 2014 daemon.info dnsmasq-dhcp[1958]: DHCPACK(br-lan) 192.168.1.100 00:24:d7:84:8a:38 blasse-thinkpad
Thu Aug  7 19:19:29 2014 authpriv.info dropbear[2614]: Child connection from 192.168.1.100:54695
Thu Aug  7 19:19:37 2014 authpriv.notice dropbear[2614]: Password auth succeeded for 'root' from 192.168.1.100:54695

Zawartość pliku /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd86:5252:7535::/48'

config interface 'lan'
        option ifname 'eth0.1'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0t 2 3 4 5'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0t 1'

config interface 'wan'
        option proto 'qmi'
        option device '/dev/cdc-wdm0'
        option apn 'internet'
        option pincode '5888'
        option username 'internet'
        option password 'internet'
        option apn 'internet'

no i zainstalowane pakiety do obsługi qmi

root@WDR4300:~# opkg list-installed | grep qmi
kmod-usb-net-qmi-wwan - 3.10.49-1
uqmi - 2014-05-27-d7a56cad6d6ef3c2a5602fc604e31999eb9e78fa
root@WDR4300:~#

Po wydaniu komendy ifup wan przez ssh w logread nie pojawia się nic nowego.

OpenWrt 19.07-SNAPSHOT: EA6350v3 || OpenWrt 18.06-SNAPSHOT: SR3200/R6220 || W szufladzie: WNDR4300/TL-WDR4300/WT3020H

243

Odp: Nowe wersje skryptów HSO, NDIS i QMI dla modemów 3G/LTE

Wywal na chwilę opcje device, zrestartuj router i uruchom ifup wan. I pokaż logi.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

244

Odp: Nowe wersje skryptów HSO, NDIS i QMI dla modemów 3G/LTE

Po restarcie:

Thu Aug  7 20:31:45 2014 kern.notice kernel: [    9.800000] jffs2: notice: (435) jffs2_build_xattr_subsystem: complete building xattr subsystem, 1 of xdatum (1 unchecked, 0 orphan) and 42 of xref (0 dead, 17 orphan) found.
Thu Aug  7 20:31:45 2014 kern.info kernel: [    9.840000] eth0: link down
Thu Aug  7 20:31:45 2014 kern.info kernel: [   13.260000] NET: Registered protocol family 10
Thu Aug  7 20:31:45 2014 kern.info kernel: [   13.300000] l2tp_core: L2TP core driver, V2.0
Thu Aug  7 20:31:45 2014 kern.info kernel: [   13.300000] l2tp_netlink: L2TP netlink interface
Thu Aug  7 20:31:45 2014 kern.info kernel: [   13.320000] gre: GRE over IPv4 demultiplexor driver
Thu Aug  7 20:31:45 2014 kern.info kernel: [   13.340000] ip_gre: GRE over IPv4 tunneling driver
Thu Aug  7 20:31:45 2014 kern.info kernel: [   13.360000] nf_conntrack version 0.5.0 (1974 buckets, 7896 max)
Thu Aug  7 20:31:45 2014 kern.info kernel: [   13.400000] ip6_tables: (C) 2000-2006 Netfilter Core Team
Thu Aug  7 20:31:45 2014 kern.info kernel: [   13.430000] Loading modules backported from Linux version master-2014-05-22-0-gf2032ea
Thu Aug  7 20:31:45 2014 kern.info kernel: [   13.440000] Backport generated by backports.git backports-20140320-37-g5c33da0
Thu Aug  7 20:31:45 2014 kern.info kernel: [   13.500000] cfg80211: Calling CRDA to update world regulatory domain
Thu Aug  7 20:31:45 2014 kern.info kernel: [   13.500000] cfg80211: World regulatory domain updated:
Thu Aug  7 20:31:45 2014 kern.info kernel: [   13.510000] cfg80211:  DFS Master region: unset
Thu Aug  7 20:31:45 2014 kern.info kernel: [   13.510000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
Thu Aug  7 20:31:45 2014 kern.info kernel: [   13.520000] cfg80211:   (2400000 KHz - 2483000 KHz @ 40000 KHz), (N/A, 3000 mBm), (N/A)
Thu Aug  7 20:31:45 2014 kern.info kernel: [   13.530000] cfg80211:   (5140000 KHz - 5860000 KHz @ 40000 KHz), (N/A, 3000 mBm), (N/A)
Thu Aug  7 20:31:45 2014 kern.info kernel: [   13.630000] u32 classifier
Thu Aug  7 20:31:45 2014 kern.info kernel: [   13.630000]     input device check on
Thu Aug  7 20:31:45 2014 kern.info kernel: [   13.640000]     Actions configured
Thu Aug  7 20:31:45 2014 kern.info kernel: [   13.650000] Mirror/redirect action on
Thu Aug  7 20:31:45 2014 kern.info kernel: [   13.670000] fuse init (API version 7.22)
Thu Aug  7 20:31:45 2014 kern.info kernel: [   13.900000] usbcore: registered new interface driver cdc_acm
Thu Aug  7 20:31:45 2014 kern.info kernel: [   13.910000] cdc_acm: USB Abstract Control Model driver for USB modems and ISDN adapters
Thu Aug  7 20:31:45 2014 kern.info kernel: [   13.930000] usbcore: registered new interface driver cdc_wdm
Thu Aug  7 20:31:45 2014 kern.info kernel: [   13.940000] ip_tables: (C) 2000-2006 Netfilter Core Team
Thu Aug  7 20:31:45 2014 kern.info kernel: [   13.980000] usblp 1-1.1.1:1.0: usblp0: USB Bidirectional printer dev 5 if 0 alt 0 proto 2 vid 0x04E8 pid 0x3413
Thu Aug  7 20:31:45 2014 kern.info kernel: [   14.000000] usbcore: registered new interface driver usblp
Thu Aug  7 20:31:45 2014 kern.info kernel: [   14.020000] usbcore: registered new interface driver usbserial
Thu Aug  7 20:31:45 2014 kern.info kernel: [   14.040000] usbcore: registered new interface driver usbserial_generic
Thu Aug  7 20:31:45 2014 kern.info kernel: [   14.040000] usbserial: USB Serial support registered for generic
Thu Aug  7 20:31:45 2014 kern.info kernel: [   14.100000] xt_time: kernel timezone is -0000
Thu Aug  7 20:31:45 2014 kern.info kernel: [   14.120000] usbcore: registered new interface driver cdc_ether
Thu Aug  7 20:31:45 2014 kern.info kernel: [   14.140000] usbcore: registered new interface driver cdc_ncm
Thu Aug  7 20:31:45 2014 kern.info kernel: [   14.160000] PPP generic driver version 2.4.2
Thu Aug  7 20:31:45 2014 kern.info kernel: [   14.180000] PPP MPPE Compression module registered
Thu Aug  7 20:31:45 2014 kern.info kernel: [   14.180000] NET: Registered protocol family 24
Thu Aug  7 20:31:45 2014 kern.info kernel: [   14.190000] PPTP driver version 0.8.5
Thu Aug  7 20:31:45 2014 kern.info kernel: [   14.200000] usbcore: registered new interface driver qmi_wwan
Thu Aug  7 20:31:45 2014 kern.info kernel: [   14.210000] usbcore: registered new interface driver sierra
Thu Aug  7 20:31:45 2014 kern.info kernel: [   14.210000] usbserial: USB Serial support registered for Sierra USB modem
Thu Aug  7 20:31:45 2014 kern.debug kernel: [   14.250000] ath: EEPROM regdomain: 0x0
Thu Aug  7 20:31:45 2014 kern.debug kernel: [   14.250000] ath: EEPROM indicates default country code should be used
Thu Aug  7 20:31:45 2014 kern.debug kernel: [   14.250000] ath: doing EEPROM country->regdmn map search
Thu Aug  7 20:31:45 2014 kern.debug kernel: [   14.250000] ath: country maps to regdmn code: 0x3a
Thu Aug  7 20:31:45 2014 kern.debug kernel: [   14.250000] ath: Country alpha2 being used: US
Thu Aug  7 20:31:45 2014 kern.debug kernel: [   14.250000] ath: Regpair used: 0x3a
Thu Aug  7 20:31:45 2014 kern.debug kernel: [   14.260000] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
Thu Aug  7 20:31:45 2014 kern.info kernel: [   14.260000] cfg80211: Calling CRDA for country: US
Thu Aug  7 20:31:45 2014 kern.info kernel: [   14.270000] cfg80211: Regulatory domain changed to country: US
Thu Aug  7 20:31:45 2014 kern.info kernel: [   14.280000] cfg80211:  DFS Master region: unset
Thu Aug  7 20:31:45 2014 kern.info kernel: [   14.280000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
Thu Aug  7 20:31:45 2014 kern.info kernel: [   14.290000] cfg80211:   (2400000 KHz - 2483000 KHz @ 40000 KHz), (N/A, 3000 mBm), (N/A)
Thu Aug  7 20:31:45 2014 kern.info kernel: [   14.300000] cfg80211:   (5140000 KHz - 5860000 KHz @ 40000 KHz), (N/A, 3000 mBm), (N/A)
Thu Aug  7 20:31:45 2014 kern.info kernel: [   14.310000] ieee80211 phy0: Atheros AR9340 Rev:0 mem=0xb8100000, irq=47
Thu Aug  7 20:31:45 2014 kern.warn kernel: [   14.320000] PCI: Enabling device 0000:00:00.0 (0000 -> 0002)
Thu Aug  7 20:31:45 2014 kern.debug kernel: [   14.330000] ath: EEPROM regdomain: 0x0
Thu Aug  7 20:31:45 2014 kern.debug kernel: [   14.330000] ath: EEPROM indicates default country code should be used
Thu Aug  7 20:31:45 2014 kern.debug kernel: [   14.330000] ath: doing EEPROM country->regdmn map search
Thu Aug  7 20:31:45 2014 kern.debug kernel: [   14.330000] ath: country maps to regdmn code: 0x3a
Thu Aug  7 20:31:45 2014 kern.debug kernel: [   14.330000] ath: Country alpha2 being used: US
Thu Aug  7 20:31:45 2014 kern.debug kernel: [   14.330000] ath: Regpair used: 0x3a
Thu Aug  7 20:31:45 2014 kern.debug kernel: [   14.340000] ieee80211 phy1: Selected rate control algorithm 'minstrel_ht'
Thu Aug  7 20:31:45 2014 kern.info kernel: [   14.340000] ieee80211 phy1: Atheros AR9300 Rev:4 mem=0xb0000000, irq=40
Thu Aug  7 20:31:45 2014 kern.info kernel: [   14.360000] l2tp_ppp: PPPoL2TP kernel driver, V2.0
Thu Aug  7 20:31:45 2014 kern.info kernel: [   14.370000] usbcore: registered new interface driver option
Thu Aug  7 20:31:45 2014 kern.info kernel: [   14.370000] usbserial: USB Serial support registered for GSM modem (1-port)
Thu Aug  7 20:31:45 2014 kern.info kernel: [   14.570000] EXT4-fs (sdb1): mounted filesystem with ordered data mode. Opts:
Thu Aug  7 20:31:46 2014 user.emerg syslog: Error: Failed to connect to ubus
Thu Aug  7 20:31:48 2014 user.emerg syslog: this file has been obseleted. please call "/sbin/block mount" directly
Thu Aug  7 20:31:49 2014 user.err syslog: /dev/mtdblock3 is already mounted
Thu Aug  7 20:31:49 2014 user.emerg syslog: block: /dev/mtdblock3 is already mounted
Thu Aug  7 20:31:49 2014 user.err syslog: /dev/sdb1 is already mounted
Thu Aug  7 20:31:49 2014 user.emerg syslog: block: /dev/sdb1 is already mounted
Thu Aug  7 20:31:49 2014 kern.info kernel: [   19.930000] usb 1-1.2: USB disconnect, device number 4
Thu Aug  7 20:31:51 2014 kern.info kernel: [   22.260000] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
Thu Aug  7 20:31:51 2014 kern.info kernel: [   22.270000] IPv6: ADDRCONF(NETDEV_UP): eth0.1: link is not ready
Thu Aug  7 20:31:51 2014 kern.info kernel: [   22.270000] device eth0.1 entered promiscuous mode
Thu Aug  7 20:31:51 2014 kern.info kernel: [   22.280000] device eth0 entered promiscuous mode
Thu Aug  7 20:31:51 2014 daemon.notice netifd: Interface 'lan' is enabled
Thu Aug  7 20:31:51 2014 daemon.notice netifd: Interface 'lan' is setting up now
Thu Aug  7 20:31:51 2014 daemon.notice netifd: Interface 'lan' is now up
Thu Aug  7 20:31:51 2014 kern.info kernel: [   22.290000] IPv6: ADDRCONF(NETDEV_UP): br-lan: link is not ready
Thu Aug  7 20:31:51 2014 daemon.notice netifd: Interface 'loopback' is enabled
Thu Aug  7 20:31:51 2014 daemon.notice netifd: Interface 'loopback' is setting up now
Thu Aug  7 20:31:51 2014 daemon.notice netifd: Interface 'loopback' is now up
Thu Aug  7 20:31:51 2014 daemon.notice netifd: Network device 'lo' link is up
Thu Aug  7 20:31:51 2014 daemon.notice netifd: Interface 'loopback' has link connectivity
Thu Aug  7 20:31:52 2014 kern.info kernel: [   23.270000] cfg80211: Calling CRDA for country: PL
Thu Aug  7 20:31:52 2014 kern.info kernel: [   23.310000] cfg80211: Regulatory domain changed to country: PL
Thu Aug  7 20:31:52 2014 kern.info kernel: [   23.320000] cfg80211:  DFS Master region: ETSI
Thu Aug  7 20:31:52 2014 kern.info kernel: [   23.320000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
Thu Aug  7 20:31:52 2014 kern.info kernel: [   23.330000] cfg80211:   (2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
Thu Aug  7 20:31:52 2014 kern.info kernel: [   23.340000] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
Thu Aug  7 20:31:52 2014 kern.info kernel: [   23.350000] cfg80211:   (5250000 KHz - 5330000 KHz @ 80000 KHz), (N/A, 2000 mBm), (0 s)
Thu Aug  7 20:31:52 2014 kern.info kernel: [   23.360000] cfg80211:   (5490000 KHz - 5710000 KHz @ 80000 KHz), (N/A, 2700 mBm), (0 s)
Thu Aug  7 20:31:52 2014 kern.info kernel: [   23.360000] cfg80211:   (57240000 KHz - 65880000 KHz @ 2160000 KHz), (N/A, 4000 mBm), (N/A)
Thu Aug  7 20:31:53 2014 authpriv.warn dropbear[1471]: Failed listening on '22': Error listening: Cannot assign requested address
Thu Aug  7 20:31:53 2014 authpriv.info dropbear[1471]: Not backgrounding
Thu Aug  7 20:31:53 2014 kern.info kernel: [   24.100000] eth0: link up (1000Mbps/Full duplex)
Thu Aug  7 20:31:53 2014 daemon.notice netifd: Network device 'eth0' link is up
Thu Aug  7 20:31:53 2014 daemon.notice netifd: VLAN 'eth0.1' link is up
Thu Aug  7 20:31:53 2014 kern.info kernel: [   24.120000] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
Thu Aug  7 20:31:53 2014 kern.info kernel: [   24.120000] br-lan: port 1(eth0.1) entered forwarding state
Thu Aug  7 20:31:53 2014 kern.info kernel: [   24.130000] br-lan: port 1(eth0.1) entered forwarding state
Thu Aug  7 20:31:53 2014 kern.info kernel: [   24.130000] IPv6: ADDRCONF(NETDEV_CHANGE): eth0.1: link becomes ready
Thu Aug  7 20:31:53 2014 daemon.notice netifd: Bridge 'br-lan' link is up
Thu Aug  7 20:31:53 2014 daemon.notice netifd: Interface 'lan' has link connectivity
Thu Aug  7 20:31:53 2014 kern.info kernel: [   24.160000] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
Thu Aug  7 20:31:54 2014 user.notice firewall: Reloading firewall due to ifup of lan (br-lan)
Thu Aug  7 20:31:54 2014 kern.info kernel: [   25.280000] IPv6: ADDRCONF(NETDEV_UP): wlan1: link is not ready
Thu Aug  7 20:31:54 2014 kern.info kernel: [   25.320000] device wlan1 entered promiscuous mode
Thu Aug  7 20:31:54 2014 kern.info kernel: [   25.320000] br-lan: port 2(wlan1) entered forwarding state
Thu Aug  7 20:31:54 2014 kern.info kernel: [   25.330000] br-lan: port 2(wlan1) entered forwarding state
Thu Aug  7 20:31:54 2014 kern.info kernel: [   25.350000] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Thu Aug  7 20:31:54 2014 kern.info kernel: [   25.380000] device wlan0 entered promiscuous mode
Thu Aug  7 20:31:54 2014 kern.info kernel: [   25.390000] br-lan: port 3(wlan0) entered forwarding state
Thu Aug  7 20:31:54 2014 kern.info kernel: [   25.390000] br-lan: port 3(wlan0) entered forwarding state
Thu Aug  7 20:31:54 2014 kern.info kernel: [   25.420000] br-lan: port 2(wlan1) entered disabled state
Thu Aug  7 20:31:54 2014 kern.info kernel: [   25.430000] br-lan: port 3(wlan0) entered disabled state
Thu Aug  7 20:31:55 2014 kern.info kernel: [   26.130000] br-lan: port 1(eth0.1) entered forwarding state
Thu Aug  7 20:31:56 2014 user.info syslog: module is already loaded - xt_comment
Thu Aug  7 20:31:56 2014 kern.emerg already loaded - xt_comment
Thu Aug  7 20:31:56 2014 user.info syslog: module is already loaded - xt_comment
Thu Aug  7 20:31:56 2014 kern.emerg already loaded - xt_comment
Thu Aug  7 20:31:59 2014 kern.info kernel: [   29.670000] usb 1-1.2: new high-speed USB device number 7 using ehci-platform
Thu Aug  7 20:31:59 2014 kern.info kernel: [   29.850000] option 1-1.2:1.0: GSM modem (1-port) converter detected
Thu Aug  7 20:31:59 2014 kern.info kernel: [   29.870000] usb 1-1.2: GSM modem (1-port) converter now attached to ttyUSB0
Thu Aug  7 20:31:59 2014 kern.info kernel: [   29.910000] option 1-1.2:1.1: GSM modem (1-port) converter detected
Thu Aug  7 20:31:59 2014 kern.info kernel: [   29.910000] usb 1-1.2: GSM modem (1-port) converter now attached to ttyUSB1
Thu Aug  7 20:31:59 2014 kern.info kernel: [   29.960000] option 1-1.2:1.2: GSM modem (1-port) converter detected
Thu Aug  7 20:31:59 2014 kern.info kernel: [   30.010000] usb 1-1.2: GSM modem (1-port) converter now attached to ttyUSB2
Thu Aug  7 20:31:59 2014 kern.info kernel: [   30.030000] qmi_wwan 1-1.2:1.3: cdc-wdm0: USB WDM device
Thu Aug  7 20:31:59 2014 kern.info kernel: [   30.050000] qmi_wwan 1-1.2:1.3 wwan0: register 'qmi_wwan' at usb-ehci-platform-1.2, WWAN/QMI device, 00:a0:c6:00:00:00
Thu Aug  7 20:32:00 2014 daemon.crit xl2tpd[1912]: setsockopt recvref[30]: Protocol not available
Thu Aug  7 20:32:00 2014 daemon.info xl2tpd[1912]: Using l2tp kernel support.
Thu Aug  7 20:32:00 2014 daemon.info xl2tpd[1925]: xl2tpd version xl2tpd-1.3.6 started on WDR4300 PID:1925
Thu Aug  7 20:32:00 2014 daemon.info xl2tpd[1925]: Written by Mark Spencer, Copyright (C) 1998, Adtran, Inc.
Thu Aug  7 20:32:00 2014 daemon.info xl2tpd[1925]: Forked by Scott Balmos and David Stipp, (C) 2001
Thu Aug  7 20:32:00 2014 daemon.info xl2tpd[1925]: Inherited by Jeff McAdams, (C) 2002
Thu Aug  7 20:32:00 2014 daemon.info xl2tpd[1925]: Forked again by Xelerance (www.xelerance.com) (C) 2006
Thu Aug  7 20:32:00 2014 daemon.info xl2tpd[1925]: Listening on IP address 0.0.0.0, port 1701
Thu Aug  7 20:32:00 2014 daemon.info dnsmasq[1914]: started, version 2.71 cachesize 150
Thu Aug  7 20:32:00 2014 daemon.info dnsmasq[1914]: compile time options: IPv6 GNU-getopt no-DBus no-i18n no-IDN DHCP no-DHCPv6 no-Lua TFTP no-conntrack no-ipset no-auth no-DNSSEC
Thu Aug  7 20:32:00 2014 daemon.info dnsmasq-dhcp[1914]: DHCP, IP range 192.168.1.100 -- 192.168.1.249, lease time 12h
Thu Aug  7 20:32:00 2014 daemon.info dnsmasq[1914]: using local addresses only for domain lan
Thu Aug  7 20:32:00 2014 daemon.warn dnsmasq[1914]: no servers found in /tmp/resolv.conf.auto, will retry
Thu Aug  7 20:32:00 2014 daemon.info dnsmasq[1914]: read /etc/hosts - 1 addresses
Thu Aug  7 20:32:00 2014 daemon.info dnsmasq-dhcp[1914]: read /etc/ethers - 0 addresses
Thu Aug  7 20:32:01 2014 user.notice upnp daemon: external interface not found, not starting
Thu Aug  7 20:32:04 2014 kern.info kernel: [   34.800000] br-lan: port 3(wlan0) entered forwarding state
Thu Aug  7 20:32:04 2014 kern.info kernel: [   34.800000] br-lan: port 3(wlan0) entered forwarding state
Thu Aug  7 20:32:04 2014 kern.info kernel: [   34.810000] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Thu Aug  7 20:32:04 2014 daemon.notice netifd: Network device 'wlan0' link is up
Thu Aug  7 20:32:06 2014 kern.info kernel: [   36.800000] br-lan: port 3(wlan0) entered forwarding state
Thu Aug  7 20:32:06 2014 kern.info kernel: [   36.940000] br-lan: port 2(wlan1) entered forwarding state
Thu Aug  7 20:32:06 2014 kern.info kernel: [   36.940000] br-lan: port 2(wlan1) entered forwarding state
Thu Aug  7 20:32:06 2014 kern.info kernel: [   36.950000] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready
Thu Aug  7 20:32:06 2014 daemon.notice netifd: Network device 'wlan1' link is up
Thu Aug  7 20:32:08 2014 kern.info kernel: [   38.940000] br-lan: port 2(wlan1) entered forwarding state
Thu Aug  7 20:32:50 2014 daemon.info hostapd: wlan0: STA 00:21:6a:78:06:e6 IEEE 802.11: authenticated
Thu Aug  7 20:32:50 2014 daemon.info hostapd: wlan0: STA 00:21:6a:78:06:e6 IEEE 802.11: associated (aid 1)
Thu Aug  7 20:32:50 2014 daemon.info hostapd: wlan0: STA 00:21:6a:78:06:e6 WPA: pairwise key handshake completed (RSN)
Thu Aug  7 20:32:50 2014 daemon.info dnsmasq-dhcp[1914]: DHCPREQUEST(br-lan) 192.168.1.140 00:21:6a:78:06:e6
Thu Aug  7 20:32:50 2014 daemon.info dnsmasq-dhcp[1914]: DHCPACK(br-lan) 192.168.1.140 00:21:6a:78:06:e6 magda-dell
Thu Aug  7 20:32:51 2014 user.emerg syslog: setting up led WLAN2G
Thu Aug  7 20:32:51 2014 user.emerg syslog: setting up led WWAN
Thu Aug  7 20:32:51 2014 user.info watchcat: starting all tasks
Thu Aug  7 20:32:51 2014 user.info wathchat: started task (mode=ping;period=21600;pinghosts=8.8.8.8;pingperiod=1080;forcedelay=30)
Thu Aug  7 20:32:51 2014 user.info watchcat: all tasks started
Thu Aug  7 20:32:53 2014 user.emerg syslog: - init complete -
Thu Aug  7 20:32:55 2014 daemon.err transmission-daemon[2571]: UDP Failed to set receive buffer: requested 4194304, got 327680 (tr-udp.c:78)
Thu Aug  7 20:32:55 2014 daemon.err transmission-daemon[2571]: UDP Failed to set send buffer: requested 1048576, got 327680 (tr-udp.c:89)
Thu Aug  7 20:33:15 2014 daemon.info hostapd: wlan1: STA 00:24:d7:84:8a:38 IEEE 802.11: authenticated
Thu Aug  7 20:33:15 2014 daemon.info hostapd: wlan1: STA 00:24:d7:84:8a:38 IEEE 802.11: associated (aid 1)
Thu Aug  7 20:33:15 2014 daemon.info hostapd: wlan1: STA 00:24:d7:84:8a:38 WPA: pairwise key handshake completed (RSN)
Thu Aug  7 20:33:15 2014 daemon.info dnsmasq-dhcp[1914]: DHCPREQUEST(br-lan) 192.168.1.100 00:24:d7:84:8a:38
Thu Aug  7 20:33:15 2014 daemon.info dnsmasq-dhcp[1914]: DHCPACK(br-lan) 192.168.1.100 00:24:d7:84:8a:38 blasse-thinkpad
Thu Aug  7 20:33:34 2014 authpriv.info dropbear[2576]: Child connection from 192.168.1.100:56105
Thu Aug  7 20:33:44 2014 authpriv.notice dropbear[2576]: Password auth succeeded for 'root' from 192.168.1.100:56105

Po ifup wan znów nic....

OpenWrt 19.07-SNAPSHOT: EA6350v3 || OpenWrt 18.06-SNAPSHOT: SR3200/R6220 || W szufladzie: WNDR4300/TL-WDR4300/WT3020H

245

Odp: Nowe wersje skryptów HSO, NDIS i QMI dla modemów 3G/LTE

Masz plik /lib/netifd/proto/qmi.sh?

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

246

Odp: Nowe wersje skryptów HSO, NDIS i QMI dla modemów 3G/LTE

Jest. Ręczna próba opalenia (jeśli ma to jakieś znaczenie) wyrzuca błąd:

/lib/netifd/proto/qmi.sh: .: line 4: can't open '../netifd-proto.sh'
OpenWrt 19.07-SNAPSHOT: EA6350v3 || OpenWrt 18.06-SNAPSHOT: SR3200/R6220 || W szufladzie: WNDR4300/TL-WDR4300/WT3020H

247

Odp: Nowe wersje skryptów HSO, NDIS i QMI dla modemów 3G/LTE

Tak, bo to część podsystemu. To ciekawe czemu Ci tego nie widzi.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

248

Odp: Nowe wersje skryptów HSO, NDIS i QMI dla modemów 3G/LTE

Plik jest na miejscu... I można go ręcznie wywołać.
Gdy wyedytuje qmi.sh i wprowadzę odwołanie z pełną ścieżką do netifd-proto.sh błąd zmienia się na:

/lib/netifd/proto/qmi.sh: line 136: add_protocol: not found
OpenWrt 19.07-SNAPSHOT: EA6350v3 || OpenWrt 18.06-SNAPSHOT: SR3200/R6220 || W szufladzie: WNDR4300/TL-WDR4300/WT3020H

249

Odp: Nowe wersje skryptów HSO, NDIS i QMI dla modemów 3G/LTE

Bo to są tylko funkcje, nic tam w nim masz nie zmieniać.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

250

Odp: Nowe wersje skryptów HSO, NDIS i QMI dla modemów 3G/LTE

And the winner is... smile

Wszystko jasne. Żeby proto qmi działało, potrzebna jest jeszcze jedna magiczna linijka:

        option ifname 'wwan0'
OpenWrt 19.07-SNAPSHOT: EA6350v3 || OpenWrt 18.06-SNAPSHOT: SR3200/R6220 || W szufladzie: WNDR4300/TL-WDR4300/WT3020H