1 (edytowany przez shivy 2014-05-30 00:10:18)

Temat: OpenWRT 12.04 + Luci + UPC Wi-Free

Witam,

Zapewne wiadomo że od jakiegoś czasu UPC wlączyła usługę hot-spotów dla swoich klientów. Czy ktoś z Was próbował łączyć się z siecią UPC Wi-Free jako AP-client z poziomu OpenWRT?

Od wczoraj próbuję z zerowym rezultatem.
Zainstalowałem pakiet wpad ( nie mini ). Wybieram z listy sieci, tą z najmocniejszym zasięgiem, wybieram rodzaj szyfrowania WPA2-EAP. Jako typ autoryzacji ustawiam PEAP MSCHAP2. Dalej podaje swoje dane klienta i hasło.
Łączy z siecią, jednak nie dostaję żadnego IP, po jakiejś chwili rozłącza i tak w kółko.
Próbowałem też na wpa_supplicant, bez zmian.
Także próbowałem wybierać inne sieci, lub w ogóle nie wpisywać nic w pole BSSID - rezultat ten sam, a raczej jego brak.

Te same ustawienia stosuję lącząc się z telefonu z androidem - działa prawidłowo. Wcześniej sprawdzałem na PC z WinXP z domyślnego programu dla kart TP-Linka - także działa. Tylko na OpenWRT nie działa.

Oto wycinek z syslog:

May 28 21:03:55 OpenWrt kern.info kernel: [10704.712000] wlan0: authenticate with c6:27:95:8c:32:e5
May 28 21:03:55 OpenWrt kern.info kernel: [10704.720000] wlan0: send auth to c6:27:95:8c:32:e5 (try 1/3)
May 28 21:03:55 OpenWrt kern.info kernel: [10704.732000] wlan0: authenticated
May 28 21:03:55 OpenWrt kern.info kernel: [10704.740000] wlan0: associate with c6:27:95:8c:32:e5 (try 1/3)
May 28 21:03:55 OpenWrt kern.info kernel: [10704.748000] wlan0: RX AssocResp from c6:27:95:8c:32:e5 (capab=0x1411 status=0 aid=1)
May 28 21:03:55 OpenWrt kern.info kernel: [10704.760000] wlan0: associated
May 28 21:03:55 OpenWrt kern.info kernel: [10705.380000] wlan0: deauthenticated from c6:27:95:8c:32:e5 (Reason: 23)
May 28 21:05:57 OpenWrt kern.info kernel: [10826.636000] wlan0: authenticate with c6:27:95:8c:32:e5
May 28 21:05:57 OpenWrt kern.info kernel: [10826.644000] wlan0: send auth to c6:27:95:8c:32:e5 (try 1/3)
May 28 21:05:57 OpenWrt kern.info kernel: [10826.652000] wlan0: authenticated
May 28 21:05:57 OpenWrt kern.info kernel: [10826.664000] wlan0: associate with c6:27:95:8c:32:e5 (try 1/3)
May 28 21:05:57 OpenWrt kern.info kernel: [10826.672000] wlan0: RX AssocResp from c6:27:95:8c:32:e5 (capab=0x1411 status=0 aid=1)
May 28 21:05:57 OpenWrt kern.info kernel: [10826.684000] wlan0: associated
May 28 21:05:57 OpenWrt kern.info kernel: [10827.300000] wlan0: deauthenticated from c6:27:95:8c:32:e5 (Reason: 23)
May 28 21:07:57 OpenWrt kern.info kernel: [10946.620000] wlan0: authenticate with c6:27:95:8c:32:e5
May 28 21:07:57 OpenWrt kern.info kernel: [10946.628000] wlan0: send auth to c6:27:95:8c:32:e5 (try 1/3)
May 28 21:07:57 OpenWrt kern.info kernel: [10946.636000] wlan0: authenticated
May 28 21:07:57 OpenWrt kern.info kernel: [10946.648000] wlan0: associate with c6:27:95:8c:32:e5 (try 1/3)
May 28 21:07:57 OpenWrt kern.info kernel: [10946.656000] wlan0: RX AssocResp from c6:27:95:8c:32:e5 (capab=0x1411 status=0 aid=1)
May 28 21:07:57 OpenWrt kern.info kernel: [10946.684000] wlan0: associated
May 28 21:07:58 OpenWrt kern.info kernel: [10948.364000] wlan0: deauthenticated from c6:27:95:8c:32:e5 (Reason: 23)

w kółko te same komunikaty się pojawiają w logu.

Probowałem wszystkie metody autoryzacji jakie są dostępne - bez zmian.
Z moją domową siecią Wifi router się lączy bez problemu ( WPA-PSK ). Za bardzo nie wiem gdzie szukać przyczyny...

/etc/config/wireless

config wifi-device 'radio0'
    option type 'mac80211'
    option macaddr '00:22:15:26:bf:f1'
    option country 'PL'
    option channel '1'
    option disabled '0'
    option txpower '20'

config wifi-iface
    option network 'wwan'
    option ssid 'UPC Wi-Free'
    option device 'radio0'
    option mode 'sta'
    option bssid 'C6:27:95:8C:32:E5'
    option encryption 'wpa2'
    option eap_type 'peap'
    option identity '*********'
    option password '*********'

/etc/config/network

...
config interface 'wwan'
    option proto 'dhcp'

Także proszę o pomoc gdyż nie wiem zupełnie co jest grane.

EDIT:
log z ręcznego odpalenia wpa_supplicant który ewidentnie wskazuje ze coś jest nie tak:

root@OpenWrt:/tmp/run# wpa_supplicant -iwlan0 -Dnl80211 -c/var/run/wpa_supplicant-wlan0.conf
Successfully initialized wpa_supplicant
wlan0: SME: Trying to authenticate with 02:26:24:79:2a:e3 (SSID='UPC Wi-Free' freq=2417 MHz)
wlan0: Trying to associate with 02:26:24:79:2a:e3 (SSID='UPC Wi-Free' freq=2417 MHz)
wlan0: Associated with 02:26:24:79:2a:e3
wlan0: CTRL-EVENT-EAP-STARTED EAP authentication started
wlan0: CTRL-EVENT-EAP-PROPOSED-METHOD vendor=0 method=25
TLS: Unsupported Phase2 EAP method 'PAP'
wlan0: CTRL-EVENT-EAP-METHOD EAP vendor 0 method 25 (PEAP) selected
X509: Certificate not valid (now=1401313120 not_before=1383609600 not_after=3599)
wlan0: CTRL-EVENT-EAP-FAILURE EAP authentication failed
wlan0: CTRL-EVENT-DISCONNECTED bssid=02:26:24:79:2a:e3 reason=23
wlan0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="UPC Wi-Free" auth_failures=1 duration=10
wlan0: CTRL-EVENT-SSID-REENABLED id=0 ssid="UPC Wi-Free"
wlan0: SME: Trying to authenticate with 02:26:24:79:2a:e3 (SSID='UPC Wi-Free' freq=2417 MHz)
wlan0: Trying to associate with 02:26:24:79:2a:e3 (SSID='UPC Wi-Free' freq=2417 MHz)
wlan0: Associated with 02:26:24:79:2a:e3
wlan0: CTRL-EVENT-EAP-STARTED EAP authentication started
wlan0: CTRL-EVENT-EAP-STARTED EAP authentication started
wlan0: CTRL-EVENT-EAP-STARTED EAP authentication started
wlan0: CTRL-EVENT-EAP-PROPOSED-METHOD vendor=0 method=25
TLS: Unsupported Phase2 EAP method 'PAP'
wlan0: CTRL-EVENT-EAP-METHOD EAP vendor 0 method 25 (PEAP) selected
X509: Certificate not valid (now=1401313180 not_before=1383609600 not_after=3599)
wlan0: CTRL-EVENT-DISCONNECTED bssid=02:26:24:79:2a:e3 reason=23
wlan0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="UPC Wi-Free" auth_failures=2 duration=20
wlan0: CTRL-EVENT-SSID-REENABLED id=0 ssid="UPC Wi-Free"
wlan0: SME: Trying to authenticate with 02:26:24:79:2a:e3 (SSID='UPC Wi-Free' freq=2417 MHz)
wlan0: Trying to associate with 02:26:24:79:2a:e3 (SSID='UPC Wi-Free' freq=2417 MHz)
wlan0: Associated with 02:26:24:79:2a:e3
wlan0: CTRL-EVENT-EAP-STARTED EAP authentication started
wlan0: CTRL-EVENT-EAP-STARTED EAP authentication started
wlan0: CTRL-EVENT-EAP-STARTED EAP authentication started
wlan0: CTRL-EVENT-EAP-PROPOSED-METHOD vendor=0 method=25
TLS: Unsupported Phase2 EAP method 'PAP'

EDIT:

Problem został już rozwiązany.
Skompilowałem ręcznie paczkę wpa_supplicant dla mojej platformy ustawiając takie opcje:

make menuconfig
Network->wpa_supplicant->Disable timestamp check
Network->wpa_supplicant->Chose TLS provider->openssl

Po zainstalowaniu tego pakietu na openwrt, połączenie z usługą przebiegło bez problemów.

2

Odp: OpenWRT 12.04 + Luci + UPC Wi-Free

U mnie na TPLINK 2543ND zadziałało bez rekompilacji, ale co z tego, gdy i tak przy ściąganiu plików transfer spada do zera. Mniej więcej po 6-10 MB (czyli 30-50 sekund pobierania) pliku jest przycinka i koniec. To samo gdy oglądam coś w sieci. Przy przeglądaniu stron tego nie widać. Robiłem już podbicie TTL ale bez rezultatu. Dziwne jest to, że to nie jest wina ani routera ani openwrt. Na Windows 7, na dwóch różnych kartach mam to samo. Wywala wciąż połączenie. Zastanawiam się czy to wina usługi (może w Opolu to jeszcze nie działa dobrze) czy coś jeszcze powinienem zrobić. Syganł mam 70%-82% więc to też nie powinno być przeszkodą.

3

Odp: OpenWRT 12.04 + Luci + UPC Wi-Free

Ogólnie ta usługa działa póki co beznadziejnie. O ile z transferem nie mam problemów ( jest w miarę stabilny ), o tyle często rozłącza sieć. Ogólnie ograniczenie transferu na usłudze to 3MBit/1MBit down/up, u mnie zwykle dochodzi o 2.5Mbit/0.7Mbit przy dobrej sile sygnału.
Mam problem za to z częstym rozłączaniem. Czasami w ogóle nie chce połączyć. Zresztą UPC Wi-Free przydziela IP tylko na 60 sekund, więc być może dlatego rozłącza, gdyż nie zawsze udaje mu się odnowić adres.
Mam postawiony skrypt który restartuje router w przypadku braku połączenia z internetem, i z tego co widzę to codziennie jest po 2-3 restarty.

Z oficjalnych informacji wiem tylko tyle że pracują nad polepszeniem tej usługi ale kiedy to nastąpi, nikt nie wie. Podobno sprzęt który teraz dają klientom jest słaby i nie radzi sobie. ( jakiś Technicolor ... )

4

Odp: OpenWRT 12.04 + Luci + UPC Wi-Free

No to wszystko jasne. Moje problemy są dokładnie takie same. Dzięki za potwierdzenie. Czekamy więc na lepsze czasy big_smile
dobrego dnia

5

Odp: OpenWRT 12.04 + Luci + UPC Wi-Free

Witam,
czy ktoś pomógłby zrobić to co kolega w pieszym poście mam podobny problem ale nie potrafię zrobić poniższej instrukcji jak wpisze make menuconfig mam odpowiedz:

make: *** No rule to make target `menuconfig'.  Stop.

Będę wdzięczny za pomoc smile


Problem został już rozwiązany.
Skompilowałem ręcznie paczkę wpa_supplicant dla mojej platformy ustawiając takie opcje:
make menuconfig
Network->wpa_supplicant->Disable timestamp check
Network->wpa_supplicant->Chose TLS provider->openssl
Po zainstalowaniu tego pakietu na openwrt, połączenie z usługą przebiegło bez problemów.

Pozdrawiam

6

Odp: OpenWRT 12.04 + Luci + UPC Wi-Free

A gdzie to wykonujesz? Bo powinieneś w głównym katalogu że źródłami.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

7 (edytowany przez rekin32 2014-07-04 13:23:34)

Odp: OpenWRT 12.04 + Luci + UPC Wi-Free

mam rozumieć ze robię wszystko z konsoli czy ręcznie edytuje plik? wpa_supplicant.sh
próbowałem z konsoli /etc/lib/wifi  potem  make menuconfig

8

Odp: OpenWRT 12.04 + Luci + UPC Wi-Free

Nie! Kompilujesz pakiet ze źródeł, nie na routerze tylko na komputerze z linuksem ze źródłami openwrt...

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

9 (edytowany przez rekin32 2014-07-04 13:37:59)

Odp: OpenWRT 12.04 + Luci + UPC Wi-Free

to chyba nie podołam a jest jakaś szansa  żeby połączyć się z upc-free w inny sposób lub jakaś instrukcja jak kompilować to w linuxie?

10

Odp: OpenWRT 12.04 + Luci + UPC Wi-Free

Na eko.one.pl znajdziesz instrukcję.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

11 (edytowany przez smereka 2014-07-09 16:07:52)

Odp: OpenWRT 12.04 + Luci + UPC Wi-Free

Mam skonfigurowane /etc/config/wireless tak:


config wifi-device 'radio0'
    option type 'mac80211'
    option hwmode '11ng'
    option path 'platform/ar934x_wmac'
    option htmode 'HT20'
    list ht_capab 'LDPC'
    list ht_capab 'SHORT-GI-20'
    list ht_capab 'SHORT-GI-40'
    list ht_capab 'TX-STBC'
    list ht_capab 'RX-STBC1'
    list ht_capab 'DSSS_CCK-40'
    option noscan '1'
    option channel '5'

config wifi-device 'radio1'
    option type 'mac80211'
    option channel '36'
    option hwmode '11na'
    option path 'pci0000:00/0000:00:00.0'
    option htmode 'HT20'
    list ht_capab 'LDPC'
    list ht_capab 'SHORT-GI-20'
    list ht_capab 'SHORT-GI-40'
    list ht_capab 'TX-STBC'
    list ht_capab 'RX-STBC1'
    list ht_capab 'DSSS_CCK-40'
    option noscan '1'

config wifi-iface 'stacfg'
    option device 'radio0'
    option mode 'sta'
    option network 'wan'
    option ssid 'UPC Wi-Free'
    option encryption 'wpa2'
    option eap_type 'peap'
    phase2='auth=MSCHAPV2'
    option identity '***********'
    option password '************'

oraz /etc/config/network tak:

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config interface 'lan'
    option ifname 'eth0.1'
    option type 'bridge'
    option proto 'static'
    option netmask '255.255.255.0'
    option dns '192.168.3.1'
    option ipaddr '192.168.3.1'

config interface 'wan'
    option proto 'dhcp'
    option type 'bridge'

config switch
    option name 'eth0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'eth0'
    option vlan '1'
    option ports '0t 2 3 4 5'

config switch_vlan
    option device 'eth0'
    option vlan '2'
    option ports '0t 1'


Nie chce się łączyć z UPC:
Daje mi takie logi:


root@Gargoyle:~# wpa_supplicant -iwlan0 -Dnl80211 -c/var/run/wpa_supplicant-wlan0.conf
Successfully initialized wpa_supplicant
wlan0: SME: Trying to authenticate with 2a:be:9b:d2:f6:24 (SSID='UPC Wi-Free' freq=2412 MHz)
wlan0: Trying to associate with 2a:be:9b:d2:f6:24 (SSID='UPC Wi-Free' freq=2412 MHz)
wlan0: Associated with 2a:be:9b:d2:f6:24
wlan0: CTRL-EVENT-EAP-STARTED EAP authentication started
wlan0: CTRL-EVENT-EAP-PROPOSED-METHOD vendor=0 method=25
wlan0: CTRL-EVENT-EAP-METHOD EAP vendor 0 method 25 (PEAP) selected
X509: Certificate not valid (now=1404913865 not_before=1383609600 not_after=3599)
wlan0: CTRL-EVENT-EAP-FAILURE EAP authentication failed
wlan0: CTRL-EVENT-DISCONNECTED bssid=2a:be:9b:d2:f6:24 reason=23
wlan0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="UPC Wi-Free" auth_failures=1 duration=10
wlan0: CTRL-EVENT-SSID-REENABLED id=0 ssid="UPC Wi-Free"
wlan0: SME: Trying to authenticate with 2a:be:9b:d2:d6:6a (SSID='UPC Wi-Free' freq=2432 MHz)
wlan0: Trying to associate with 2a:be:9b:d2:d6:6a (SSID='UPC Wi-Free' freq=2432 MHz)
wlan0: Associated with 2a:be:9b:d2:d6:6a
wlan0: CTRL-EVENT-EAP-STARTED EAP authentication started
wlan0: CTRL-EVENT-EAP-PROPOSED-METHOD vendor=0 method=25
wlan0: CTRL-EVENT-EAP-METHOD EAP vendor 0 method 25 (PEAP) selected
X509: Certificate not valid (now=1404913876 not_before=1383609600 not_after=3599)
wlan0: CTRL-EVENT-EAP-FAILURE EAP authentication failed
wlan0: CTRL-EVENT-DISCONNECTED bssid=2a:be:9b:d2:d6:6a reason=23
wlan0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="UPC Wi-Free" auth_failures=2 duration=20
wlan0: CTRL-EVENT-SSID-REENABLED id=0 ssid="UPC Wi-Free"
wlan0: SME: Trying to authenticate with 2a:be:9b:d2:d6:6a (SSID='UPC Wi-Free' freq=2432 MHz)
wlan0: Trying to associate with 2a:be:9b:d2:d6:6a (SSID='UPC Wi-Free' freq=2432 MHz)
wlan0: Associated with 2a:be:9b:d2:d6:6a
wlan0: CTRL-EVENT-EAP-STARTED EAP authentication started
^Cwlan0: CTRL-EVENT-DISCONNECTED bssid=2a:be:9b:d2:d6:6a reason=3 locally_generated=1
wlan0: CTRL-EVENT-TERMINATING


Wyżej jest napisane, że trzeba coś kompilować. Można prosić jak krok po kroku się do tego zabrać. Znam strone, która podał cezary ale nie jest tam to zbyt prosto wyjaśnione. Pomożecie? Dziękuję.

12

Odp: OpenWRT 12.04 + Luci + UPC Wi-Free

option eap_type 'peap'
    phase2='auth=MSCHAPV2'
    option identity '***********'

to jest źle. Nie ma czegoś takiego jak  phase2='auth=MSCHAPV2' w konfigu.

Co jest jest prosto opisane w instrukcji kompilacji? Nawet żywcem ctrl-c/ctrl-v możesz zrobić.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

13 (edytowany przez smereka 2014-07-09 16:26:15)

Odp: OpenWRT 12.04 + Luci + UPC Wi-Free

Czyli konfig powinien wyglądać tak:

config wifi-device 'radio0'
    option type 'mac80211'
    option hwmode '11ng'
    option path 'platform/ar934x_wmac'
    option htmode 'HT20'
    list ht_capab 'LDPC'
    list ht_capab 'SHORT-GI-20'
    list ht_capab 'SHORT-GI-40'
    list ht_capab 'TX-STBC'
    list ht_capab 'RX-STBC1'
    list ht_capab 'DSSS_CCK-40'
    option noscan '1'
    option channel '5'

config wifi-device 'radio1'
    option type 'mac80211'
    option channel '36'
    option hwmode '11na'
    option path 'pci0000:00/0000:00:00.0'
    option htmode 'HT20'
    list ht_capab 'LDPC'
    list ht_capab 'SHORT-GI-20'
    list ht_capab 'SHORT-GI-40'
    list ht_capab 'TX-STBC'
    list ht_capab 'RX-STBC1'
    list ht_capab 'DSSS_CCK-40'
    option noscan '1'

config wifi-iface 'stacfg'
    option device 'radio0'
    option mode 'sta'
    option network 'wan'
    option ssid 'UPC Wi-Free'
    option encryption 'wpa2'
    option eap_type 'peap'
    option identity '***********'
    option password '************'

a wpa_supplicant-wlan0.conf w /var/run tak?

ctrl_interface=/var/run/wpa_supplicant-wlan0

network={
   
    scan_ssid=1
    ssid="UPC Wi-Free"
   
    key_mgmt=WPA-EAP
    proto=WPA2
   
    fixed_freq=1
   
   
   
   
   
   
   
   
    eap=PEAP
   
   
    phase2="auth=MSCHAPv2"
   
    identity="***********"
    password="***********"
   
   
   
   
   
}

Nie konfigurowałem nigdy peap w linuksie dlatego wybacz cezary moja niewiedzę. Ucze się i potem już takich pytań nie bezie:)

14

Odp: OpenWRT 12.04 + Luci + UPC Wi-Free

option auth 'MSCHAPV2' zabrakło , choć to jest domyślnie dla peap. wpa_supplicant-wlan0.conf  powstaje automatycznie, a parametry do wifi masz tu: http://wiki.openwrt.org/doc/uci/wireless

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

15 (edytowany przez smereka 2014-07-11 10:55:54)

Odp: OpenWRT 12.04 + Luci + UPC Wi-Free

Zrobiłem jeszcze inny test. Wrzuciłem na wdr3600 soft openwrt luci ten z openwrt.org wywaliłem stamtąd wpad-mini i zainstalowałem recznie wpa-supplicant_20131120-1_ar71xx.ipk czyli tą paczuszkę Cezary od Ciebie i działa łączy z tym całym UPC wi-free. Ale na Twojej Luci za żadne skarby nie chce to działać. Wszystko robiłem tak samo jak na oryginalnym sofcie czyli od razu po zainstalowaniu usunąłem paczkę wpad-mini i zainstalowałem wpa_supplicifant. Status "Nie połączono" i koniec. Znacząco różni się Twój soft od tamtego oryginału? Inne są sterowniki atherosa? Kurcze dłubie dłubie i nie wiem o co chodzi. Wolałbym alby ta cała usługa chodziła na Twoim sofcie bo połączenie jest stabilniejsze jak na moje oko. Co jeszcze mogę zrobić?

16

Odp: OpenWRT 12.04 + Luci + UPC Wi-Free

Takie same, budowane to jest z tego samego źródła.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

17 (edytowany przez Dawid1980 2014-09-20 18:01:33)

Odp: OpenWRT 12.04 + Luci + UPC Wi-Free

Być może ktoś będzie wiedział gdzie tkwi błąd przy łączeniu się z siecią UPC Wi-Free, oto mój config w pliku /etc/config/wireless:


config wifi-device 'radio0'
    option type 'mac80211'
    option hwmode '11ng'
    option path 'pci0000:00/0000:00:00.0'
    option htmode 'HT20'
    list ht_capab 'SHORT-GI-20'
    list ht_capab 'SHORT-GI-40'
    list ht_capab 'TX-STBC'
    list ht_capab 'RX-STBC1'
    list ht_capab 'DSSS_CCK-40'
    option noscan '1'
    option channel '1'

config wifi-iface 'stacfg'
    option device 'radio0'
    option mode 'sta'
    option network 'wan'
    option ssid 'UPC Wi-Free'
    option encryption 'wpa2'
    option eap_type 'peap'
    option auth 'MSCHAPV2'
    option identity '**********'
    option password '**********'

Router TP-Link TL-MR3420 v1 niestety nie nawiązuje połączenia z Internetem, i na WAN-ie nie otrzymuje żadnego adresu IP. Plik wpa_supplicant-wlan0.conf generuje się automatycznie, tak jak pisał wcześniej Cezary, dane logowania (są na pewno dobre gdyż działają na smartphonie i komputerze) i szyfrowanie powinny się zgadzać:

ctrl_interface=/var/run/wpa_supplicant-wlan0

network={
   
    scan_ssid=1
    ssid="UPC Wi-Free"
   
    key_mgmt=WPA-EAP
    proto=WPA2
   
    fixed_freq=1
   
   
   
   
   
   
   
   
    eap=PEAP
   
   
   
   
    phase2="auth=MSCHAPV2"
    identity="********"
    password="********"


Z góry dziękuję za pomoc.

18

Odp: OpenWRT 12.04 + Luci + UPC Wi-Free

Jeżeli chodzi o usługę Wi-Free to jest problem. Niektóre routery mimo że nadają sygnał Wi-free i można się z nimi połączyć nie nawiązują połączenia. Ja tak miałem u siebie. Router z siecią wi-free blisko, sygnał na poziomie 70db, i ciągle albo uwierzytelnianie albo pobieranie ip albo inne kwiatki. Po prostu nadaje sygnał ale nie nadaje internetu. Czasem rozłączając się i łącząc ponownie udawało się połączyć do innego routera który jest dalej, sygnał około 85 db i następuje połączenie. Chociaż teraz z tego co zauważyłem ten router który jest blisko już działa dobrze. Łączy się do niego bez problemu.

Najgorsze jest to rozłączanie. Czasem jednak korzystam z tego Wi-free i wtedy przydaje mi się połączenie na sztywno. Czasem bez przerywania jest to godzina a czasem dwie smile

1. Modem e3131, sieć Aero2  + Router TL-MR3420 Gargoyle 1.6.2.1
2. Modem E3372, sieć CP LTE + Router TL-MR3420 Gargoyle 1.6.2.1

19 (edytowany przez lolkowatylol 2014-10-28 02:25:31)

Odp: OpenWRT 12.04 + Luci + UPC Wi-Free

Przepraszam, że odkopuje, ale bardzo serdecznie proszę o pomoc.
Jak ręcznie skonfigutować tego wpa_supplicant w tak isposób w jaki podał autor.
Pozdrawiam

Posiadam tp link 740n v4.21 openwrt

Jestem zbyt nieogarnięty żeby zrozumieć to chodź próbuje:
http://eko.one.pl/?p=openwrt-kompilacja
a ze strony wiki openwrt to już w ogóle blek medżik

20

Odp: OpenWRT 12.04 + Luci + UPC Wi-Free

Czy jest możliwość aby ktoś wystawił taka skompilowaną paczkę wpa_supplicant skompilowaną z openssl i bez timestamp'ów wspierającą auroryzację do UPC Wi-Free?

Keyboard error or no keyboard present press f1 to continue...

21

Odp: OpenWRT 12.04 + Luci + UPC Wi-Free

To mój pierwszy post na forum, więc witam wszystkich kolegów !


Próbuję się podłączyć do UPC Wi-Free, przy pomocy routera WRTU-54g z wgranym openwrt i mam z tym problem

- wgrałem "Alex's r26444 build includes ipv6, radvd, and luci: ze strony http://wiki.scottn.us/wrtu54g-tm. próbowałem łączyć się z usługą UPC wi-free - nie udaje się.
Zgodnie z radami z forum próbwałem skompilować z wpa_supplicant z openssl i bez timestampów, ale rewizja r26444 nie jest już dostępna w svn

- wgrałem świerzą wersję http://downloads.openwrt.org/attitude_a … 8/generic/  rewizja r35600 i tutaj też zonk.
Zbudowałem wpa-supplicant z openssl i bez timestamów, i podmieniłem to w routerze,  jednak przy łączeniu się do sieci upc wi-free nie mam tam opcji wpa2, tylko to co na dołączonym zrzucie ekranowym

Czy pownienem coś doinstalować/przekompilować, żeby móc uwierzytelniać się przy pomocy wpa2 ?

http://i60.tinypic.com/2cprwhf.png

22

Odp: OpenWRT 12.04 + Luci + UPC Wi-Free

Nadal używasz starej wersji. Przekompiluj sobie 14.07, w gui tryb pracy jako klient najpierw przestaw. A tak poza tym - nie rób tego w luci tylko ręcznie w plikach.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

23

Odp: OpenWRT 12.04 + Luci + UPC Wi-Free

Cezary napisał/a:

Nadal używasz starej wersji. Przekompiluj sobie 14.07, w gui tryb pracy jako klient najpierw przestaw. A tak poza tym - nie rób tego w luci tylko ręcznie w plikach.

a czy 14.07 ma wsparcie dla adm8668 ???

24

Odp: OpenWRT 12.04 + Luci + UPC Wi-Free

Dobry strzał, nie ma smile

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

25

Odp: OpenWRT 12.04 + Luci + UPC Wi-Free

ok, problem rozwiązany:

aby router działał jako klient UPC Wi-Free w przypadku ATTITUDE ADJUSTMENT (12.09, r36088) należy:
* odinstalować wpad
* przekompilować wpa-supplicant z wyłączonymi timestampami i z openssl
* zainstalować wpa-supplicant, zlib, libopenssl

od tego momentu konfiguracja wpa2 będzie możliwa przez luci

dodatkowo jeszcze musiałem stworzyć skrypt modyfikujący dhcp lease time tak aby nie rwało połączenia.


a wszystko to dzięki waszym uwagom z powyższych postów, więc wielkie dzięki ! smile