1 (edytowany przez Cezary 2018-01-20 19:49:11)

Temat: Emoji

Nie wiem czy wiecie, ale nazwa sieci (SSID) nie podlega jakimś specjalnym ograniczeniom jeżeli chodzi o wpisywane symbole. Można podać cokolwiek, inna sprawa że później może być trudno takie coś wyświetlić lub zależy jak to zinterpretuje dany system operacyjny.
W internecie można wszędzie natknąć się na emoji (jak ktoś jest z młodszego pokolenia to wie co chodzi, jak ktoś ze starszego  - niech zapyta się dzieci) czyli po naszemu "emotki". Pierwotnie wyrażały uczucia w tekście pisanym, obecnie chyba żadna wypowiedź nastolatka nie może obyć się bez wstawiania takich znaczków smile . Emotki miały też spopularyzować niektóre komunikatory internetowe lub systemy operacyjne (dzień dobry Apple!).
W kodowaniu UTF8 można znaleźć wiele symboli które są odpowiednikami emotek (kodowane są zwykle na czterech bajtach). Spis niektórych można znaleźć np. tu: http://www.utf8-chartable.de/unicode-ut … art=128512. Zwykle współczesne systemy operacyjne poprawnie wyświetlają takie znaki, więc... czemu by nie ustawić to jako ssid?
W openwrt robimy takie coś:

# uci set wireless.@wifi-iface[0].ssid="$(echo -e '\xf0\x9f\x98\x9d\xf0\x9f\x98\x97\xf0\x9f\x98\xad')"
# uci commit
# wifi

Jak chcemy ustawić inny to należy odszukać odpowiadające znakowi kod hex, umieścić go w echo jako liczby heksadecymalne (czyli \x liczba i tak kolejno), wykonać całość i już. Od systemu zależy jak to zostanie wyświetlone. Moja motorola z Androidem 6 robi to tak:

https://s10.postimg.org/5b3u8lehl/Screenshot_20180119-194947.png

Zaś networkmanager z minta:

https://s10.postimg.org/60mmkymqx/Zrzut_ekranu_z_2018-01-19_19-50-52.png

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

2 (edytowany przez ad2014 2018-01-19 23:46:34)

Odp: Emoji

fajne smile   mała rzecz a cieszy

3

Odp: Emoji

O rany. Nie wiedziałem o takich cudach. Na pewno postaram się zadziwić znajomych big_smile

4

Odp: Emoji

Invalid argument big_smile

5

Odp: Emoji

Pokaż co wykonujesz.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

6 (edytowany przez mar_w 2018-01-20 17:26:22)

Odp: Emoji

założę się, że @Drail miał błąd, bo wpisał przy ssid komendę z echo do pliku /etc/config/wireless:

# cat /etc/config/wireless | grep ssid
    option ssid "$(echo -e '\xf0\x9f\x98\x9d\xf0\x9f\x98\x81\xf0\x9f\x98\xad')"

i wtedy mamy to:

...
daemon.notice hostapd: nl80211: Failed to remove interface wlan0 from bridge br-lan: Invalid argument
...

jak ktoś chce edytować plik przez vi to musi sobie najpierw wygenerować znaki w terminalu:

# echo -e '\xf0\x9f\x98\x9d\xf0\x9f\x98\x81\xf0\x9f\x98\xad'
????????????  #tu są buźki w terminalu :)

potem skopiować same buźki do schowka, wejść przez vi do pliku /etc/config/wireless i wkleić schowek:

 option ssid '............'

tak to będzie wyglądać w vi, zapisać plik i wifi

Matoda Cezarego prostsza, szybsza i bezproblemowa smile

* WR1043v1 16MB@64MB * || * WT3020-16MB * || * Xiaomi Miwifi Mini *
* E3276 HiLink + RTL2832 + IT9135 + Siano + EC103 *

7

Odp: Emoji

Nie. Raczej chodzi o to nie używa openwrt tylko gargoyle, nie ma sekcji default_radio0 tyko ap_g lub jakąś inną nazwę. i bezmyślnie bez zastanowienia skopiował polecenie po prostu.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

8

Odp: Emoji

Oooo Paaaanie .... Super sprawa ! ... somsiadowi oko zbieleje !!!

9

Odp: Emoji

sprawdzone  win10  ok   android  ok  linux ok  win7 wyswietla krzaczki

http://s2.ifotos.pl/mini/xfceEmotp_qxqqhpx.png

http://s6.ifotos.pl/mini/win10Emot_qxqqhpw.png

http://s5.ifotos.pl/mini/ssidemotp_qxqqhpq.png

mozna tez łaczyc  nazwa z emotą

10 (edytowany przez mar_w 2018-01-20 17:49:42)

Odp: Emoji

Cezary,
W każdym bądź razie, ktoś czytając mojego posta będzie wiedział jak nie należy robić.
bo w tym przypadku nie ma znaku równości:

uci set wireless.default_radio0.ssid="$(echo -e....   =//=  vi /etc/config/wireless {opiton ssid "$(echo...  }

w odróżnieniu, gdy nie stosujemy komend w opcjach, tylko same znaki np. [a-zA-Z0-9]

@ad2014
zależy jaki Android. Mój Jelly Bean 4.1.1 nie wyświetla jednej buźki, więc musiałem szukać wśród innych uśmieszków aż trafiłem na taki co jest obsługiwany.

* WR1043v1 16MB@64MB * || * WT3020-16MB * || * Xiaomi Miwifi Mini *
* E3276 HiLink + RTL2832 + IT9135 + Siano + EC103 *

11 (edytowany przez ad2014 2018-01-20 17:57:23)

Odp: Emoji

aa  tak   jak tez  sprawdzałem różne i nie wszystkie   chciały  sie wyswietlac  , przy okazji  oczywiscie pokazuje sie tez w luci 

radio0: Master "???? ???? ???? ???? ????"

na forum  sie nie wyswietlają

12

Odp: Emoji

Coś pięknego smile

13 (edytowany przez jazeck 2018-01-20 19:55:07)

Odp: Emoji

Dajcie info jak to zrobić w graficznym interfejsie na gargoyle, albo konkretniej krok po kroku w putty - jestem leszczem w linuksie, ale mimo to Cezary opisał łopatologicznie krok po kroku jak wrócić z LEDE na inny open i dałem radę.
Tutaj coś robię źle - wpisuję ręcznie w putty
uci: Parse error

14

Odp: Emoji

W pierwszym poście jest. Zrobiłem bardziej uniwersalnie.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

15

Odp: Emoji

Cezary coś mam źle:
Configuration file: /var/run/hostapd-phy0.conf
Using interface wlan0 with hwaddr 10:fe:ed:5b:b0:08 and ssid "OIOMLTE"
wlan0: interface state UNINITIALIZED->ENABLED
wlan0: AP-ENABLED

Nie wyświetla tego co wpisałem z Twojeg kodu.

16

Odp: Emoji

To powtórz to jeszcze raz. Bo chyba nie zapisałeś zmian,

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

17

Odp: Emoji

Hahaha... Masakra Cezary - jesteś mistrzem! Niby wszystko wpisywałem, ale za trzecim razem poszło ,może za szybko chociaż odpowiedzi miałem szybko, albo tak jak w innym poście - mój tl-mr3420 kończy życie? smile

18 (edytowany przez sloniupl 2018-01-20 22:48:57)

Odp: Emoji

U mnie w gargoyle 1.10.0.1 po zmianie nazwy sieci gościnnej na taką z emotkami 2,4GHz przestaje działać (sieć gościnna tylko na 2,4 ustawiona) smile

config wifi-iface 'ap_gn_g'
        option device 'radio1'
        option mode 'ap'
        option network 'lan'
        option disassoc_low_ack '0'
        option is_guest_network '1'
        option macaddr '6a:4e:d9:ed:97:73'
        option ssid '\xf0\x9f\x98\x9d\xf0\x9f\x98\x97\xf0\x9f\x98\xad'
        option isolate '1'
        option encryption 'psk2'
        option key 'haslo'
OpenWRT na TP-LINK Archer C7 v2 | http://blog.sloniupl.eu/

19

Odp: Emoji

Źle to wpisałeś. Wpisz poprawnie ssid jak podałem w pierwszym poście.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

20

Odp: Emoji

Działa dzięki smile

Dla wifi-iface 'ap_gn_g' które było drugie w kolejce wifi-iface w /etc/config/wireless smile

uci set wireless.@wifi-iface[1].ssid="$(echo -e '\xf0\x9f\x98\x9d\xf0\x9f\x98\x97\xf0\x9f\x98\xad')"
uci commit
wifi
OpenWRT na TP-LINK Archer C7 v2 | http://blog.sloniupl.eu/

21

Odp: Emoji

Świetne!
Na maku zrobiłem w terminalu echo -e '\xf0\x9f\x98\x83', a potem w Gargoyle można sobie wkleić z terminala. smile
Dzięki Cezary!

Router: Nexx WT3020 16MB - MiFi 17.01-SNAPSHOT, r3825-28483d4 by obsy
Modem: E3372s-153 Hi-Link mod fw

Router#2: Nexx WT3020 16MB - Gargoyle PL 1.10.0.2 (19bea59) by obsy

22 (edytowany przez Drail 2018-01-21 02:06:08)

Odp: Emoji

mar_w napisał/a:

założę się, że @Drail miał błąd, bo wpisał przy ssid komendę z echo do pliku /etc/config/wireless:

# cat /etc/config/wireless | grep ssid
    option ssid "$(echo -e '\xf0\x9f\x98\x9d\xf0\x9f\x98\x81\xf0\x9f\x98\xad')"

i wtedy mamy to:

...
daemon.notice hostapd: nl80211: Failed to remove interface wlan0 from bridge br-lan: Invalid argument
...

jak ktoś chce edytować plik przez vi to musi sobie najpierw wygenerować znaki w terminalu:

# echo -e '\xf0\x9f\x98\x9d\xf0\x9f\x98\x81\xf0\x9f\x98\xad'
????????????  #tu są buźki w terminalu :)

potem skopiować same buźki do schowka, wejść przez vi do pliku /etc/config/wireless i wkleić schowek:

 option ssid '............'

tak to będzie wyglądać w vi, zapisać plik i wifi

Matoda Cezarego prostsza, szybsza i bezproblemowa smile

Nie, przeklepałem do ssh to co napisał Cezary.

Mam OpenWRT z luci, nie gargoyle. I w sumie nie wiem gdzie był błąd, bo spróbowałem jeszcze raz i zadziałało smile

23

Odp: Emoji

U mnie wszystko ruszyło dobrze. Telefony widzą Emoji, komputery krzaki ale niestety kamera wifi D-LINK widzi sieć, ale po podłączeniu jest brak połączenia. Chyba kamera nie rozgryzła o co chodzi mi z tymi emo smile. A było tak fajnie.

24 (edytowany przez Robstar76 2018-01-23 00:42:31)

Odp: Emoji

Można po prostu wkleić na stronie routera w SSID emotika + nazwa i też działa.
Jedyny problem z połączeń jaki widzę maja urządzenia z Android 4.4

25

Odp: Emoji

Do użytkowników Kindle, próba połączenia PW3 z tak nazwaną siecią zakończyła się blokadą wifi oraz Airplane Mode i finalnie wymagany był reset do ustawień fabrycznych, więc odradzam parowanie tego klienta z takim SSiD.