1 (edytowany przez geos 2018-01-01 00:48:50)

Temat: zrywanie wifi 5GHz

zainstalowałem najnowsze LEDE 17.01.4 i obserwuję, że laptop podczas połączenia do sieci wifi 5GHz często zrywa połączenie i jest to widoczne podczas oglądania filmów z lokalnej kablówki VECTRA udostępniającej telewizję online.

gdy wszystko jest OK to w Luci, Network -> Wireless, kolumna RX rate/TX rate widzę następujące wartości:

300.0 Mbit/s, 40MHz, MCS 15, Short GI
300.0 Mbit/s, 40MHz, MCS 15, Short GI

gdy coś się dzieje i wifi klęka to zmienia się to na takie:

6.0 Mbit/s, 20MHz
300.0 Mbit/s, 40MHz, MCS 15, Short GI

poniżej przedstawiam konfigurację wireless. od czego najlepiej zacząć diagnostykę? w logach nie widzę niczego podejrzanego poza tym (być może takie wpisy są normalne, nie wiem), ruter to WDR4900 v1, LEDE ze strony projektu:

[ 2006.092460] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 2006.099103] br-lan: port 2(wlan0) entered forwarding state
[ 2006.104644] br-lan: port 2(wlan0) entered forwarding state
[ 2008.105498] br-lan: port 2(wlan0) entered forwarding state
[ 2618.285984] device wlan0 left promiscuous mode
[ 2618.290544] br-lan: port 2(wlan0) entered disabled state
[ 2619.052861] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 2619.102876] device wlan0 entered promiscuous mode
[ 2619.107762] br-lan: port 2(wlan0) entered forwarding state
[ 2619.113294] br-lan: port 2(wlan0) entered forwarding state
[ 2619.420481] br-lan: port 2(wlan0) entered disabled state

pozdrawiam
geos

uci show wireless

wireless.radio0=wifi-device
wireless.radio0.path='ffe09000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
wireless.radio0.type='mac80211'
wireless.radio0.hwmode='11a'
wireless.radio0.channel='auto'
wireless.radio0.htmode='HT40'
wireless.radio0.country='PL'
wireless.radio0.txpower='13'

wireless.radio1=wifi-device
wireless.radio1.path='ffe0a000.pcie/pci0001:02/0001:02:00.0/0001:03:00.0'
wireless.radio1.type='mac80211'
wireless.radio1.hwmode='11g'
wireless.radio1.channel='auto'
wireless.radio1.htmode='HT40'
wireless.radio1.country='PL'
wireless.radio1.txpower='13'

wireless.default_radio0=wifi-iface
wireless.default_radio0.device='radio0'
wireless.default_radio0.network='lan'
wireless.default_radio0.mode='ap'
wireless.default_radio0.ssid='domowa-5GHz'
wireless.default_radio0.encryption='psk2+ccmp'
wireless.default_radio0.key='***'
wireless.default_radio0.wmm='1'

wireless.default_radio1=wifi-iface
wireless.default_radio1.device='radio1'
wireless.default_radio1.network='lan'
wireless.default_radio1.mode='ap'
wireless.default_radio1.ssid='domowa'
wireless.default_radio1.encryption='psk2+ccmp'
wireless.default_radio1.key='***'
wireless.default_radio1.wmm='1'

2

Odp: zrywanie wifi 5GHz

Na początek to wywal to "auto" i ustaw jeden konkretny kanał, np. 36. Może być że auto ustawia ci na jeden z kanałów dfs i przełącza się jak ma potrzebę.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

3 (edytowany przez geos 2018-01-01 20:25:58)

Odp: zrywanie wifi 5GHz

dziękuję Cezary. chyba strzeliłeś w 10tkę. zazwyczaj "auto" ustawiało mi kanały powyżej 100. ustawiłem na 44 i jak ręką odjął, nic nie zrywa. przy okazji sprawdziłem listę kanałów:

https://en.wikipedia.org/wiki/List_of_W … /h/j/n/ac)

czy dobrze rozumiem, że w PL to są dostępne tylko 4, które nie wymagają obsługi DFS (36,40,44,48)? czy radary, o których wpominają artykuły o DFS, to są również radary meteo i lotnicze (mieszkam blisko lotniska i stacji meteo z radarem)?

pozdrawiam
geos

4

Odp: zrywanie wifi 5GHz

Tak, to zwłaszcza są radary meteo. Z kanałami jest tak jak piszesz.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

5

Odp: zrywanie wifi 5GHz

dziękuję Cezary! wszystkiego dobrego w nowym roku!