1 (edytowany przez george2002 2017-09-13 00:22:35)

Temat: Problem z dostępem n2n <-> FTP

Witam,
mam problem z dostaniem się do serwera FTP (Zyxel NSA210) poprzez sieć n2n.
Router TL-WR1043ND v4 (wgrane LEDE Reboot 17.01-SNAPSHOT r3466-f6907dc / LuCI lede-17.01 branch (git-17.194.52964-580f012) z modemem Hilink e3372 karta Play - tutaj wszystko ładnie śmiga, bez problemu dostaję się na router poprzez sieć n2n.
Problem jest z dostaniem się do serwera FTP (Zyxel NSA210) który jest podłączony po LAN-ie do routera, jego adres 192.168.2.161, ani w trybie pasywnym ani w aktywnym nie mogę się połączyć, zakładam że coś źle przekierowuję a wygląda to teraz tak w ustawieniach:

config network:

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fdb6:d06a:d0c0::/48'

config interface 'lan'
    option type 'bridge'
    option ifname 'eth0.1'
    option proto 'static'
    option netmask '255.255.255.0'
    option ip6assign '60'
    option ipaddr '192.168.2.1'

config interface 'wan'
    option proto 'dhcp'
    option ifname 'eth1'

config device 'wan_dev'
    option name 'eth0.2'
    option macaddr '84:16:f9:66:40:c9'

config interface 'wan6'
    option ifname 'eth0.2'
    option proto 'dhcpv6'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '1 2 3 4 0t'

config switch_vlan
    option device 'switch0'
    option vlan '2'
    option ports '5 0t'

config interface 'n2n'
    option ifname 'edge0'
    option proto 'static'
    option netmask '255.255.255.0'
    option ipaddr '1.2.3.4' 

config n2n:

config edge
    option netmask '255.255.255.0'
    option port '86'
    option route '1'
    option ipaddr '1.2.3.4'
    option supernode '***'
    option community '***'
    option key '***'

config supernode
    option port '86' 

config firewall.user:

iptables -I FORWARD -i edge0 -p tcp -d 192.168.2.161 --dport 21 -j ACCEPT
iptables -t nat -I PREROUTING -i edge0 -p tcp --dport 21 -j DNAT --to-destination 192.168.1.161:21

Ogólnie łączyć do FTP się łączę ale nie pokazuje nic w katalogu w totalcommanderze (zarówno tryb pasywny jak i aktywny) oto log z połączenia w totalcommanderze:

----------
Connect to: (2017-09-11 10:36:34)
hostname=1.2.3.4
username=aaa
startdir=
1.2.3.4=1.2.3.4
220---------- Welcome to Pure-FTPd [TLS] ----------
220-You are user number 2 of 5 allowed.
220-Local time is now 10:38. Server port: 21.
220 You will be disconnected after 15 minutes of inactivity.
USER aaa
331 User aaa OK. Password required
PASS ***********
230 OK. Current restricted directory is /
SYST
215 UNIX Type: L8
FEAT
211-Extensions supported:
 EPRT
 IDLE
 MDTM
 SIZE
 REST STREAM
 MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;
 MLSD
 TVFS
 ESTP
 PASV
 EPSV
 SPSV
 ESTA
 AUTH TLS
 PBSZ
 PROT
 UTF8
211 End.
HELP SITE
214-The following SITE commands are recognized
 CHMOD
 IDLE
 UTIME
214 Pure-FTPd - http://pureftpd.org/
OPTS UTF8 ON
200 OK, UTF-8 enabled
Connect ok!
PWD
257 "/" is your current location
Pobierz katalog
TYPE A
200 TYPE is now ASCII
PASV
227 Entering Passive Mode (192,168,2,161,4,3)
Server reports local IP -> Redirect to: 1.2.3.4
PORT 1,2,3,5,7,161
200 PORT command successful
MLSD
PORT failed, try PASV mode!
PASV

Próbowałem również wyłączyć firewall i antywirusy w komputerze z którego się łączę (adres komputera n2n:1.2.3.5) (adres routera n2n:1.2.3.4) i też to nic nie pomaga, zakładam że coś w przekierowaniach mam źle, sam serwer FTP nie ma za dużo ustawień, tylko użytkownicy i opcjonalnie zakres portów z jakich ma korzystać (ustawione od 1023-1033), nie ma chyba nawet trybu pasywnego w nim z tego co na szybko sprawdzałem, oczywiście w sieci lokalnej bez problemu czy przez total commander czy przez stronkę z ftp się da połączyć i widać pliki smile

PS
Chyba że łatwiej zrobić przekierowanie do jego zasobów sieciowych - chyba samba jak dobrze kojarzę bo też takowe ma udostępnione smile

2

Odp: Problem z dostępem n2n <-> FTP

Cezary da się w ogóle to zrobić sad ?

3

Odp: Problem z dostępem n2n <-> FTP

george2002 napisał/a:

Cezary da się w ogóle to zrobić sad ?

Nie wiem, nie sprawdzałem takiej konfiguracji.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

4

Odp: Problem z dostępem n2n <-> FTP

a odpłatnie albo za podesłanie np routerka mr3020 gratis za pomoc dało by się coś pomyśleć smile ?

5

Odp: Problem z dostępem n2n <-> FTP

Wszystko zależy od ilości wolnego czasu.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

6 (edytowany przez george2002 2017-09-12 15:38:40)

Odp: Problem z dostępem n2n <-> FTP

Cezary napisał/a:

Wszystko zależy od ilości wolnego czasu.

Hmm, czyli można na coś liczyć / czekać czy nie za bardzo smile ? (i oczywiście nie chodzi mi o zbawienie big_smile )

PS
Znalazłem takie info i nie wiem czy to nie tutaj pies pogrzebany jest:
https://unix.stackexchange.com/question … coming-ftp
zwłaszcza że nie mam raczej tego modułu modprobe ip_conntrack_ftp - istnieje możliwość na takie coś:) ?

Jeszcze takie info znalazłem:
https://dev.openwrt.org/ticket/6015

i ostatecznie takie:
https://major.io/2007/07/01/active-ftp- … -iptables/

Jak doinsalować/włączyć i skąd wziąść ten moduł ip_conntrack_ftp sad ?

7

Odp: Problem z dostępem n2n <-> FTP

kmod-nf-nethelper

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

8 (edytowany przez george2002 2017-09-12 17:07:24)

Odp: Problem z dostępem n2n <-> FTP

Cezary napisał/a:

kmod-nf-nethelper

O kurde ruszyło od kopa po zainstalowaniu tylko mała uwaga - nie kmod-nf-nethelper tylko kmod-nf-nathelper smile
Jeszcze tylko pytanko - szybkość tego rozwiązania zależy najbardziej od supernode szybkości tak ? bo teraz ~100KB/s transfery są a normalnie sieć w której znajduje się ten ftp co prawda na modemie ale prędkości dochodzą spokojnie do 50mb/s download i 30mb/s upload smile ciekawe czy szybciej było by po udziałach sieciowych ale to już może kiedyś tam, na razie cieszę się że działa przez FTP smile

Także podsumowując jeśli ktoś będzie chciał dostać się do ftp przez sieć n2n-v2 dokładnie to jak ustawi wszystko wg tego co tu naskrobałem i zainstaluje to co podpowiedział Cezary to powinno ruszyć od kopa smile

PS
Wysłałem ci maila smile