1 (edytowany przez marcoos 2017-03-24 16:27:09)

Temat: TP-Link MR6400 z LTE @ LEDE

Cześć,
może kogoś zainteresuje moje najnowsze odkrycie sprzętowe - chyba pierwszy tani router z wbudowanym modułem LTE działający pod LEDE dostępny bez problemu w polskiej dystrybucji.

Kosztuje ~450 PLN brutto, jest szeroko dostępny i wg. dystrybutora nie powinno być problemów z dostępnością w najbliższych miesiącach.

W środku w praktyce znane i lubiane hity tp-linkowe:

cat /proc/cpuinfo
system type             : Qualcomm Atheros QCA9533 ver 2 rev 0
machine                 : TP-LINK TL-MR6400
processor               : 0
cpu model               : MIPS 24Kc V7.4
BogoMIPS                : 432.53

Czyli SoC wygląda na identyczny co TL-WR842Nv3 - w konsekwencji ta sama wydajność i to samo radio N300
Flash 8 MB, 64 MB RAMu.

Ich moduł LTE podpięty w środku po USB:

root@LEDE:~# cat /sys/kernel/debug/usb/devices

T:  Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=480  MxCh= 1
B:  Alloc=  0/800 us ( 0%), #Int=  1, #Iso=  0
D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=01 MxPS=64 #Cfgs=  1
P:  Vendor=1d6b ProdID=0002 Rev= 4.04
S:  Manufacturer=Linux 4.4.52 ehci_hcd
S:  Product=EHCI Host Controller
S:  SerialNumber=ehci-platform
C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=  0mA
I:* If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   4 Ivl=256ms

T:  Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  3 Spd=480  MxCh= 0
D:  Ver= 2.01 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=2357 ProdID=000d Rev= 2.28
S:  Manufacturer=TP-LINK Technologies Co., Ltd.
S:  Product=LTE_MODULE
S:  SerialNumber=[ocenzurowano]
C:* #Ifs= 7 Cfg#= 1 Atr=a0 MxPwr=500mA

Modem przydziela na interfejsie usb0 adres z puli 192.168.0.0/24 i jest do niego dostęp po 192.168.0.1 - wygląda na generyczny firmware do wszystkich urządzeń tplinka z modułem LTE bo są ślady po stanie baterii czy wyłączaniu wifi z interfejsu modemu. Prędkości przynajmniej w mojej lokalizacji identyczne (wiadomo co pomiar wychodzi minimalna różnica) z Alcatelem 850V i Huawei E3372 HiLink - około 25 mbit/s down i 5 mbit/s up @ LTE T-Mobile, sygnał na "3 kreski".

Na lede wygląda wstępnie, że działa wszystko poprawnie, łącznie z wskaźnikiem siły sygnału na obudowie która jest sterowana z firmware'u modemu. IMHO dobra alternatywa jeśli nie chcemy się bawić w osobny modem na USB.

Do skompilowania obrazu potrzebne są patche z wątku http://lists.infradead.org/pipermail/le … 06513.html (uwaga jest rozjazd w linux/ar71xx/base-files/etc/board.d/02_network z aktualnym snapshotem, ale to tylko linijki)

2

Odp: TP-Link MR6400 z LTE @ LEDE

TP-LINK MR200 był pierwszy smile

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

3

Odp: TP-Link MR6400 z LTE @ LEDE

Cezary napisał/a:

TP-LINK MR200 był pierwszy smile

Ale 500+ PLN cennikowo sprawia, że trudno go wrzucić w worek tani.
Zresztą MR200 ztcp nadal nie do końca działa pod LEDE - WiFi 5 GHz nie wspierane, więc jedyna zauważalna przewaga jest zniwelowana na starcie. Chyba też Qualcomm ma lepsze wsparcie niż MediaTek MT7620A, ale to może prywatna awersja do wypustów MTK wink

4

Odp: TP-Link MR6400 z LTE @ LEDE

Bo brakuje drivera do tego chipu co jest w mr200.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

5

Odp: TP-Link MR6400 z LTE @ LEDE

marcoos napisał/a:

Ale 500+ PLN cennikowo sprawia, że trudno go wrzucić w worek tani.

No ten MR6400 za ~450 zł bez żadnego USB i z portami 100 Mbps to też raczej średnia rewelacja.

6

Odp: TP-Link MR6400 z LTE @ LEDE

garysek napisał/a:
marcoos napisał/a:

Ale 500+ PLN cennikowo sprawia, że trudno go wrzucić w worek tani.

No ten MR6400 za ~450 zł bez żadnego USB i z portami 100 Mbps to też raczej średnia rewelacja.

Ale nic tańszego nie ma w momencie gdy chcemy mieć w jednym pudełku router i modem - widzisz alternatywę?
Jasne tl-wr842nv3 plus modem alcatel/huawei wyjdzie taniej, ale ani to ładnie nie wyglada ani nie jest bezpieczne jeśli sie nie zamontuje dobrze (nie wiarygodne jak często "przypadkiem" router spada i jak często przy okazji wtyczka usb modemu odgina sie o kilkanaście stopni wink.
Plusem jest jeszcze wskaźnik siły sygnału komórkowego na obudowie.

7

Odp: TP-Link MR6400 z LTE @ LEDE

Nie no oczywiście, że sprzęt komuś może przypasować. Z mojego punktu widzenia jednak brak 1GBps i USB go dyskwalifikuje - w tej cenie mógłby to mieć. U mnie akurat router stoi albo w szafie, albo na strychu, więc estetyka i wskaźnik na obudowie zupełnie są nieistotne. No ale oczywiście każdy ma inne wymagania.
Te 2 anteny to jak rozumiem do LTE tylko, wykręcane chociaż są?

8

Odp: TP-Link MR6400 z LTE @ LEDE

garysek napisał/a:

Nie no oczywiście, że sprzęt komuś może przypasować. Z mojego punktu widzenia jednak brak 1GBps i USB go dyskwalifikuje - w tej cenie mógłby to mieć. U mnie akurat router stoi albo w szafie, albo na strychu, więc estetyka i wskaźnik na obudowie zupełnie są nieistotne. No ale oczywiście każdy ma inne wymagania.
Te 2 anteny to jak rozumiem do LTE tylko, wykręcane chociaż są?

Anteny odkręcane. Wezmę w przyszłym tygodniu w jedna trudna lokalizacje, porównam z alcatelem 850v z ciekawości.
USB przy modemie lte to i tak zazwyczaj kadzidelko, bo 2 urządzenia na tak słabych SoC to za dużo. Zresztą teraz nawet drukarki za 300 złotych maja wifi, a do udostępniania dysku i tak ta liga wydajnościowo. Tylko faktycznie gigabit ethernetu szkoda, strasznie powoli pojawia się w urządzeniach z średnio-niższego segmentu sad

9

Odp: TP-Link MR6400 z LTE @ LEDE

Przeniosłem sobie te łatki do mojego 17.01, skompilowało się. Ktoś chętny to testów?

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

10

Odp: TP-Link MR6400 z LTE @ LEDE

Marcoos proszę popraw informację o rozmiarze flash na 16MB.
8MB może raczej zniechęcić niż zachęcić wink

WDR3600 16MB -> RT-N18U -> Intel DQ77KB + Celeron G1620 (Luci Lede Obsy 17.01) + UPC250
        WR842NDv2 + 21M-02 -> WR2543ND (Gargoyle Obsy 1.9.1.2) + E3272S-153 ndis
                                              RT-N14U (Gargoyle Obsy 1.9.1.2) + E3372S-153 ndis

11

Odp: TP-Link MR6400 z LTE @ LEDE

pacuro napisał/a:

Marcoos proszę popraw informację o rozmiarze flash na 16MB.
8MB może raczej zniechęcić niż zachęcić wink

Ale w nim jest 8 MB flash.

12

Odp: TP-Link MR6400 z LTE @ LEDE

Próbowałem zaaplikować 17.01 od Ciebie Cezary, ale niestety wyskakuje mi znany błąd 18005. Próbowałem ze zmianą nazwy pliku, ale nie pomogło. Oprogramowanie pobrane od TP-Linka wchodzi bez problemu.

Firmware Version:   
1.0.12 Build 160322 Rel.33912n
Hardware Version:   
MR6400 v1 00000000

Jakieś pomysły? Coś przeoczyłem?

13

Odp: TP-Link MR6400 z LTE @ LEDE

Przez tftp z tego co mi wiadomo: http://lists.infradead.org/pipermail/le … 06513.html

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

14

Odp: TP-Link MR6400 z LTE @ LEDE

Tak właśnie zrobiłem, właśnie miałem napisać, że poszło.
Jeszcze tylko muszę się jakoś dobrać do ustawień APN w modemie, czy wskazówki z MR200 mogą być pomocne?

15

Odp: TP-Link MR6400 z LTE @ LEDE

Tak, spróbuj postąpić też w ten sposób.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

16

Odp: TP-Link MR6400 z LTE @ LEDE

I? Działa wszystko?

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

17

Odp: TP-Link MR6400 z LTE @ LEDE

Przepraszam za takiego laga, zaskoczył mnie pilny wyjazd - tak działa wszystko (prawie), poprzez rndis. GUI modemu dostępne pod 192.168.0.1
DHCP w modemie przekonfigurowane, żeby zawsze przydzielało 192.168.0.100 (DMZ) interfejsowi routera, ale niestety nadal mam problem z funkcjonowaniem IPSec (na potrzeby VoWIFI w t-mobile i Orange).
MR6400 nie pozwala zestawić sesji z operatorem, nie chciał na OFW i nie chce na LEDE. Ponieważ usługa pracuje poprawnie w zestawie inny router z LEDE i modem USB, to winy doszukuje się w zestawie rndis i DMZ.

Myślisz Cezary, że da się zainicjować modem w MR6400 w taki sposób, żeby interfejs LEDE dostawał IP bezpośrednio od operatora, czy próbowanie z ppp, jak w przypadku MR200 ma sens? Pytanie jest o tyle zasadne, że przy OFW w MR6400 i tak występuje podwójny NAT - traceroute zawsze pokaże 192.168.0.1 przed wyjściem w świat :-)

18

Odp: TP-Link MR6400 z LTE @ LEDE

Nie wiem czy z tym modemem jesteś w stanie to zrobić. Myślę że raczej nie.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

19

Odp: TP-Link MR6400 z LTE @ LEDE

W tej chwili mam do routera tylko dostęp zdalny, więc nie mogę w pełni potestować, bo odetnę sobie gałąź na której siedzę pozbawiając przy tym Bogu ducha winną rodzinę internetu, ale wstępnie wygląda to tak:

Mon May 15 19:48:38 2017 daemon.notice pppd[307]: pppd 2.4.7 started by root, uid 0
Mon May 15 19:48:39 2017 local2.info chat[309]: abort on (BUSY)
Mon May 15 19:48:39 2017 local2.info chat[309]: abort on (NO CARRIER)
Mon May 15 19:48:39 2017 local2.info chat[309]: abort on (ERROR)
Mon May 15 19:48:39 2017 local2.info chat[309]: report (CONNECT)
Mon May 15 19:48:39 2017 local2.info chat[309]: timeout set to 10 seconds
Mon May 15 19:48:39 2017 local2.info chat[309]: send (AT&F^M)
Mon May 15 19:48:39 2017 local2.info chat[309]: expect (OK)
Mon May 15 19:48:39 2017 local2.info chat[309]: AT&F^M^M
Mon May 15 19:48:39 2017 local2.info chat[309]: OK
Mon May 15 19:48:39 2017 local2.info chat[309]:  -- got it
Mon May 15 19:48:39 2017 local2.info chat[309]: send (ATE1^M)
Mon May 15 19:48:39 2017 local2.info chat[309]: expect (OK)
Mon May 15 19:48:39 2017 local2.info chat[309]: ^M
Mon May 15 19:48:39 2017 local2.info chat[309]: ATE1^M^M
Mon May 15 19:48:39 2017 local2.info chat[309]: OK
Mon May 15 19:48:39 2017 local2.info chat[309]:  -- got it
Mon May 15 19:48:39 2017 local2.info chat[309]: send (AT+CGDCONT=1,"IP","vpn"^M)
Mon May 15 19:48:40 2017 local2.info chat[309]: timeout set to 30 seconds
Mon May 15 19:48:40 2017 local2.info chat[309]: expect (OK)
Mon May 15 19:48:40 2017 local2.info chat[309]: ^M
Mon May 15 19:48:40 2017 local2.info chat[309]: AT+CGDCONT=1,"IP","vpn"^M^M
Mon May 15 19:48:40 2017 local2.info chat[309]: OK
Mon May 15 19:48:40 2017 local2.info chat[309]:  -- got it
Mon May 15 19:48:40 2017 local2.info chat[309]: send (ATD*99***1#^M)
Mon May 15 19:48:40 2017 local2.info chat[309]: expect (CONNECT)
Mon May 15 19:48:40 2017 local2.info chat[309]: ^M
Mon May 15 19:48:40 2017 local2.info chat[309]: ATD*99***1#^M^M
Mon May 15 19:48:40 2017 local2.info chat[309]: CONNECT
Mon May 15 19:48:40 2017 local2.info chat[309]:  -- got it
Mon May 15 19:48:40 2017 local2.info chat[309]: send ( ^M)
Mon May 15 19:48:40 2017 daemon.info pppd[307]: Serial connection established.
Mon May 15 19:48:40 2017 kern.info kernel: [10320.040277] 3g-test: renamed from ppp0
Mon May 15 19:48:40 2017 daemon.info pppd[307]: Using interface 3g-test
Mon May 15 19:48:40 2017 daemon.notice pppd[307]: Connect: 3g-test <--> /dev/ttyUSB1
Mon May 15 19:48:41 2017 daemon.notice pppd[307]: PAP authentication succeeded
Mon May 15 19:48:47 2017 daemon.info pppd[307]: No response to 5 echo-requests
Mon May 15 19:48:47 2017 daemon.notice pppd[307]: Serial link appears to be disconnected.
Mon May 15 19:48:53 2017 daemon.notice pppd[307]: Connection terminated.

Nie wiem, czy brak odpowiedzi wynika z aktywnego już połączenia rndis, czy z innego, ale nie mam jak sprawdzić. Zastanawiające jest to, że wykorzystywany APN obsługuje tylko PAP, domyślnie proto_3g próbuje CHAP i pokazywał CHAP authentication succeeded. Albo Orange wprowadził po cichu zmianę, albo to "Authentication succeeded" to false positive. :-)

20

Odp: TP-Link MR6400 z LTE @ LEDE

@miszka.ha jeśli masz chwilę to wypróbuj to: https://github.com/lede-project/source/pull/641
Możliwe że z tym modemem też da się nawiązać połączenie i mieć publiczny IP bezpośrednio na interfejsie.

https://tplinkforum.pl - Polskie forum poświęcone tematyce urządzeń firmy TP-Link i Neffos

21

Odp: TP-Link MR6400 z LTE @ LEDE

Pozwólcie, że zapytam czy:

- widać parametry połączenia, tj. RSRP, RSRQ, SINR, CellID?

- czy da się wybrać Tylko LTE i dalej, np. Tylko 2100?

22

Odp: TP-Link MR6400 z LTE @ LEDE

Jeżeli modem jest ten sam co w mr200 to nie/nie. Chyba że ktoś znajdzie sposób na odczyt tych wartości.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

23

Odp: TP-Link MR6400 z LTE @ LEDE

@Heinz, cezary, dzisiaj miałem w końcu okazję pobawić się dalej i udało się uzyskać połączenie ppp bez większych kombinacji.
W GUI (192.168.0.1) modemu należy wyłączyć "mobile data", żeby modem nie nawiązywał automatycznie połączenia. Następnie konfigurujemy standardowe połączenie ppp 3g w LEDE.

Poniżej konfiguracja mojego interfejsu, dla Orange i APN vpn (nie obsługuje CHAP, stąd dodane pppd_options, żeby wymusić PAP). Wszystko wstaje, jak trzeba, a najważniejsze jest to, że IP operatora jest przypisane bezpośrednio do interfejsu LEDE, dzięki temu wszelkie usługi działają bez problemu, w tym VoWiFi.

config interface 'WAN_LTE'
    option proto '3g'
    option device '/dev/ttyUSB1'
    option ipv6 'auto'
    option apn 'vpn'
    option username 'vpn'
    option password 'vpn'
    option ppdd_options 'noipdefault refuse-chap refuse-mschap refuse-mschap-v2 refuse-eap'

24

Odp: TP-Link MR6400 z LTE @ LEDE

Jaka prędkość połączenia?

https://tplinkforum.pl - Polskie forum poświęcone tematyce urządzeń firmy TP-Link i Neffos

25

Odp: TP-Link MR6400 z LTE @ LEDE

Około 8mbps down, 5mps up, ale jestem na granicy zasięgu i z niezbyt dokładnie ustawioną anteną zewnętrzną na słabej jakości kablu. Generalnie nie widać różnicy gołym okiem w moim przypadku. Myślę, że użytecznej odpowiedzi mógłby udzielić ktoś w lepszym pokryciu sygnałem.