1 (edytowany przez jedreg 2011-02-07 01:00:17)

Temat: WR1043ND z hubem USB - restarty pod obciążeniem

Witajcie,
temat nie nowy, sporo się oczytałem o problemach przy obciążeniu rutera transmission-em.
Mam w ruterze hub usb a na zewnętrznym dysku 2,5" system na extroot-cie. Przy sporych obciążeniach systemu (load na poziomie >2) i pobieraniu plików (300kB/s z wanu) system jest w stanie pociągnąć od 10 do 90 minut, dłużej się nie udało. Najczęściej następuje restart a sporadycznie odpięcie systemu plików.  Oba sugerują problem USB. W przypadku "odpięcia" FS miałem efekt zgłoszenia w logu, błędy dostępu do ext4, tak jakby dysk przeszedł w offline (brak reakcji ale kręci się). W przypadku restartu, bootuje się oprogramowanie z flasha i dostaję błędy USB sugerujące problemy fizyczne, tak jakby brakowało mocy (dysk kręci się ale nie reaguje); by wystartował na nowo trzeba odpiąć zasilanie, reboot nie wystarcza.
dmesg zgłasza to tak:

usb 1-1: new high speed USB device using ar71xx-ehci and address 2
usb 1-1: configuration #1 chosen from 1 choice
hub 1-1:1.0: USB hub found
hub 1-1:1.0: 4 ports detected
usb 1-1.1: new full speed USB device using ar71xx-ehci and address 3
usb 1-1.1: device descriptor read/64, error -32
usb 1-1.1: device descriptor read/64, error -32
usb 1-1.1: new full speed USB device using ar71xx-ehci and address 4
usb 1-1.1: device descriptor read/64, error -32
usb 1-1.1: device descriptor read/64, error -32
usb 1-1.1: new full speed USB device using ar71xx-ehci and address 5
usb 1-1.1: device not accepting address 5, error -32
usb 1-1.1: new full speed USB device using ar71xx-ehci and address 6
usb 1-1.1: device not accepting address 6, error -32
hub 1-1:1.0: unable to enumerate USB device on port 1

Ponieważ hub usb jest aktywny, zapiąłem do niego oryginalny zasilacz (5V/1A) i niestety bez zmian sad Zauważyłem też spore grzanie się kostki hub-a, więc zamontowałem na nim mały radiatorek na taśmie termoprzewodzącej. Ale zwiecha dalej. USB jest generalnie sprawne bo wcześniej po przelucie ram-u na 64mb chodził nonstop z uptime 4 tygodnie na extroocie z pendrive-a. Zastanawiam się, czy "ten model tak ma" a może jest sens powalczyć jeszcze z nowszym firmware? W tym momecie mam: Linux version 2.6.32.25 (cezary@eko.one.pl) (gcc version 4.3.3 (GCC) ) #47 Sat Nov 27 22:22:21 CET 2010

Jutro jeszcze dwa ostateczne testy - zapnę hdd z ominięciem hub-a, no i spróbuję puścić system bez intensywnego obciążenia (bez transmission).
Pomysły/komentarze mile widziane.

pozdro,
andrzej.

2

Odp: WR1043ND z hubem USB - restarty pod obciążeniem

Bez obciążenia ruter pracował stabilnie całą noc (hdd przez hub usb), rano wrzucenie 12GB przez sambe na ruter też nie spowodowało problemu... jedyne co zauważyłem to średni load przy takich czynnościach to 1,5-2.0 a gdy ruter się przewracał, transmission dawał load na poziomie 5.0-7.0! (robił weryfikację plików i jednocześnie ściągał nowe kawałki).

Jedna z opinii z forum openlinksys mówi, że urządzenia box-owe mają tendencję do niestabilności przy dużych obciążeniach, co mój przypadek wyraźnie potwierwdza. Czy da się jakoś zmniejszyć priorytet transmission tak, żeby nie generował tak dużego load? Spróbuję ustawić duże "nice" na demonach, ale nie wiem czy to efektywnie ściągnie load w dół gdy nic więcej nie pracuje. Może warto stuningować samo transmission tak by zmniejszyć jego przepustowość - czy ktoś z praktyków podzieli się "stabilną konfiguracją"?

pozdro,
andrzej.

3

Odp: WR1043ND z hubem USB - restarty pod obciążeniem

ja bym zaczął od sprawdzenia systemu pod obciążeniem na zasilaczu z odpowiednim zapasem mocy.
ja to widze tak: wieksze obciażenie procesora = wiekszy pobór prądu = szybkie rozładowywanie sie kondensatorów w zasilaczu a to oznacza wiekszą wrażliwość na wachania napięcia w sieci. braknie ci prądu na ułamek sekundy przy nie obciążonym procesorze, to pare milisekund ci pociągnie na kondensatorze, ale jak jest obciążony, to juz nie

4

Odp: WR1043ND z hubem USB - restarty pod obciążeniem

ja mam to samo, tyle, ze to dzieje sie przy probie odtworzenia muzyki poprzez mpc. wyglada tak jakby usb sie resetowalo. trzeba wyl/wl dysk i wtedy system po reboocie wraca do normy.myslalem, ze to wina wlasnie braku napiecia zewnetrznego (hub pasywny), ale widze, ze nie tedy droga.

jesli chodzi o samo transmission, to mi potrafi caly router  zresetowac gdy sciagam 5 plikow, uruchomione  (nieuzywane) mdlna, openvpn.

wieczorem potestuje pod obciazeniem.

5

Odp: WR1043ND z hubem USB - restarty pod obciążeniem

patryk napisał/a:

ja bym zaczął od sprawdzenia systemu pod obciążeniem na zasilaczu z odpowiednim zapasem mocy.

Właśnie to zrobiłem. Jak napisałem wcześniej ruter chodził na swoim zasilaczu (12V/1.5A) a do aktywnego huba podpiąłem drugi (5V/1A); przy dużej wielozadaniowości z użyciem dysku -- ostre swapowanie na krawędzi 64mb, transmission z 5 plikami, z czego jeden w trakcie weryfikacji (mocne obciążenie dysku i systemu) i pchanie pliku po sambie -- system nie utrzymał się na nogach więcej niż 10 minut smile

Wg mnie problem nie tkwi w zasilaniu, być może w termice. Elektronika hub-a nawet z radiatorem parzyła w palce przy takim rzeźbieniu dyskiem - spróbuję dać jeszcze większy radiator albo na chwilę dać jakieś bardziej aktywne chłodzenie smile Posadziłem też duży miedziany radiator (ze zdemontowaneog mostka płyty głównej) na procka i pamięć. Oczywiście aktywne chłodzenie na stałe (wiatraki itp) nie jest opcją, to ma zostać cichym, może lekko ciepłym, pudełkiem smile

Jeśli to nie termika to problem może wynikać z jakiegoś subtelnego problemu sterownika USB przy dużym obciążeniu i "sieczce danych" z wielu źródeł, tutaj transmission dobrze radzi sobie z tym zadaniem wink 

Spróbuję powalczyć z ograniczeniem obciążenia systemu przez transmission, bo nie zależy mi na przepustowości (wtedy można pociągnąć pc-tem) a pracy w tle z niskim poborem mocy. Jeśli niestabilność okaże się funkcją obciążenia systemu, to możnaby oskryptować transmission tak, żeby przy dużym load-zie jeszcze bardziej zmniejszać priorytet transmission lub ograniczać jego przepustowość prowadząc do spadku obciążenia.

pozdro,
andrzej.

6

Odp: WR1043ND z hubem USB - restarty pod obciążeniem

mi niestety nadal wywala sie wifi, wiec przy duzym obciazeniu nie dam rady nawet zagrzac huba smile 10 minut pochodziło i taki błąd  przy sciaganiu ftp, transmission i www.

Feb  7 20:26:31 OpenWrt user.err kernel: ath: DMA failed to stop in 10 ms AR_CR=0x00000024 AR_DIAG_SW=0x42000020
Feb  7 20:26:32 OpenWrt user.err kernel: ath: Could not stop RX, we could be confusing the DMA engine when we start RX up
Feb  7 20:26:32 OpenWrt user.warn kernel: ------------[ cut here ]------------
Feb  7 20:26:32 OpenWrt user.warn kernel: WARNING: at /opt/projekty/openwrt/ar71xx-backfire/build_dir/linux-ar71xx/compat-wireless-2011-01-24/drivers/net/wireless/ath/ath9k/recv.c:509 0x80c67984()
Feb  7 20:26:32 OpenWrt user.warn kernel: Modules linked in: btusb hci_uart hidp bnep rfcomm sco l2cap bluetooth fuse option hid usbserial snd_usb_audio snd_usb_lib evdev ledtrig_usbdev nf_nat_tftp nf_conntrack_tftp nf_nat_irc nf_conntrack_irc nf_nat_ftp nf_conntrack_f
Feb  7 20:26:32 OpenWrt user.warn kernel: Call Trace:[<800877fc>] 0x800877fc
Feb  7 20:26:32 OpenWrt user.warn kernel: [<800686c4>] 0x800686c4
Feb  7 20:26:32 OpenWrt user.warn kernel: [<800686c4>] 0x800686c4
Feb  7 20:26:32 OpenWrt user.warn kernel: [<80086708>] 0x80086708
Feb  7 20:26:32 OpenWrt user.warn kernel: [<80c67984>] 0x80c67984
Feb  7 20:26:32 OpenWrt user.warn kernel: [<80c70000>] 0x80c70000
Feb  7 20:26:32 OpenWrt user.warn kernel: [<80c67984>] 0x80c67984

jakiego huba usb z zasilaniem polecacie? dlink 4 portowy to koszt okolo 40zł, cos innego?

7

Odp: WR1043ND z hubem USB - restarty pod obciążeniem

Sobol, u ciebie objawy są zupełnie inne, u mnie pad nie jest taki delikatny (nie ma stack trace tylko automatyczny reboot).

Co do huba usb to ja kupiłem Unitek Y-206P za 17pln na alledrogo - aktywny 4portowy z zasilaczem (w zestawie), wyjścia po jednej stronie, idealny do wszycia wink

Jeśli dysk kręci się na pasywnym hubie to nie ma sensu przepłacać za aktywny. U mnie docelowo hub nie będzie zasilany. Myślałem o opcji dodatkowego zasilania w środku podpinając się do dostarczanego 12V z użyciem stabilizatora ts7805 ale w najprostszym układzie (scalak i 2 kondy filtrujące) tak się dziad grzeje, że bez dużej blachy się nie obejdzie. Na bardziej skomplikowaną konstrukcję brakło mi na razie weny więc odpuszczam.

pozdro,
andrzej.

8

Odp: WR1043ND z hubem USB - restarty pod obciążeniem

Zmień hub USB na inny - lepszy.
U mnie na hubie Activejet dość często następował restart dysku (huba?) co było widać w logu jako wykrycie nowego urządzenia. Po wymianie na hub Toshiby problem ustąpił.

Moje artykuły o OpenWRT na routerach TP-Link i iConnect:
http://www.pawelwozniak.info/

9 (edytowany przez jedreg 2011-02-12 01:07:25)

Odp: WR1043ND z hubem USB - restarty pod obciążeniem

Zapiąłem HDD na oryginalny port USB i ze smutkiem potwierdzam, że wszystko działa, zatem niestabilność wprowadza hub. Jak na razie przez 30m load waha się koło 7 tak, że radiator na procku i pamięci jest naprawdę gorący, transmission jedzie na maksa z pełnym priorytetm, jeden plik się weryfikuje (full obciążenie hdd), ftp pcha ogromne pliki ... i wszystko działa.
//EDIT: ruter działał stabilnie całą noc pod obciążeniem, hub do wymiany

Jak teraz trafić na dobrego huba? Problem jest taki, że dookoła sama chińszczyna. Jak tu być mądrym i kupić coś co (a) jest stabilne i (b) ma poziome porty o rozstawie takim żeby wszedł w wycięte otwory hmm Cezary na pytanie jakiego hub-a używa odparł, że najtańszego. I od takiego wariantu zacznę sprawdzając warunek (b) i testując bez "wszywania" w obudowę, do tego poszukam jeszcze czegoś ze średniej półki, znalazłem używanego D-linka za 30pln z rozstawem portów na oko takim samym... coż, jestem dalej końca zabawy niż myślałem ale jeszcze nie padłem w walce.

pozdro,
andrzej.

10

Odp: WR1043ND z hubem USB - restarty pod obciążeniem

Ten dlink to taki 7 portowy (czy coś koło tego?)

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

11

Odp: WR1043ND z hubem USB - restarty pod obciążeniem

Nie, miałem na myśli ten 4-portowy: http://allegro.pl/d-link-hub-usb-4-port … 05123.html
Ale na razie zrobię niskobudżetowy test z hubem za 5pln prosto z chin; w końcu nawet te markowe też tam są składane. Mam na oku też hub "hama" za 14pln; firma sprawdzona - filtr polaryzacyjny tej firmy do lustrzanki nigdy mi się nie zawiesił tongue

12

Odp: WR1043ND z hubem USB - restarty pod obciążeniem

Próba z tanią chinszczyzną nie udała się, sprzedawany za 5pln hub usb2.0 był stabilny ale miał przepustowość usb1.1 i zatykał cały system, więc z miejsca poszedł do kosza. W końcu jednak dopadłem stabilnego hub-a, który jak na razie wytrzymał 1,5h pod ostrym obciążeniem a kosztował tylko 15pln (http://allegro.pl/hub-usb-2-0-hama-4-po … 88800.html).  Jedyny mankament jest taki, że bez dodatkowego zasilania nie rozpędza dysku. Ponieważ hub ma być wszyty w obudowę więc albo spróbuję podłączyć 5V z oryginalnego zasilania USB albo pomyślę nad wewnętrznym stabilizatorem impulsowym (np. LM2675) przekładającym zewnętrzne 12V na 5. PCB jest większe niż przeciętne ale powinno się zmieścić.

pozdro,
andrzej.

13

Odp: WR1043ND z hubem USB - restarty pod obciążeniem

Cześć,

Jedreg możesz napisać VID i PID tego huba USB lub oznaczenie układu na jakim jest oparty?

14

Odp: WR1043ND z hubem USB - restarty pod obciążeniem

P:  Vendor=05e3 ProdID=0608 Rev= 7.02
S:  Product=USB2.0 Hub

Dodam, że u mnie ten hub od kilku dni bez problemu pracuje z dyskiem Samsumg HM320HI w kieszeni f-my Carbon z elektroniką opartą na SPIF301-HL237. Piszę o tym dlatego, że kolega kaml wspomiał mi na priv-ie, że ze swoim dyskiem samsunga miał problemy z hubami opartymi na tym samym kontrolerze GL850G.

pozdro,
andrzej

15 (edytowany przez p4trykx 2011-03-02 03:28:27)

Odp: WR1043ND z hubem USB - restarty pod obciążeniem

A nie prościej zasilić kieszeń dysku zamiast tego HUBa? Przeważnie obudowy usb mają wejście na zasilacz 5V.
Jeśli chodzi o HUBy to ja mam Modecoma Wave 7 portowego z zasilaczem chyba 1A. Nie testowałem go pod dużym obciążeniem ale z kilkoma urządzeniami działa. Testowałem też wcześniej huba Hama 7 portowego i chyba trochę lepiej działał.

16 (edytowany przez kabal 2011-06-09 13:33:37)

Odp: WR1043ND z hubem USB - restarty pod obciążeniem

Witam.

Te same problemy - tyle że na RouterStation Pro.
Obecnie hub jaki jest używany to aktywny 4 portowy hub Pentagram'a. 2 dyski: 2TB 3.5' WD w kieszeni z własnym zasilaniem, 500GB 2.5' Seagate w kieszeni bez zasilania.

Błędy jakie pluje do dmesg'a:
usb 1-1: reset high speed USB device using ar71xx-ehci and address 2

Temat omawiany również tutaj: https://forum.openwrt.org/viewtopic.php?pid=128983
Zmiana parametrów opisanych w tym wątku troszkę zmniejszyła ilość wypluwanych błędów.

Ciekawostką jest to że nawet jak odepnę huba i podłącze tylko dysk 2TB i zacznę kopiować duży plik miedzy katalogami to potrafi wypluć takie błędy.
W RSPro zmieniony już został zasilacz na mocniejszy - więc to nie wina zasilacza RSPro (poza tym dysk ma swój zasilacz) a raczej platformy ar71xx.

@ jedreg
Możesz podesłać dokładna nazwę/model tego huba Hamy ? - może jeszcze tego spróbuję...

Netgear WNDR3800 # TP-Link TL-WR1043ND v4

17

Odp: WR1043ND z hubem USB - restarty pod obciążeniem

A ja bym stawiał na wadę rspro. Na innych forach trafiłem na kilka ogólnych wątków o coraz słabszych hardware ubiquiti, więc może masz taką przypaddłow.

PS. A próbowałeś dać dobry, ekranowany kabel USB?

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

18 (edytowany przez kabal 2011-06-09 10:26:44)

Odp: WR1043ND z hubem USB - restarty pod obciążeniem

Cezary napisał/a:

A ja bym stawiał na wadę rspro. Na innych forach trafiłem na kilka ogólnych wątków o coraz słabszych hardware ubiquiti, więc może masz taką przypaddłow.

Hmm...czy ja wiem. Jeśli takie problemy występują i na TP-Link'ach, Netgear'ach i RSPro ? - nie chce się upierać bo fachowcem aż takim nie jestem w tym temacie ale wszystko wskazuje na to że to wina platformy ar71xx lub sterownika USB2 w OpenWrt.

Cezary napisał/a:

PS. A próbowałeś dać dobry, ekranowany kabel USB?

Tak. Podłączałem już kilka kabli USB - w tym krótki, oryginalny, gruby kabel od innego dysku WD Passport 2.5' - i niestety bez zmian..


Ale jak wspomniałem wyżej...zmiana wartości "/sys/block/sdb/device/max_sectors" na 1024 zmniejszyła występowanie błędów - szkoda że nie zniwelowała.
Jakoś obstawiam że to wina sterownika USB2 w OpenWrt...

Netgear WNDR3800 # TP-Link TL-WR1043ND v4

19

Odp: WR1043ND z hubem USB - restarty pod obciążeniem

Ten sterownik pochodzi z kernala linuksowego. Uzyj więc trunka, gdzie masz najnowszy kernel - jeżeli tam nadal nie chodzi na działa na normalnym ubuntu z tym samym kernelem - to masz problem sprzętowy.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

20 (edytowany przez kabal 2011-06-09 13:34:21)

Odp: WR1043ND z hubem USB - restarty pod obciążeniem

Hmm... słuszna uwaga.
Sprawdzę zatem trunka z nowym jądrem i dam znać..

Netgear WNDR3800 # TP-Link TL-WR1043ND v4

21 (edytowany przez slavko 2011-06-28 23:30:24)

Odp: WR1043ND z hubem USB - restarty pod obciążeniem

Podpinam się do tematu bo mam problem pośrednio związany z tym wątkiem - czyli przy znacznym obciążeniu transmission następuje odcięcie systemu plików z podłaczonego dysku 2,5" - dysk podłaczony do huba w którym siedzi także Pen.

Aktualnie zastosowałem taki myk - do dysku podłączyłem podwójny kabel usb z tym że drugą wtyczkę (taką cieńszą - czyli jak przypuszczam zasilającą) podłączyłem do routera który leży obok WR1043ND- w moim przypadku jest to modemo router Thomson (UPC). Router ten ma nieużywany port USB ale na porcie "płyną" jakieś prądy :-). Po zastosowaniu tego rozwiązania problemy z restartowaniem dysku ustąpiły.

Nie jestem elektronikiem/elektrykiem więc pytanie do osób bardziej obeznanych z tematem - czy takie rozwiązanie jest bezpieczne?

22

Odp: WR1043ND z hubem USB - restarty pod obciążeniem

Jeżeli zasilane są z tego samego źródła - listwy to tak.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

23 (edytowany przez kabal 2011-06-29 08:50:37)

Odp: WR1043ND z hubem USB - restarty pod obciążeniem

Witam ponownie.

Z kolei w moim przypadku nadal to samo - rspro nadal co jakiś czas wywala dysk USB lub wypluwa błędy typu:

usb 1-1: reset high speed USB device using ar71xx-ehci and address 2 

Trunk oczywiście skompilowany i wpakowany w rspro - żadnych zmian na lepsze.
Oba dyski (2TB i 500GB) maja własne zasilanie z oddzielnych zasilaczy oraz hub USB też ma własny zasilacz - więc wykluczam brak zasilania.
Po prostu ta platforma nie radzi sobie z USB i dużymi operacjami na dyskach.

Błędy najczęściej są wypluwane gdy jednocześnie transmission ściąga torcika na dysk 500GB (powiedzmy ok <=500KB/s) a w tym czasie kopiuje z tego dysku (500GB) na dysk 2TB innego ściągniętego torta. Wszystko idzie przez HUB'a.
Przeważnie wtedy któryś z dysków się rozłączy i wypluje wspomniany wyżej błąd. Ba - są sytuacje że nawet odłączy dysk przy tym resecie USB.
Często również rozłącza dysk i wywala błędy do loga gdy transmission działa np całą noc i transfer ciągły jest w granicach ok 1MB - rspro nie wytrzymuje tego i rozłącza dysk.

Przy normalnej pracy czyli np tylko oglądanie filmu (plik 8GB) z dysku 2TB przez sambe i jednocześnie słuchanie muzyki na innym komputerze z samby z tego samego dysku, czy wolniejsze ściąganie plików tylko na 500-tke - wspomnianych sytuacji nie ma.


Gdybym miał dostęp do zachwalanego wszędzie WNDR3700v2 przetestował bym go pod kontem moich zaobserwowanych spostrzeżeń w danych sytuacjach smile To ta sama platforma więc ciekaw jestem czy on by przetrwał taki typ użytkowania.. może coś poprawili/ulepszyli... ?!

Netgear WNDR3800 # TP-Link TL-WR1043ND v4

24

Odp: WR1043ND z hubem USB - restarty pod obciążeniem

To Ci mogę sprawdzić - co prawda hub mam pasywny, ale mogę zobaczyć jak się będzie zachowywał w takich sytuacjach.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

25

Odp: WR1043ND z hubem USB - restarty pod obciążeniem

Cezary napisał/a:

To Ci mogę sprawdzić - co prawda hub mam pasywny, ale mogę zobaczyć jak się będzie zachowywał w takich sytuacjach.

To świetnie. Daj znać jak to wygląda na tym WNDR'ku.

Na koniec dodam że mam jeszcze Tp-Link'a WR1043ND 64MB mod. Ten z kolei nie przetrwa sprawdzania plików na dysku 2TB ext4 (e2fsck -cfv /dev/sda1) smile
Przy uruchomieniu sprawdzania systemu plików, po chwili następuje reset router'a - diagnoza to zbyt mało pamięci (dysk był podpięty bezpośrednio do Tp-Linka  z własnym zasilaniem). Po zastosowaniu swap'a (tym razem juz idzie przez HUB'a) również reset rutera - tyle że wytrzymuje ciut dłużej.. wink
Do końca nie ma szans sprawdzenia na nim dysku 2TB.

Netgear WNDR3800 # TP-Link TL-WR1043ND v4