Temat: WRT1900ACS pierwsze kroki

Witam.

Rozpocząłem moją przygodę z open-wrt.

Kupiłem model WRT1900ACS.

Wgrałem na nim obraz https://downloads.openwrt.org/chaos_cal … actory.img

Później doczytałem, że dla tego modelu odpowiedni jest obraz shelby.

ściągnąłem więc obraz https://downloads.openwrt.org/snapshots … ctory.img.



Problem jest taki , że obraz shelby nie działa.
Nic nie odpowiada 192.168.1.1

Musiałem sprzętowo wrócić do poprzedniej wersji .


Ktoś mi powie czemu tak się dzieje ?

2

Odp: WRT1900ACS pierwsze kroki

Jesteś pewien  że masz ACS właśnie? smile

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

Odp: WRT1900ACS pierwsze kroki

Cezary napisał/a:

Jesteś pewien  że masz ACS właśnie? smile


10000 %.

Sprawdzałem na dwóch modelach.

Efekt taki sam.

Trochę mnie to dziwi, bo działa mi jak rozumiem firmware dla AC V2, a nie działa na ACS.

PS. Dlaczego w  /chaos_calmer/15.05/mvebu/generic/ nie ma wersji Shelby , tylko w głownej gałęzi jest ?


Już chodzi mi po głowie , czy pliku firmware nie mam uszkodzonego.

Wielkość się zgadza, więc powinno być OK.

Robiłem ugrade z opcją "zachowaj konfigurację" właczoną i wyłączoną.

Efekt taki sam.

Trochę ta sytuacja mnie smuci.

4

Odp: WRT1900ACS pierwsze kroki

A spróbuj obraz ode mnie, tu z eko.one.pl

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

Odp: WRT1900ACS pierwsze kroki

Cezary napisał/a:

A spróbuj obraz ode mnie, tu z eko.one.pl


Mówisz o tym:

dl.eko.one.pl/luci/chaos_calmer/mvebu/luci-15.05-mvebu-armada-385-linksys-shelby-wrt1900acs-squashfs-factory.img

?

Co w tych obrazach zmieniłeś ?

PS.

Głupie pytanie:

Nie mogę doczytać co robi squashfs-sysupgrade.tar ?

6

Odp: WRT1900ACS pierwsze kroki

Na eko.one.pl masz opisane czym się różną moje obrazy. I w opisie też masz do czego służy factory i sysupgrade.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

7 (edytowany przez marcin.kasinski 2016-03-13 18:42:53)

Odp: WRT1900ACS pierwsze kroki

Cezary napisał/a:

Na eko.one.pl masz opisane czym się różną moje obrazy. I w opisie też masz do czego służy factory i sysupgrade.


Już się odnalazłem.

Wgrywałem jeszcze raz factory.

Teraz dopiero doczytałem  że powinienem sysupgrade.

Tylko mam pytanie.

Komendą sysupgrade wgrywam pliki bin.

Z trunk ten plik to tar.

W nim nie ma pliku bin
Pewnie czegoś nie doczytałem.

Co z tym tarem mam zrobić ?

8

Odp: WRT1900ACS pierwsze kroki

Wgrać. Zadziała.

OpenWrt 18.06-SNAPSHOT r7260-4b4a6308e7: YunCore SR3200/WNDR4300/TL-WDR4300 v1/WT3020H
Modem 3g: e3372h / NAS: DNS-320LW

Odp: WRT1900ACS pierwsze kroki

Sigma napisał/a:

Wgrać. Zadziała.


No właśnie jak wgrałem samego tara i nic.


Czyli status mamy taki,


1.
Mam WRT1900ACS z wgranym openwrt-15.05-mvebu-armada-385-linksys-cobra-squashfs-factory.img
Z Luci wgrywam openwrt-mvebu-armada-385-linksys-shelby-squashfs-factory.img

Po tym nic nie działa.

2.
Mam WRT1900ACS z wgranym openwrt-15.05-mvebu-armada-385-linksys-cobra-squashfs-factory.img
Z Luci wgrywam openwrt-mvebu-armada-385-linksys-shelby-squashfs-sysupgrade.tar

Po tym nic nie działa.

10

Odp: WRT1900ACS pierwsze kroki

Poniżej wyniku upgrade dla wersji oryginalnej i Twojej:


root@MKrouter2:~# /sbin/sysupgrade -n -v openwrt-mvebu-armada-385-linksys-shelby-squashfs-sysupgrade.tar
killall: watchdog: no process killed
Sending TERM to remaining processes ... uhttpd ntpd dnsmasq udhcpc odhcp6c scp ubusd askfirst logd rpcd netifd odhcpd crond
Sending KILL to remaining processes ... askfirst
Switching to ramdisk...
Performing system upgrade...
UBI device number 2, total 272 LEBs (34537472 bytes, 32.9 MiB), available 248 LEBs (31490048 bytes, 30.0 MiB), LEB size 126976 bytes (124.0 KiB)

Tu się kończy i router przestaje działać.

Dla Twojej wersji:

root@MKrouter2:~# /sbin/sysupgrade -n -v luci-15.05-mvebu-armada-385-linksys-shelby-wrt1900acs-squashfs-sysupgrade.tar
killall: watchdog: no process killed
Sending TERM to remaining processes ... uhttpd ntpd dnsmasq udhcpc odhcp6c ubusd askfirst logd rpcd netifd odhcpd crond
Sending KILL to remaining processes ... askfirst
Switching to ramdisk...
Performing system upgrade...
UBI device number 2, total 272 LEBs (34537472 bytes, 32.9 MiB), available 248 LEBs (31490048 bytes, 30.0 MiB), LEB size 126976 bytes (124.0 KiB)
ubimkvol: error!: bad volume size: "0"
cannot create rootfs volume
ubiupdatevol: error!: file size must be specified if input is stdin
tar: sysupgrade-armada-385-linksys-cobra/root: not found in archive
sysupgrade successful

Tu się kończy i router przestaje działać.

11 (edytowany przez mac.wolski 2016-03-26 18:56:03)

Odp: WRT1900ACS pierwsze kroki

Witam

Również jestem użytkownikiem WRT1900ACS więc aby nie zaśmiecać forum kolejnym wątkiem poproszę o pomoc tu.

Właśnie popsułem swój ruter wgrywając trunk z adresu: https://downloads.openwrt.org/snapshots … actory.img

zamiast:  https://downloads.openwrt.org/latest/mv … actory.img

Ruter o dziwo działa czyli w magiczny sposób daje dostęp do internetu ale już w klasie adresowej 192.168.1.1 czyli innej niż ja ustawiłem w oryginalnym sofcie linksysa. Co ciekawe działa też sieć wifi na moim hasle ale połączyć mogę się tylko w paśmie 2,4 Ghz. Dziwne bo nawet nazwę sieci zachował sprzed instalacji openwrt.

Niestety GUI przez www nie działa: "Serwer 192.168.1.1 odrzucił połączenie. ERR_CONNECTION_REFUSED"

Telnet - "połączenie z hostem nie powiodło się"

SSH przez putty - login as: root i dalej root@192.168.1.1's password: i tu pytanie co dalej - gdyż nie działa ani root, ani admin, ani puste czyli leżymy do góry kołami.


Domyślam się że trunk to wersja bez gui/Luci tak? W takim razie co mogę teraz zrobić żeby bardziej nic nie zepsuć. Znalazłem tu na forum opis "Failsafe" ale nie wiem czy tego próbować.

Czy gdybym sprzętowo - przyciskiem zresetował ruter to będzie to goły podstawowy open wrt z dostępem przez ssh i BEZ hasła?

Czy po zalogowaniu się ssh do rutera można przywrócić oryginalny soft? Posiadam go oczywiście na dysku. Czy też lepiej od razu wgrać właściwą wersję openwrt?


Z góry dziękuję za pomoc.

Linksys WRT1900ACS @ LEDE Reboot 17.01-SNAPSHOT r3491-889638c
Linksys WRT54GL      @ Tomato 1.28
TPlink TL-WA750RE   @ ori soft

12

Odp: WRT1900ACS pierwsze kroki

Ja wgrywałem obraz z trunk i działał bez problemu.

Rozumiem, że ssh Ci działa, tak  ?

Wpisujesz login root i co dalej się dzieje ?

13

Odp: WRT1900ACS pierwsze kroki

SSH przez putty - login as: root i dalej root@192.168.1.1's password: i tu pytanie co dalej - jakie haslo bo root nie dziala - "acces denied"

nie wiem czy powinienem zresetować przyciskiem ruter i czy wtedy będzie to "czysty" open wrt.

czy jeśli uda mi się zalogować przez ssh to będzie możliwość wgrania innego obrazu albo przywrócenie fabrycznego?

Linksys WRT1900ACS @ LEDE Reboot 17.01-SNAPSHOT r3491-889638c
Linksys WRT54GL      @ Tomato 1.28
TPlink TL-WA750RE   @ ori soft

14

Odp: WRT1900ACS pierwsze kroki

Już działa ori soft - reset 15 sekund i trzykrotny reboot przywróciły ruter do życia.

Bardzo dziękuję koledze marcin.kasinski za pomoc.

Będę w tym wątku informował o postępach prac nad openwrt@wrt1900acs


Pozdrawiam

Linksys WRT1900ACS @ LEDE Reboot 17.01-SNAPSHOT r3491-889638c
Linksys WRT54GL      @ Tomato 1.28
TPlink TL-WA750RE   @ ori soft

15

Odp: WRT1900ACS pierwsze kroki

Trunk nie ma domyślnie gui. I jeżeli nie jesteś developerem to raczej nie używaj trunka, bo w nim z dnia na dzień może się wszystko może się zmienić.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

16

Odp: WRT1900ACS pierwsze kroki

Openwrt w wydaniu Cezarego działa od kilku dni smile skończyły się problemy z łączeniem do sieci 5Ghz co potwierdziło tylko moją opinię o "badziewności" ori softu.

Pytania:

1. ruter dostał adresy od operatora (kablówka), łącznie z dnsami ale nie przekazał ich do lanu. ręcznie wpisałem te dnsy w pole "przekierowania DNS" (Lista serwerów DNS do których będą przekazywane zapytania). Czy tak to ma poprawnie wyglądać ?

2. "lista pakietów" - czy z tej pobranej listy mogę zainstalować każdy pakiet? rozumiem że one są dopasowane do tego konkretnego obrazu Cezarego http://dl.eko.one.pl/luci/chaos_calmer/ … actory.img

Linksys WRT1900ACS @ LEDE Reboot 17.01-SNAPSHOT r3491-889638c
Linksys WRT54GL      @ Tomato 1.28
TPlink TL-WA750RE   @ ori soft

17

Odp: WRT1900ACS pierwsze kroki

1. Tak, komputery dostają jako dns adres routera który robi za dns cache. On forwarduje zapytania dalej jak jest  potrzeba
2. Nie do konkretnego routera a do konkretnej platformy/architektury. Możesz zainstalować co chcesz z tej listy, o ile starczy ci miejsca na to.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

18 (edytowany przez mac.wolski 2016-04-10 20:18:49)

Odp: WRT1900ACS pierwsze kroki

1. Po dziesięciu dniach poprawnego działania dziś zaślimaczył dostęp do graficznego panelu przez przeglądarkę (lokalnie) - LuCI rzuciła focha. Pomógł restart a więc pomysł na regularny restart.
Zapis     * 3 * * 1 reboot   w crontab (jak poprawnie umieszczać na forum komendy?) ma rebootować ruter w każdy poniedziałek o 3 w nocy. Dlaczego "graficzny konfigurator crontaba" http://eko.one.pl/cron.php  podaje to w postaci 1 3 * * 1  reboot   ? Czego nie zrozumiałem?


2. W crontab był już zapis: */5 * * * * /sbin/fan_ctrl.sh    To jakiś fan control którego wydaje mi się w moim ruterze nie ma? Co o tym sądzi kolega marcin.kasinski - posiadacz takiego?


3. Próbuję przekonać się do konsoli - putty po ssh działa (lokalnie), loguję się i uruchamiam crontab -e. Jak wyjść z tego edytora po skończonej edycji?


4. Zdalny dostęp po ssh - to bezpieczne żeby otwierać na zewnątrz port 22? Może lepiej jakiś inny? Ale jak wtedy uruchomić nasłuch demona ssh na tym innym porcie?

Linksys WRT1900ACS @ LEDE Reboot 17.01-SNAPSHOT r3491-889638c
Linksys WRT54GL      @ Tomato 1.28
TPlink TL-WA750RE   @ ori soft

19

Odp: WRT1900ACS pierwsze kroki

1. Żeby jawnie było o 3:01. Jakoś nie lubię zostawiać takich domysłów systemowi.
2. Zwykły 1900 ma wentylator i to od tego. A obrazy są wspólne dla tej rodziny to i skrypt został.
3. to jest vi, obsługa - na eko.one.pl (:wq)

http://eko.one.pl/?p=openwrt-konfigurac … estronywan

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

20

Odp: WRT1900ACS pierwsze kroki

Dziękuję za podpowiedzi ale jeszcze raz: to normalna praktyka otwierania na zewnątrz portu 22 dla zdalnego dostępu? Wybaczcie banalne pytania.

Linksys WRT1900ACS @ LEDE Reboot 17.01-SNAPSHOT r3491-889638c
Linksys WRT54GL      @ Tomato 1.28
TPlink TL-WA750RE   @ ori soft

21

Odp: WRT1900ACS pierwsze kroki

Tak, na wanie domyślnie jest wszystko zablokowane. Chcesz się dostać z zewnątrz to musisz odpowiedni port dla usługi otworzyć.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

22 (edytowany przez mac.wolski 2016-04-10 20:59:04)

Odp: WRT1900ACS pierwsze kroki

http://eko.one.pl/?p=openwrt-konfigurac … estronywan - czyli przepis na otwarcie portu 22 dla ssh nie bardzo zadziałał. Rozumiem że powinienem w konsoli (putty po logowaniu jako root) wpisywać kolejno każde z poleceń (np.  uci add firewall rule) i enter? Jeden Efekt jaki to dało to jakaś reguła która zablokowała cały ruch.

Spróbowałem przy pomocy LuCI: Zapora / Reguły ruchu / otwórz port na ruterze i to poszło ale wolałbym w konsoli.

Ogólnie łączność przy pomocy JuiceSSH@android  w Play gsm - działa smile

Linksys WRT1900ACS @ LEDE Reboot 17.01-SNAPSHOT r3491-889638c
Linksys WRT54GL      @ Tomato 1.28
TPlink TL-WA750RE   @ ori soft

23

Odp: WRT1900ACS pierwsze kroki

Przepis jak najbardziej działa - nie jesteś pierwszy który to robi. I dokładnie to samo robi luci.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

24

Odp: WRT1900ACS pierwsze kroki

No więc dla ssh od strony lan pozostawiłem port 22 a dla wan inny (dość wysoki numer - dla bezpieczeństwa) - tak w ramach ćwiczeń i wszystko działa.

Konsolę jakoś opanuję - dziękuję Cezary za pomoc. Dziś nauki wystarczy.

Pozdrawiam

Linksys WRT1900ACS @ LEDE Reboot 17.01-SNAPSHOT r3491-889638c
Linksys WRT54GL      @ Tomato 1.28
TPlink TL-WA750RE   @ ori soft

25 (edytowany przez mac.wolski 2016-04-11 20:34:51)

Odp: WRT1900ACS pierwsze kroki

1. reboot ustawiony w crontab zadziałał ale ruter zapętlił się i restatuje się co ok 1 minutę. Ustawiłem restart na próbę na dziś czyli poniedziałek na godzinę 19.

crontab wygląda tak:

* 19 * * 1 reboot
54 19 * * * /sbin/stat.sh

Co zrobiłem źle?


2. Po takim planowanym reboocie doszedł drugi problem - przestałem się łączyć ssh ze strony wan. Wcześniej ustawiłem w konfigu dropbear inny port dla nasluchu ssh od strony wan: dla przykładu 558. Dla dostępu od lan pozostawiłem port 22. Oczywiście dodałem regułę do firewalla. I to działało bezbłędnie do czasu tego zapętlenia z punktu 1.

Tak wygląda aktualny konfig:


config dropbear
        option PasswordAuth 'on'
        option Interface 'lan'
        option Port '22'

config dropbear
        option PasswordAuth 'on'
        option Interface 'wan'
        option Port '558'


3. Restarty ustały po usunięciu wszystkich wpisów w crontab. Ręcznie uruchomiłem go ponownie. Łączności od strony wan nadal nie ma.


edit:
- dodałem wpis do dropbear:   option GatewayPorts 'on'  - bez zmian - brak dostępu.
- restart rutera - brak dostępu
- wpisałem pod LuCI jeszcze raz port 558 dla wan, zapis i restart i nagle cudownie wszystko ożyło (mimo tego że ten port tam był wpisany!!)
- gdzie robię błąd?

Linksys WRT1900ACS @ LEDE Reboot 17.01-SNAPSHOT r3491-889638c
Linksys WRT54GL      @ Tomato 1.28
TPlink TL-WA750RE   @ ori soft