176

Odp: E3372 w ncm

ok rozumiem.
Troche smiece w watku, nie wiem czy sens zakladac kolejny. Nic raczej nie zmienialem, bylem na basenie, wracam a tu luci http://192.168.0.4/ przekierowuje na http://192.168.0.4/cgi-bin/luci i 403 forbidden (chyba tez mialem 404). SSH sesja zerwana, wiecej sie juz nie polacze (ssh: connect to host 192.168.0.4 port 22: Connection refused). Cudem dziala luci przez IP WLAN (ssh na ten IP tez sie nie udaje, chociaz dropbear slucha na * oraz lacze sie z sieci wew). I badz tu madry... luci +ssh nie dzialaja jak wczesniej. Miejca jeszcze troche jest. Reset urzadzenia nic nie pomaga. Nic nie grzebalem... jakas rada co moge zrobic oprocz kolejnego resetu do ustawien fabrycznych? TIA!

177

Odp: E3372 w ncm

Tryb failsafe (http://eko.one.pl/?p=openwrt-failsafe) i napraw to co zepsułeś.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

178

Odp: E3372 w ncm

Ja tylko tak napomnę, że można się obyć bez usb-modeswitch . Wystarczy przełączyć tryb modemu ręcznie raz i już później nie trzeba instalować usb-modeswitch .  Ja jadę na takiej konfiguracji cały czas:

AT^SETPORT="FF;12,10,16,A2"

Z tym, że nie wiem jak to działa pod windowsem. Na wszystkich linuxach za to bez problemu. big_smile

Morfitronik -- blog o linux'ach, głównie Debian, OpenWRT/LEDE i Android

179

Odp: E3372 w ncm

Tyle że niektóry mają dziwne obawy co do przełączania tego na stałe...

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

180

Odp: E3372 w ncm

Zobacze, cezary - nie psulem nic :-) Czyli ok zainstaluje Twoj obraz, musze sie doszkolic jak wifi odpalic z shella i pozniej dogram luci. Pewnie miejsca mi i tak zabraknie :-/ Hilinkowy jeszcze obsluzy (cdc-ether) z luci.

181

Odp: E3372 w ncm

witam,
Próbowałem uruchomić na Router Station PRO modem E3372H-153 z play i nie mogłem sobie z nim poradzić.
Miałem zamiar uruchomić go w trybie NDIS, przeczytałem wskazówki na stronie eko.one.pl i prześledziłem ten wątek, ale tylko udało mi się go zmusić  do odblokowania PIN, i na tym się kończyło, znalazłem gdzieś na forum openwrt taką komendę:

echo -e "AT^NDISDUP=1,1,\"internet\"\r" > /dev/cdc-wdm0


Po wpisaniu tego wyżej od razu się połączył.
Gdzie robię coś źle? Niestety nie wiem co znaczy ta komenda, ale działa..
Mam jeszcze pytanie o transfery, ile można osiągnąć na tym modemie w ndis, czy ewentualnie jest wolniej w stosunku do hilink?

182

Odp: E3372 w ncm

Nie wiem co robisz źle bo w ogóle nie podałeś konfiguracji. A skrypty openwrt robią m.in dokładnie to samo polecenie.

W hilink jest  najszybszy z tego wszystkiego.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

183

Odp: E3372 w ncm

W modułach nie grzebałem, bo wywnioskowałem, że powinno już być wszystko, co potrzebne w obrazie.
Treść konfigu /etc/config/network

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fda9:bac8:01fc::/48'

config interface 'lan'
    option ifname 'eth1'
    option force_link '1'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.12.1'
    option netmask '255.255.255.0'
    option ip6assign '60'

config interface 'wan'
    option ifname 'wwan0'
       option proto 'ncm'
    option pincode '2518'
        option device '/dev/ttyUSB0'
        option apn 'internet'
    option username 'internet'
    option password 'internet'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '0 1 2 3 4'

Wpisywałem w sekcji device ttyUSB0 i USB1 i cdc-wdm0 też, bez skutku, chyba tylko przy wdm0 nawet nie wpisywał pinu..

184

Odp: E3372 w ncm

ifname możesz skasować z sekcji wan. Skoro załączył się przy cdc-wdm0 to właśnie taki powinien być ustawiony.

Chociaż z doświadczenia wiem ze powinno być /dev/ttyUSB0, bo sam taki modem miałem: http://eko.one.pl/?p=openwrt-3g#obsugamodemwwtrybiencm

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

185

Odp: E3372 w ncm

Przepraszam, wkradł się błąd, powinno być tak:

echo -e "AT^NDISDUP=1,1,\"internet\"\r" > /dev/ttyUSB0

Czy jest jakieś wyjaśnienie dlaczego nie chce normalnie zaskoczyć tylko trzeba go popchnąć ręcznie?
Taki mały offtop, czy używasz modem+router do LTE?
Mi się przegrzewa ten modem jak był w wersji hilink stąd próba zmiany trybu pracy na ndis.

186

Odp: E3372 w ncm

Pewnie że używam, jak kilka tysięcy innych użytkowników tego forum. Myślisz że jak powstały te wszystkie opisy i poradniki?

Hilink jest najmniej bezproblemowy bo jest bezobsługowy praktycznie. Skoro on źle działał to albo masz coś z łączem albo z samym modemem.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

187

Odp: E3372 w ncm

Modemy grzeją się, to normalne, mogą mieć 50-55 stopni na obudowie i niczemu to nie szkodzi. "Przegrzewanie", czyli resetowanie lub zawieszanie się modemu pod wpływem temperatury, jeżeli miał przewiew - nie spotkałem się. Szkoda czasu na walkę z NDIS, jak tylko o to chodzi.

188

Odp: E3372 w ncm

Ja w trybie hilink miałem taki objaw, że wrzuciłem parę plików (każdy po 1GB) do ściągania i przy 6-7 zwiecha i nic dalej, reset usb i wraca do żywych. Transfery mam na poziomie 80/30 mb/s. Zasięg całkiem niezły, więc stawiam na problemy z obciążeniem. Muszę zrezygnować z neostrady i widziałem w LTE dobrą alternatywę, ale nie mogę ze sprzętem dojść do łądu.
Co jest z NDIS, jakiś trudny? Dlaczego szkoda czasu?
Czy jakieś chłodzenie modemu może trzeba zrobić:)?

189

Odp: E3372 w ncm

jakubd napisał/a:

Szkoda czasu na walkę z NDIS, jak tylko o to chodzi.

Tutaj się całkiem z kolegą nie zgodzę, rozumiem Cezarego, bo trudno setny raz tłumaczyć dlaczego modem nie chce się połączyć-nie mając dostępu do sprzętu (w HiLinku za całe połączenie odpowiada sam modem, router z OpenWRT, innym softem nie ma nic do roboty), gdyż tam gdzie NDIS ma problemy z nawiązaniem/utrzymaniem połączenia one wystąpią również przy HiLinku ( najczęściej występują na przeciążonej sieci Play, wirtualnych operatorów-bez resetu zasilania nawet HiLink nie daje rady), a problemy HiLinka to nie tylko przegrzewanie się, to również "złe działanie serwerów DNS"-wówczas zamiast oczekiwanego adresu w sieci pojawia się strona konfiguracji HiLinka, sam modem w tej wersji jest bezkonkurencyjny w narzędziu wyboru częstotliwości LTE (modowane softy) i jak nastawimy się na używanie go w tej wersji-to rozebrać, przypiąć opaską jakiś aluminiowy radiator.

190

Odp: E3372 w ncm

Zainstalowałem radiator na modemie (radiator pobrałem ze starej karty graficznej i udało mi się to przykleić na klej termoprzewodzący). Niestety, równolegle wgrałem znowu soft Hilink do tego modemu i teraz nie wiem co jest przyczyną poprawy pracy, czy ponowne wgranie oprogramowania czy radiator, ale muszę przyznać, że hilink wyciska najwyższe transfery.
Na razie modem sprawuje się świetnie, router wstawiłem w DMZ i mam dostęp do portów z zewnątrz (zew. IP). Pozdrawiam

191

Odp: E3372 w ncm

lukaszp napisał/a:

Zainstalowałem radiator na modemie (radiator pobrałem ze starej karty graficznej i udało mi się to przykleić na klej termoprzewodzący). Niestety, równolegle wgrałem znowu soft Hilink do tego modemu i teraz nie wiem co jest przyczyną poprawy pracy, czy ponowne wgranie oprogramowania czy radiator, ale muszę przyznać, że hilink wyciska najwyższe transfery.
Na razie modem sprawuje się świetnie, router wstawiłem w DMZ i mam dostęp do portów z zewnątrz (zew. IP)

Ja testowałem w Łodzi oba tryby pracy E3372/E3276 i różnicy nie widziałem żadnej w transferach-sieć max. wyciągała do 70Mbps (w samym teście jest taka różnica że HiLink od razu wchodzi na max. prędkości, NDIS się rozpędza), teraz w innej lokalizacji mam złożony Nexx WT3020+E398 i w NDIS ten stary modem wyciąga do 85Mbps (zestaw zasilam PoE, zamontowany na zewnątrz w alu-obudowie, jestem ciekaw czy wytrzyma w zimie? ). Co do przekierowań na DMZ, nie miałem żadnych problemów-również korzystam z publicznego IP. Z radiatorem nie powinno być problemów (w upalne lato 2015r. miałem tak zaopatrzony E3276HiLink i działał bezproblemowo, a bez radiatora robił "fikołki" aż miło wink, do wydania Gargoyle 1.9 by obsy stary sterownik NDIS-NCM robił narzut opóźnień pakietów ok. 20ms).