1

(49 odpowiedzi, napisanych Oprogramowanie)

Cezary napisał/a:

O.... JA... Proszę paaaaana, taki błąd. Koniec świata i w ogóle. Jak żyć? zaraz zacznie się lament. Używam lede od Cezarego przecież....

Więc co masz zrobić jeżeli nie chcesz czekać na nowe obrazy:
- podłączasz router do internetu (!)
- robisz opkg update
- robisz opkg install wpad-mini

Możesz po prostu też odinstalować pakiet i zainstalować go ponownie, łącznie z innymi zależnościami. Ważne że pakiet miał w nazwie np. wpad-mini_2016-12-19-ad02e79d-5_mips_24kc.ipk - o tą piątkę się rozchodzi. 4 to źle, 5 lub wyżej to dobrze. I pamiętaj że telefony też trzeba zaktualizować żeby nikt nie podejrzał hasła do facebooka....

@Cezary
Aby się uchronić przed atakiem trzeba patchować klienta i AP to zrozumiałe.
Jednak czy dobrze rozumiem że ta wersja zabezpiecza router tylko w trybie AP ?
czy też router w trybie "Bridged Client" potrzebuje osobnej poprawki czy ta załatwi sprawę ?

2

(261 odpowiedzi, napisanych Oprogramowanie)

@Cezary
Nie wiesz przypadkiem, czy układ mt7530 wspiera sprzętowy IGMP snooping ?

Z tego co pokazałeś swconfig to widzimy że dla tego układu "mt7530(mt7530)" LEDE nie wspiera "igmp_snooping",
pytanie jest czy ten układ w ogóle to wspiera ?
Widzę tu (https://github.com/andy-padavan/rt-n56u … es.eng.txt)
zmianę dla mt7530: "Ethernet switch: fixed MT7620/MT7621/MT7530 issue with HW IGMP snooping."
co sugeruje że ma ten sprzętowy IGMP snooping (zastanawiam się czy jest szansa że kiedyś się to znajdzie w LEDE) ?

Jest gdzieś jakiś namiar na dokumentację tego układu ?
Ktoś może potwierdzić że mt7530 ma sprzętowy IGMP snooping ?

3

(261 odpowiedzi, napisanych Oprogramowanie)

miguelos napisał/a:

- sorki nie wiedzialem, nazwe maja ta sama hmm

Jak dla mnie mają różne nazwy
Xiaomi Router 3
Xiaomi Router 3G

Jest także wersja 3A (https://wikidevi.com/wiki/List_of_Xiaom … ss_Devices)

4

(41 odpowiedzi, napisanych Oprogramowanie)

kabal napisał/a:

Witam.

Nie chce zakładać nowego wątku aby nie zaśmiecać forum - a mam pytanko.

Jest możliwość powrotu wersji v4 z Lede do oryginalnego firmware? Akurat na chwile muszę wrócić do oryginału..


Zaznaczę że pobrałem od Obsego z serwera plik "wr1043ndv4_tp_recovery.bin" zakładając że jest to "obcięty" obraz ale sysupgrade wywala mi błąd:

root@LEDE:/tmp# sysupgrade -n wr1043ndv4_tp_recovery.bin
Image metadata not found
Invalid image type.
Image check 'platform_check_image' failed.

Jak to ugryźć?

Dzięki z góry.

Użyj tej metody:
https://morfitronik.pl/jak-przy-pomocy- … r-tp-link/

5

(261 odpowiedzi, napisanych Oprogramowanie)

@Cezary
1. jestem monotematyczny więc zapytam o vlany i igmp_snooping
można prosić o "swconfig dev switch0 help" ?
2. rozumiem że to ten router https://www.gearbest.com/wireless-route … 42436.html ?
z usb 3.0 ? zmierzasz zrobić jakieś testy wydajności usb 3.0 ?

6

(1,161 odpowiedzi, napisanych Oprogramowanie)

Cezary napisał/a:

wdr3600? Wyjaśnienie będziesz miał w tym starym wątku.

@Cezary

sprawdz proszę w "swconfig dev switch0 help" dla wdr3600, czy obsługuje "igmp_snooping"
bo tu https://wiki.openwrt.org/toh/tp-link/tl-wdr3600
widać że switch tego nie obsługuje, ale może coś się zmieniło ?
Jak dobrze patrzę w źródła to chyba jest dla ar8327 (https://github.com/lede-project/source/ … 1300-L1302)

Pomijając "igmp_snooping" stosunek ceny/możliwości to chyba wdr3600 wypada lepiej niż 1043nd v4 ?

Cezary napisał/a:

Chyba była szansa na to.

Trudno, trochę mnie zmylił ten "pies pogrzebany" i być może zły kierunek poszukiwań.
No nic skoro na wdr3600 działa na 100% to czemu nie.

Zatem wygląda na to że chyba dobrze początkowo rozumowałem że enable_vlan4k nie jest konieczny a raczej vid ...

Tak czy siak, dzięki za pomoc.

Cezary napisał/a:

No i chyba jednak Ci się nie chciało sprawdzić skoro piszesz nowe wątki.

Nie do końca się nie chciało, a musiałem szybko oddać 1043nd v4 bo mi dziś mijało 15 dni na zwrot ;-)

Cezary napisał/a:

I co? Pingują się wzajemnie, można ssh się zalogować itd. Czyli działa. vlan 1 to standardowy lan openwrt, vlan 2 to wan, moje to vlany 2055 które zrobiłem na jednym z portów na switchu.

Czy dobrze rozumiem że była szansa zrobić to na 1043 nd v4 ?
I z tego co widzę w moim przypadku wystarczyło w "lan" zrobić

option ifname 'eth0.4000'

bo resztę miałem analogicznie.

9

(1,161 odpowiedzi, napisanych Oprogramowanie)

Witam,

Poszukuję routerka, skromnego tak za 200 PLN, minimalne wymagania:
a. radio w standardzie N
b. RAM 64MB
c. usb 2.0
d. obsługa vlan powyżej 4K

e. gigabit porty ethernet
f. obsługa igmp_snooping na switch

Pkt a) - d) koniecznie, brak e)-f) przeżyje.
Ktoś coś poradzi ?

Cezary napisał/a:

W niektórych układach domyślnie można zrobić tylko vlany do numerach do  16 lub 128, próba utworzenie vlanu o większym numerze powoduje zgłoszenie błędu. Domyślnie one nie włączają i nie obsługują vlanów o większych numerach, choć chip to potrafi. I żeby to włączyć potrzebne jest odpowiednie przestawienie rejestrów (konfiguracji) chipu switcha, a to robi właśnie kod który ukrywa się za opcją "enable_vlan4k".

Każdy chip ma swoje możliwości i swoją konfigurację. Najprościej będzie jak po prostu znajdziesz kartę katalogową dla tego chipu  i zobaczysz jak oni rozumieją te opcje.

Czyli opcja vid:

  • pozwala TYLKO na rozgraniczenie nazwy interfejsu (np. eth0.4) od numeru VLAN (np. vid=117)

  • jednocześnie ograniczona jest z góry ilością obsługiwanych VLAN, vid=(0, ilość_VLAN)

Jednym słowem opcja z vid może sobie być z przedziału (0-4094), ale ma prawo zadziałać tylko do górnej granicy wyznaczonej przez liczbę vlanów.

Czyli w moim przypadku ustawienie vid zadziała tylko dla zakresu (0-128).
Gdyby dla tego układu doszła opcja "enable_vlan4k", wówczas zadziała dla całego zakresu (0-4094).

Czy dobrze to rozumiem ?

Cezary napisał/a:

Jak masz czas to sprawdź to sobie: zrób jedną i drugą konfigurację na jakimś niskim numerze np.99, uruchom tcpdumpa i zobacz co w ramkach ethernetowych leci.

Sprawdzę, sprawdzę ...
choć zanim zacznę zabawę zawszę wolę zapoznać się z teorią (poczytać i dopytać) a potem praktykować ;-)
choćby po to żeby nie próbować durnych scenariuszy.

Cezary napisał/a:

Co jest czym masz na wiki: https://wiki.openwrt.org/doc/uci/networ … tch_config

Tak, czytałem to i widzę cyt. "The number of the VLAN is specified on the option vlan line. The VID (VLAN ID) associated with a VLAN is by default the same as the number of the VLAN. This is overridden by using an option vid line so, for example, that VLAN 1 could use VID 100."

Co rozumiem właśnie tak że numer VLAN może być nadpisany poprzez opcję vid.
O "enable_vlan4k" nic tam nie ma, a Ty napisałeś

Cezary napisał/a:

Dla niektórych routerów trzeba specjalne włączyć obsługę VLANów "o wysokich numerach" dodając opcję option enable_vlan4k 1 w sekcji config switch w pliku /etc/config/network.

Co ja rozumiałbym jako możność wykorzystania na raz 4096 vlanów,
a istnienie opcji "Attribute 1 (int): vid (VLAN ID (0-4094))" sugeruje że numery/id tych VLANów mogą być z przedziału 0-4094,
niezależnie od ich ilości ?

Czy ostatni akapit ma sen ? czy to jakieś bzdury ?

Cezary napisał/a:

A i tu jest pies chyba pogrzebany....

@Cezary,

Czytałem Twój poradnik, http://eko.one.pl/?p=openwrt-vlan
Ale czy mógłbym prosić o doprecyzowanie o co chodzi z tymi "vid" ?
Bo dla wałkowanego tu przykładu, AR8337 ma 128 vlanów,
ale ma też "Attribute 1 (int): vid (VLAN ID (0-4094))"
Czy czym zatem różni się takie konfigurowanie switch

a)

config switch_vlan
        option vlan '4'
        option vid '4000'
        option ports '5t 0t'
        option device 'switch0'

od
b)

config switch_vlan
        option vlan '4000'
        option ports '5t 0t'
        option device 'switch0'

Czy nie jest tak (albo powinno tak to działać)  że "enable_vlan4k" pozwala na wykorzystanie na raz 4096 vlanów,
a vid jest id=numerem VLANu określonym przez liczbę bitów w ramce ethernetowej ?

Zatem czy nie powinno się dać w tym układzie wykorzystać 128 różnych vlanów, ale z numerami od 0-4094 ?
Czy "vid" do tego nie służy ? A może w ogólności tak właśnie jest tylko że jakiś błąd jest w LEDE ?

13

(1 odpowiedzi, napisanych Oprogramowanie)

Cześć,

Czy orientuje się ktoś czy jest gdzieś jakaś baza danych parametrów obsługiwanych przez swconfig
dla danego typu switcha (dla openwrt lub LEDE) ?

Pewnie można wczytać się w źródła
(zdaje się że z tej lokalizacji https://github.com/lede-project/source/ … rs/net/phy)
ale mi chodzi o jakąś wygodną formę, coś jak zrzut "swconfig dev switch0 help" dla każdego układu.

Widzę parę przykładowych na https://wiki.openwrt.org/doc/techref/swconfig, ale to trochę za mało.
Dla mnie np. bardzo istotne np. wiedza dot. tego czy wspierany jest "enable_vlan4k", "igmp_snooping".
Wiem że istnieją niuanse choćby dla układu IPXXX gdzie IP175C nie wspiera "enable_vlan4k" a IP175D już tak
(cyt. http://eko.one.pl/forum/viewtopic.php?pid=16758#p16758).


P.S.
@Cezary może byłbyś wstanie zapoczątkować coś na modłę RouterDatabase ? taki SwitchDatabase ?
Gdzie RouterDatabase linkowałby do SwitchDatabase (a tu byłby choćby zrzuty "swconfig dev switch0 help",
w przyszłości może mogłaby to być lista z "checkbox" ale na początek to za dużo pracy).
Być może z opcją że każdy kto mógłby - dorzucałby takie informacje wraz z wersją LEDE.

Cezary napisał/a:

@alossek: to się w ogóle nie kompiluje. Brakuje funkcji niektórych.

Ok, trudno.
Dzięki za próbe.

Pozdrawiam!

Spoko, poczekam.

@Cezary,

Miałbym wielką i zarazem beszczelną prośbę, czy mogłbyś przekompilować obraz dla 1043nd v4 z tymi patch'ami
(https://pastebin.com/q4f0z7Fa, https://pastebin.com/MQJqayrt) ?

Patch'e przygotowałem z podesłanego przez Ciebie źrodła (na marginesie pasowały do kodu źródłowego z okolic 2014 roku).
Po moich przeróbkach pasją do rewizji LEDE Twoich ostatnich obrazów (czyli r3514-97ebdf9).
Narobiłem się z tym strasznie i już nie mam siły stawiać środowiska do wybudowania obrazów.
A Ty pewnie masz wszystko gotowe ;-)

Zdaje się że trzeba by jakoś kompilować aby dyrektywa kompilatora miała ustawione "OK_PATCH",
bo z ich użyciem podefiniowane są #if w kodzie.

Byłbym wdzięczny.
Pozdrawiam.

Jest nawet od dawna zgłoszenie
https://dev.openwrt.org/ticket/22316

Cezary napisał/a:

http://www.cnblogs.com/nicephil/p/6606716.html

Gość się załatał, choć czy to działa to już ktoś musi sobie przekompilować i sprawdzić na rzeczywistym sprzęcie.

O kurka, nie mam wyboru i będę musiał to zrobić (bo jak nie to sprzęt poleci na allegro) ...
czeka mnie męka z budowaniem :-(

Cezary napisał/a:

A i tu jest pies chyba pogrzebany....

Czyli to pewne że się nie da ?

Cezary napisał/a:

Attribute 1 (int): vid (VLAN ID (0-4094))

Więc tak. Ustaw sobie vlan 4000, eth0.4000 i zobacz.

No własnie tak miałem wcześniej

VLAN 4000:
        vid: ???
        ports: ???

To chyba nie zadziała, bo vlanów jest tylko do 127:
switch0: ag71xx-mdio.0(Atheros AR8337), ports: 7 (cpu @ 0), vlans: 128

Cześć,

Pytanie za 100 pkt, czy da się zrobić (na 1043nd v4) VLAN dla tag = 4000 (dla tagów wyższych niż 128) ?

switch0: ag71xx-mdio.0(Atheros AR8337), ports: 7 (cpu @ 0), vlans: 128
     --switch
        Attribute 1 (int): enable_vlan (Enable VLAN mode)
        Attribute 2 (none): reset_mibs (Reset all MIB counters)
        Attribute 3 (int): enable_mirror_rx (Enable mirroring of RX packets)
        Attribute 4 (int): enable_mirror_tx (Enable mirroring of TX packets)
        Attribute 5 (int): mirror_monitor_port (Mirror monitor port)
        Attribute 6 (int): mirror_source_port (Mirror source port)
        Attribute 7 (int): arl_age_time (ARL age time (secs))
        Attribute 8 (string): arl_table (Get ARL table)
        Attribute 9 (none): flush_arl_table (Flush ARL table)
        Attribute 10 (int): igmp_snooping (Enable IGMP Snooping)
        Attribute 11 (int): igmp_v3 (Enable IGMPv3 support)
        Attribute 12 (none): apply (Activate changes in the hardware)
        Attribute 13 (none): reset (Reset the switch)
     --vlan
        Attribute 1 (int): vid (VLAN ID (0-4094))
        Attribute 2 (ports): ports (VLAN port mapping)
     --port
        Attribute 1 (none): reset_mib (Reset single port MIB counters)
        Attribute 2 (string): mib (Get port's MIB counters)
        Attribute 3 (int): enable_eee (Enable EEE PHY sleep mode)
        Attribute 4 (none): flush_arl_table (Flush port's ARL table entries)
        Attribute 5 (int): igmp_snooping (Enable port's IGMP Snooping)
        Attribute 6 (int): pvid (Primary VLAN ID)
        Attribute 7 (unknown): link (Get port link information)

Jak widać 1043nd v4 nie ma enable_vlan4k (jak było w v1), czy da się to zrobić jakoś z użyciem "vid" ?
Kombinowałem tak (dodałem do standardowej konfiguracji):

config interface 'wan_4000'
        option ifname 'eth0.4'
        option proto 'dhcp'
        option metric '20'

config switch_vlan
        option vlan '4'
        option vid '4000'
        option ports '5t 0t'
        option device 'switch0'

Wynik:

root@LEDE:~# swconfig dev ag71xx-mdio.0 vlan 4 show
VLAN 4:
        vid: 4000
        ports: 0t 5t

Ale z DHCP nie dostaje ip.


Da się to zrobić ?
Pozdrawiam i proszę o pomoc.

22

(7 odpowiedzi, napisanych Oprogramowanie)

Bartek1202 napisał/a:

kwestia przydzielania adresów z DHCP myśle, że nie ma tu znaczenia. Problemem jest że multikasty działają tylko w L2, nie ma natomiast możliwości routingu multikastów za NAT za moim routerem (router2), choć jest prawidłowo uruchomiony PIM jak i odblokowane IGMP na routerze. Nie mam pomysłu co jeszcze mogę uruchomić by podłączając dekoder za moim routerem były odbierane kanały IPTV. Rekonfiguracja mojego routera aby pracował w L2 odpada, więc zostaje tylko uruchomienie tego w jakiś sposób w L3. Sygnał od operatora dla IPTV i tak jest kodowany, ale podłączając dekoder z kartą po internecie chciałbym odpierać strumienie video. Dodam jeszcze że usługi takie jak VOD działają na dekoderze podłączonym za moim routerem, ale być może dlatego, że jest to inaczej odbierane (więc tutaj mogę podejrzewać, że nie ma tam żadnych VLANów do wysyłania żądań jak i odbioru).

Mam wrażenie że aby to zadziałało to igmpproxy "musiałoby" działać na router1 i router2.
A może pozbyć się router1 i tak skonfigurować router2 aby wszystko do niego podłączyć ?

23

(7 odpowiedzi, napisanych Oprogramowanie)

Trochę się zgubiłem jak masz to wszystko połączone, czy dobrze rozumiem:

1. router1 masz od dostawcy 192.168.100.1
2. gdy podłączysz dekoder (pod router1)  to dostaje on adres 192.168.100.2 z router1 - wtedy działają multikasty
3. gdy podłączysz swój router2 z LEDE  (pod router1), to dostaje on adres 192.168.100.254 i router2 ma LAN 192.168.1.1/24
4. gdy podłączysz dekoder (pod swój router2), to dostaje adres 192.168.1.x z router2 - wtedy NIE masz multikastów  ?

Czy tak ? Jak nie tak to rozrysuj jak to jest połączone i w której konfiguracji działa a w której nie.

24

(7 odpowiedzi, napisanych Oprogramowanie)

Wypróbuje może tak:

config igmpproxy                                 
        option quickleave 1                      
                                                 
config phyint eth0                               
        option network wan                       
        option direction upstream                
        list altnet 192.168.100.0/24             
                                                         
config phyint br-lan                             
        option network lan                       
        option direction downstream
        list altnet 192.168.1.0/24               

A jak nie pójdzie to, standardowo ...

config igmpproxy                                 
        option quickleave 1                      
                                                 
config phyint eth0                               
        option network wan                       
        option direction upstream                
        list altnet 0.0.0.0/0
                                                         
config phyint br-lan                             
        option network lan                       
        option direction downstream

Multikasty masz na wan ? Czy może wan w tagowanej podsieci ?
Jak podłączysz się pod kabel od odstawy bezpośrednio np. komputerem to masz dostęp do multicastów (powiedzmy przez vlc -vvv udp:@239.255.12.42, gdzie 239.255.12.42 to adres strumienia wideo) ?

25

(7 odpowiedzi, napisanych Oprogramowanie)

Pokaż konfigurację

/etc/config/network
/etc/config/igmpproxy

i log po uruchomieniu igmpproxy