1

(32 odpowiedzi, napisanych Sprzęt)

No tak widać że zajęty:

root@OpenWrt:~# free 
              total        used        free      shared  buff/cache   available
Mem:          59560       23584       31752         100        4224       21964
Swap:             0           0           0

Obraz Twój w żaden sposób nie modyfikowany.

root@OpenWrt:/tmp# df -h
Filesystem                Size      Used Available Use% Mounted on
/dev/root                 2.5M      2.5M         0 100% /rom
tmpfs                    29.1M    100.0K     29.0M   0% /tmp
/dev/mtdblock5            3.8M    296.0K      3.5M   8% /overlay
overlayfs:/overlay        3.8M    296.0K      3.5M   8% /
tmpfs                   512.0K         0    512.0K   0% /dev

2

(32 odpowiedzi, napisanych Sprzęt)

W zasadzie to oprócz statystyk to nic ponad stan, obraz jest Twój bez luci.

BusyBox v1.30.1 () built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------------------------------
 |                                                                           |
 | OpenWrt 19.07-SNAPSHOT, r10532-cf3b50377e                                 |
 |                                                                           |
 | Build time: 2019-09-14 23:59 CEST                                         |
 | Cezary Jackiewicz (obsy), [url]http://eko.one.pl[/url]                               |
 |                                                                           |
 -----------------------------------------------------------------------------
 | Machine: TP-Link Archer C2 v3                                             |
 | Uptime: 0d, 12:13:18                                                      |
 | Load: 0.07 0.02 0.00                                                      |
 | Flash: total: 3.8MB, free: 3.5MB, used: 8%                                |
 | Memory: total: 58.2MB, free: 32.1MB, used: 44%                            |
 | WAN:                                                                      |
 | LAN: 192.168.20.20, leases: 0                                             |
 | radio0: mode: ap, ssid: Diablo, channel: auto, conn: 1                    |
 | radio1: mode: ap, ssid: Mefisto, channel: 13, conn: 2                     |
 -----------------------------------------------------------------------------

3

(32 odpowiedzi, napisanych Sprzęt)

Mam kłopot z tym urządzeniem:

root@OpenWrt:~# dmesg
[    0.000000] Linux version 4.14.143 (cezary@eko.one.pl) (gcc version 7.4.0 (OpenWrt GCC 7.4.0 r10532-cf3b50377e)) #0 Sat Sep 14 15:10:41 2019
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU0 revision is: 00019750 (MIPS 74Kc)
[    0.000000] MIPS: machine is TP-Link Archer C2 v3
[    0.000000] SoC: Qualcomm Atheros QCA956X ver 1 rev 0
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 04000000 @ 00000000 (usable)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x0000000000000000-0x0000000003ffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x0000000000000000-0x0000000003ffffff]
[    0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x0000000003ffffff]
[    0.000000] On node 0 totalpages: 16384
[    0.000000] free_area_init_node: node 0, pgdat 804f9f30, node_mem_map 81008440
[    0.000000]   Normal zone: 128 pages used for memmap
[    0.000000]   Normal zone: 0 pages reserved
[    0.000000]   Normal zone: 16384 pages, LIFO batch:3
[    0.000000] random: get_random_bytes called from 0x804fd740 with crng_init=0
[    0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
[    0.000000] pcpu-alloc: [0] 0
[    0.000000] Built 1 zonelists, mobility grouping on.  Total pages: 16256
[    0.000000] Kernel command line: console=ttyS0,115200n8 rootfstype=squashfs,jffs2
[    0.000000] PID hash table entries: 256 (order: -2, 1024 bytes)
[    0.000000] Dentry cache hash table entries: 8192 (order: 3, 32768 bytes)
[    0.000000] Inode-cache hash table entries: 4096 (order: 2, 16384 bytes)
[    0.000000] Writing ErrCtl register=00000000
[    0.000000] Readback ErrCtl register=00000000
[    0.000000] Memory: 58332K/65536K available (4023K kernel code, 160K rwdata, 532K rodata, 1228K init, 211K bss, 7204K reserved, 0K cma-reserved)
[    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] NR_IRQS: 51
[    0.000000] CPU clock: 775.000 MHz
[    0.000000] clocksource: MIPS: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 4932285024 ns
[    0.000007] sched_clock: 32 bits at 387MHz, resolution 2ns, wraps every 5541893118ns
[    0.008227] Calibrating delay loop... 385.84 BogoMIPS (lpj=1929216)
[    0.074770] pid_max: default: 32768 minimum: 301
[    0.079794] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.086774] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.097768] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
[    0.108166] futex hash table entries: 256 (order: -1, 3072 bytes)
[    0.114665] pinctrl core: initialized pinctrl subsystem
[    0.122213] NET: Registered protocol family 16
[    0.129504] PCI host bridge /ahb/apb/pcie-controller@18250000 ranges:
[    0.136347]  MEM 0x0000000012000000..0x0000000013ffffff
[    0.141851]   IO 0x0000000000000000..0x0000000000000000
[    0.161819] PCI host bridge to bus 0000:00
[    0.166145] pci_bus 0000:00: root bus resource [mem 0x12000000-0x13ffffff]
[    0.173424] pci_bus 0000:00: root bus resource [io  0x0000]
[    0.179291] pci_bus 0000:00: root bus resource [??? 0x00000000 flags 0x0]
[    0.186450] pci_bus 0000:00: No busn resource found for root bus, will use [bus 00-ff]
[    0.194828] pci 0000:00:00.0: [168c:0050] type 00 class 0x028000
[    0.194880] pci 0000:00:00.0: reg 0x10: [mem 0x00000000-0x001fffff 64bit]
[    0.194932] pci 0000:00:00.0: reg 0x30: [mem 0x00000000-0x0000ffff pref]
[    0.195002] pci 0000:00:00.0: supports D1
[    0.195009] pci 0000:00:00.0: PME# supported from D0 D1 D3hot
[    0.195182] pci_bus 0000:00: busn_res: [bus 00-ff] end is updated to 00
[    0.195205] pci 0000:00:00.0: BAR 0: assigned [mem 0x12000000-0x121fffff 64bit]
[    0.202951] pci 0000:00:00.0: BAR 6: assigned [mem 0x12200000-0x1220ffff pref]
[    0.213205] clocksource: Switched to clocksource MIPS
[    0.219425] NET: Registered protocol family 2
[    0.224801] TCP established hash table entries: 1024 (order: 0, 4096 bytes)
[    0.232157] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
[    0.238903] TCP: Hash tables configured (established 1024 bind 1024)
[    0.245732] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.251896] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.258746] NET: Registered protocol family 1
[    0.263407] PCI: CLS 0 bytes, default 32
[    0.265965] Crashlog allocated RAM at address 0x3f00000
[    0.272627] workingset: timestamp_bits=30 max_order=14 bucket_order=0
[    0.283701] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.289844] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.308395] io scheduler noop registered
[    0.312525] io scheduler deadline registered (default)
[    0.319682] pinctrl-single 1804002c.pinmux: 544 pins at pa b804002c size 68
[    0.328003] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
[    0.336790] console [ttyS0] disabled
[    0.340587] 18020000.uart: ttyS0 at MMIO 0x18020000 (irq = 9, base_baud = 1562500) is a 16550A
[    0.349720] console [ttyS0] enabled
[    0.357275] bootconsole [early0] disabled
[    0.375400] m25p80 spi0.0: gd25q64 (8192 Kbytes)
[    0.380211] 5 fixed-partitions partitions found on MTD device spi0.0
[    0.386803] Creating 5 MTD partitions on "spi0.0":
[    0.391758] 0x000000000000-0x000000020000 : "factory-uboot"
[    0.398209] 0x000000020000-0x000000030000 : "uboot"
[    0.403939] 0x000000030000-0x0000007d0000 : "firmware"
[    0.412371] 2 uimage-fw partitions found on MTD device firmware
[    0.418527] Creating 2 MTD partitions on "firmware":
[    0.423677] 0x000000000000-0x0000001852cb : "kernel"
[    0.429453] 0x0000001852cb-0x0000007a0000 : "rootfs"
[    0.435228] mtd: device 4 (rootfs) set to be root filesystem
[    0.441105] 1 squashfs-split partitions found on MTD device rootfs
[    0.447533] 0x0000003d0000-0x0000007a0000 : "rootfs_data"
[    0.453789] 0x0000007e0000-0x0000007f0000 : "info"
[    0.459366] 0x0000007f0000-0x000000800000 : "art"
[    0.465888] libphy: Fixed MDIO Bus: probed
[    1.143557] libphy: ag71xx_mdio: probed
[    1.150497] switch0: Atheros AR8337 rev. 2 switch registered on mdio-bus.0
[    1.804680] ag71xx 19000000.eth: connected to PHY at mdio-bus.0:00 [uid=004dd036, driver=Atheros AR8216/AR8236/AR8316]
[    1.816268] eth0: Atheros AG71xx at 0xb9000000, irq 4, mode: sgmii
[    1.825278] NET: Registered protocol family 10
[    1.835084] Segment Routing with IPv6
[    1.838944] NET: Registered protocol family 17
[    1.843620] bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this.
[    1.857018] 8021q: 802.1Q VLAN Support v1.8
[    1.862735] hctosys: unable to open rtc device (rtc0)
[    1.873060] VFS: Mounted root (squashfs filesystem) readonly on device 31:4.
[    1.887047] Freeing unused kernel memory: 1228K
[    1.891723] This architecture does not have kernel memory protection.
[    2.494315] init: Console is alive
[    2.498019] init: - watchdog -
[    2.553227] random: fast init done
[    3.455987] kmodloader: loading kernel modules from /etc/modules-boot.d/*
[    3.567704] kmodloader: done loading kernel modules from /etc/modules-boot.d/*
[    3.585832] init: - preinit -
[    4.683537] random: jshn: uninitialized urandom read (4 bytes read)
[    4.918575] random: jshn: uninitialized urandom read (4 bytes read)
[    5.122981] random: jshn: uninitialized urandom read (4 bytes read)
[    6.429088] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[    6.435243] IPv6: ADDRCONF(NETDEV_UP): eth0.1: link is not ready
[    6.474309] urandom_read: 4 callbacks suppressed
[    6.474316] random: procd: uninitialized urandom read (4 bytes read)
[    7.474529] eth0: link up (1000Mbps/Full duplex)
[    7.479386] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[    7.486194] IPv6: ADDRCONF(NETDEV_CHANGE): eth0.1: link becomes ready
[    9.665699] jffs2: notice: (461) jffs2_build_xattr_subsystem: complete building xattr subsystem, 9 of xdatum (0 unchecked, 7 orphan) and 11 of xref (7 dead, 0 orphan) found.
[    9.683588] mount_root: switching to jffs2 overlay
[    9.708274] overlayfs: upper fs does not support tmpfile.
[    9.720097] urandom-seed: Seeding with /etc/urandom.seed
[    9.815723] eth0: link down
[    9.835239] procd: - early -
[    9.838302] procd: - watchdog -
[   10.409589] procd: - watchdog -
[   10.413104] procd: - ubus -
[   10.437996] random: ubusd: uninitialized urandom read (4 bytes read)
[   10.467321] random: ubusd: uninitialized urandom read (4 bytes read)
[   10.475085] procd: - init -
[   11.233499] kmodloader: loading kernel modules from /etc/modules.d/*
[   11.256836] ip6_tables: (C) 2000-2006 Netfilter Core Team
[   11.278071] Loading modules backported from Linux version v4.19.66-0-g893af1c79e42
[   11.285932] Backport generated by backports.git v4.19.66-1-0-g354501da
[   11.316531] ip_tables: (C) 2000-2006 Netfilter Core Team
[   11.337607] nf_conntrack version 0.5.0 (1024 buckets, 4096 max)
[   11.349153] urngd: v1.0.0 started.
[   11.438170] xt_time: kernel timezone is -0000
[   11.637456] PPP generic driver version 2.4.2
[   11.654002] NET: Registered protocol family 24
[   11.699665] random: crng init done
[   11.705971] ath10k 4.19 driver, optimized for CT firmware, probing pci device: 0x50.
[   11.715680] PCI: Enabling device 0000:00:00.0 (0000 -> 0002)
[   11.721683] ath10k_pci 0000:00:00.0: pci irq legacy oper_irq_mode 1 irq_mode 0 reset_mode 0
[   11.997405] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/fwcfg-pci-0000:00:00.0.txt failed with error -2
[   12.008311] ath10k_pci 0000:00:00.0: Falling back to user helper
[   12.203597] firmware ath10k!fwcfg-pci-0000:00:00.0.txt: firmware_loading_store: map pages failed
[   12.212924] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/pre-cal-pci-0000:00:00.0.bin failed with error -2
[   12.224010] ath10k_pci 0000:00:00.0: Falling back to user helper
[   12.402260] firmware ath10k!pre-cal-pci-0000:00:00.0.bin: firmware_loading_store: map pages failed
[   12.412894] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/QCA9887/hw1.0/ct-firmware-5.bin failed with error -2
[   12.424260] ath10k_pci 0000:00:00.0: Falling back to user helper
[   12.597487] firmware ath10k!QCA9887!hw1.0!ct-firmware-5.bin: firmware_loading_store: map pages failed
[   12.607301] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/QCA9887/hw1.0/ct-firmware-2.bin failed with error -2
[   12.618647] ath10k_pci 0000:00:00.0: Falling back to user helper
[   12.798565] firmware ath10k!QCA9887!hw1.0!ct-firmware-2.bin: firmware_loading_store: map pages failed
[   12.808383] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/QCA9887/hw1.0/firmware-6.bin failed with error -2
[   12.819468] ath10k_pci 0000:00:00.0: Falling back to user helper
[   12.992569] firmware ath10k!QCA9887!hw1.0!firmware-6.bin: firmware_loading_store: map pages failed
[   13.002118] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/QCA9887/hw1.0/firmware-5.bin failed with error -2
[   13.013205] ath10k_pci 0000:00:00.0: Falling back to user helper
[   13.186937] firmware ath10k!QCA9887!hw1.0!firmware-5.bin: firmware_loading_store: map pages failed
[   13.196485] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/QCA9887/hw1.0/firmware-4.bin failed with error -2
[   13.207569] ath10k_pci 0000:00:00.0: Falling back to user helper
[   13.384406] firmware ath10k!QCA9887!hw1.0!firmware-4.bin: firmware_loading_store: map pages failed
[   13.393956] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/QCA9887/hw1.0/firmware-3.bin failed with error -2
[   13.405039] ath10k_pci 0000:00:00.0: Falling back to user helper
[   13.577967] firmware ath10k!QCA9887!hw1.0!firmware-3.bin: firmware_loading_store: map pages failed
[   13.591072] ath10k_pci 0000:00:00.0: qca9887 hw1.0 target 0x4100016d chip_id 0x004000ff sub 0000:0000
[   13.600647] ath10k_pci 0000:00:00.0: kconfig debug 0 debugfs 1 tracing 0 dfs 1 testmode 0
[   13.613184] ath10k_pci 0000:00:00.0: firmware ver 10.1-ct-87-__fW-022-fa250764 api 2 features wmi-10.x,has-wmi-mgmt-tx,mfp,txstatus-noack,wmi-10.x-CT,ratemask-CT,txrate-CT,get-temp-CT,tx-rc-CT,cust-stats-CT,retry-gt2-CT,txrate2-CT,beacon-cb-CT,wmi-block-ack-CT crc32 bae7d809
[   13.736144] ath10k_pci 0000:00:00.0: Direct firmware load for ath10k/QCA9887/hw1.0/board-2.bin failed with error -2
[   13.746956] ath10k_pci 0000:00:00.0: Falling back to user helper
[   13.851491] firmware ath10k!QCA9887!hw1.0!board-2.bin: firmware_loading_store: map pages failed
[   13.860928] ath10k_pci 0000:00:00.0: board_file api 1 bmi_id N/A crc32 546cca0d
[   14.847216] ath10k_pci 0000:00:00.0: 10.1 wmi init: vdevs: 16  peers: 127  tid: 256
[   14.861928] ath10k_pci 0000:00:00.0: wmi print 'P 128 V 8 T 410'
[   14.868389] ath10k_pci 0000:00:00.0: wmi print 'msdu-desc: 1424  sw-crypt: 0 ct-sta: 0'
[   14.876686] ath10k_pci 0000:00:00.0: wmi print 'alloc rem: 21496 iram: 11988'
[   14.921659] ath10k_pci 0000:00:00.0: htt-ver 2.1 wmi-op 2 htt-op 2 cal file max-sta 128 raw 0 hwcrypto 1
[   14.934776] ath10k_pci 0000:00:00.0: NOTE:  Firmware DBGLOG output disabled in debug_mask: 0x10000000
[   15.076372] ath: EEPROM regdomain: 0x0
[   15.076379] ath: EEPROM indicates default country code should be used
[   15.076382] ath: doing EEPROM country->regdmn map search
[   15.076395] ath: country maps to regdmn code: 0x3a
[   15.076399] ath: Country alpha2 being used: US
[   15.076402] ath: Regpair used: 0x3a
[   15.140628] ath: EEPROM regdomain: 0x0
[   15.140635] ath: EEPROM indicates default country code should be used
[   15.140638] ath: doing EEPROM country->regdmn map search
[   15.140651] ath: country maps to regdmn code: 0x3a
[   15.140656] ath: Country alpha2 being used: US
[   15.140659] ath: Regpair used: 0x3a
[   15.153321] ieee80211 phy1: Selected rate control algorithm 'minstrel_ht'
[   15.154865] ieee80211 phy1: Atheros AR9561 Rev:0 mem=0xb8100000, irq=2
[   15.199657] kmodloader: done loading kernel modules from /etc/modules.d/*
[   23.048397] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   23.056018] eth0: link up (1000Mbps/Full duplex)
[   23.060813] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   23.084901] br-lan: port 1(eth0.1) entered blocking state
[   23.090485] br-lan: port 1(eth0.1) entered disabled state
[   23.096497] device eth0.1 entered promiscuous mode
[   23.101450] device eth0 entered promiscuous mode
[   23.134940] br-lan: port 1(eth0.1) entered blocking state
[   23.140529] br-lan: port 1(eth0.1) entered forwarding state
[   23.146484] IPv6: ADDRCONF(NETDEV_UP): br-lan: link is not ready
[   24.113668] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
[   25.081466] ath: EEPROM regdomain: 0x8268
[   25.081474] ath: EEPROM indicates we should expect a country code
[   25.081480] ath: doing EEPROM country->regdmn map search
[   25.081485] ath: country maps to regdmn code: 0x37
[   25.081490] ath: Country alpha2 being used: PL
[   25.081493] ath: Regpair used: 0x37
[   25.081498] ath: regdomain 0x8268 dynamically updated by user
[   25.081568] ath: EEPROM regdomain: 0x8268
[   25.081571] ath: EEPROM indicates we should expect a country code
[   25.081575] ath: doing EEPROM country->regdmn map search
[   25.081580] ath: country maps to regdmn code: 0x37
[   25.081583] ath: Country alpha2 being used: PL
[   25.081586] ath: Regpair used: 0x37
[   25.081589] ath: regdomain 0x8268 dynamically updated by user
[   27.255503] ath10k_pci 0000:00:00.0: 10.1 wmi init: vdevs: 16  peers: 127  tid: 256
[   27.270191] ath10k_pci 0000:00:00.0: wmi print 'P 128 V 8 T 410'
[   27.276868] ath10k_pci 0000:00:00.0: wmi print 'msdu-desc: 1424  sw-crypt: 0 ct-sta: 0'
[   27.285184] ath10k_pci 0000:00:00.0: wmi print 'alloc rem: 21496 iram: 11988'
[   27.330384] ath10k_pci 0000:00:00.0: pdev param 0 not supported by firmware
[   27.343249] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   27.376466] br-lan: port 2(wlan0) entered blocking state
[   27.381959] br-lan: port 2(wlan0) entered disabled state
[   27.387765] device wlan0 entered promiscuous mode
[   27.636543] IPv6: ADDRCONF(NETDEV_UP): wlan1: link is not ready
[   27.666701] br-lan: port 3(wlan1) entered blocking state
[   27.672190] br-lan: port 3(wlan1) entered disabled state
[   27.678025] device wlan1 entered promiscuous mode
[   27.682969] br-lan: port 3(wlan1) entered blocking state
[   27.688508] br-lan: port 3(wlan1) entered forwarding state
[   28.353265] br-lan: port 3(wlan1) entered disabled state
[   29.349842] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready
[   29.356618] br-lan: port 3(wlan1) entered blocking state
[   29.362125] br-lan: port 3(wlan1) entered forwarding state
[  100.634632] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[  100.641442] br-lan: port 2(wlan0) entered blocking state
[  100.646984] br-lan: port 2(wlan0) entered forwarding state
[928189.536836] hostapd invoked oom-killer: gfp_mask=0x14201ca(GFP_HIGHUSER_MOVABLE|__GFP_COLD), nodemask=(null),  order=0, oom_score_adj=0
[928189.549929] CPU: 0 PID: 1629 Comm: hostapd Not tainted 4.14.143 #0
[928189.557113] Stack : 00000000 800b29e4 80500000 804ae488 00000000 00000000 00000000 00000000
[928189.566706]         00000000 00000000 00000000 00000000 00000000 00000001 827cdb30 6a387cb0
[928189.575658]         827cdbc8 00000000 00000000 00005220 00000038 804471f8 00000007 00000000
[928189.584761]         000000fe 81c453ae 000000fd 6d3a2068 827cdb10 80000000 827cdd20 8048705c
[928189.593798]         00000003 00200000 ffffffff 00000025 00000010 8027f154 00000000 80630000
[928189.603057]         ...
[928189.605686] Call Trace:
[928189.605698] [<800b29e4>] 0x800b29e4
[928189.612149] [<80500000>] 0x80500000
[928189.616207] [<804471f8>] 0x804471f8
[928189.620345] [<8027f154>] 0x8027f154
[928189.624453] [<8006a56c>] 0x8006a56c
[928189.628735] [<8006a574>] 0x8006a574
[928189.632895] [<800f638c>] 0x800f638c
[928189.636962] [<800f5674>] 0x800f5674
[928189.641024] [<800f622c>] 0x800f622c
[928189.645046] [<800fa730>] 0x800fa730
[928189.648986] [<800f0fdc>] 0x800f0fdc
[928189.652732] [<800f2f7c>] 0x800f2f7c
[928189.656423] [<8011d5dc>] 0x8011d5dc
[928189.660504] [<80119b24>] 0x80119b24
[928189.664247] [<8011dde4>] 0x8011dde4
[928189.668564] [<80071760>] 0x80071760
[928189.672315] [<800a8168>] 0x800a8168
[928189.676857] [<800a886c>] 0x800a886c
[928189.680765] [<800bd30c>] 0x800bd30c
[928189.684637] [<800bcc04>] 0x800bcc04
[928189.688424] [<8044915c>] 0x8044915c
[928189.692438] [<800c9bf8>] 0x800c9bf8
[928189.696416] [<80155610>] 0x80155610
[928189.700311] [<800770dc>] 0x800770dc
[928189.704055]
[928189.706104] Mem-Info:
[928189.708797] active_anon:333 inactive_anon:9 isolated_anon:0
[928189.708797]  active_file:122 inactive_file:202 isolated_file:0
[928189.708797]  unevictable:0 dirty:0 writeback:0 unstable:0
[928189.708797]  slab_reclaimable:198 slab_unreclaimable:1246
[928189.708797]  mapped:2 shmem:24 pagetables:59 bounce:0
[928189.708797]  free:2038 free_pcp:4 free_cma:0
[928189.742766] Node 0 active_anon:1332kB inactive_anon:36kB active_file:488kB inactive_file:808kB unevictable:0kB isolated(anon):0kB isolated(file):0kB mapped:8kB dirty:0kB writeback:0kB shmem:96kB writeback_tmp:0kB unstable:0kB all_unreclaimable? yes
[928189.766248] Normal free:8076kB min:8192kB low:10240kB high:12288kB active_anon:1332kB inactive_anon:36kB active_file:488kB inactive_file:808kB unevictable:0kB writepending:0kB present:65536kB managed:59560kB mlocked:0kB kernel_stack:320kB pagetables:236kB bounce:0kB free_pcp:24kB local_pcp:24kB free_cma:0kB
[928189.795271] lowmem_reserve[]: 0 0
[928189.798803] Normal: 195*4kB (UE) 130*8kB (UME) 55*16kB (UME) 28*32kB (UME) 13*64kB (UME) 5*128kB (UME) 2*256kB (E) 1*512kB (M) 2*1024kB (UE) 0*2048kB 0*4096kB = 8140kB
[928189.814860] 348 total pagecache pages
[928189.819025] 0 pages in swap cache
[928189.822884] Swap cache stats: add 0, delete 0, find 0/0
[928189.828964] Free swap  = 0kB
[928189.832452] Total swap = 0kB
[928189.835723] 16384 pages RAM
[928189.839074] 0 pages HighMem/MovableOnly
[928189.843459] 1494 pages reserved
[928189.846793] [ pid ]   uid  tgid total_vm      rss nr_ptes nr_pmds swapents oom_score_adj name
[928189.856524] [  530]     0   530      300       16       4       0        0             0 ubusd
[928189.866014] [  531]     0   531      229       10       3       0        0             0 askfirst
[928189.876020] [  548]     0   548      255       12       3       0        0             0 urngd
[928189.885834] [  960]     0   960      321       44       6       0        0             0 logd
[928189.895048] [ 1027]   453  1027      337       28       5       0        0             0 dnsmasq
[928189.904886] [ 1060]     0  1060      268       11       3       0        0             0 dropbear
[928189.914707] [ 1117]     0  1117      418       38       4       0        0             0 netifd
[928189.924211] [ 1152]     0  1152      360       27       4       0        0             0 odhcpd
[928189.933787] [ 1179]     0  1179      303       11       3       0        0             0 crond
[928189.943056] [ 1355]     0  1355      302       10       4       0        0             0 udhcpc
[928189.952206] [ 1357]     0  1357      261       13       4       0        0             0 odhcp6c
[928189.961494] [ 1397]     0  1397      303       12       3       0        0             0 ntpd
[928189.970444] [ 1573]     0  1573      440       38       4       0        0             0 hostapd
[928189.979642] [ 1629]     0  1629      440       34       4       0        0             0 hostapd
[928189.988819] Out of memory: Kill process 960 (logd) score 3 or sacrifice child
[928189.996312] Killed process 960 (logd) total-vm:1284kB, anon-rss:172kB, file-rss:4kB, shmem-rss:0kB
[928202.586610] hostapd invoked oom-killer: gfp_mask=0x14201ca(GFP_HIGHUSER_MOVABLE|__GFP_COLD), nodemask=(null),  order=0, oom_score_adj=0
[928202.599337] CPU: 0 PID: 1629 Comm: hostapd Not tainted 4.14.143 #0
[928202.605899] Stack : 00000000 800b29e4 80500000 804ae488 00000000 00000000 00000000 00000000
[928202.614660]         00000000 00000000 00000000 00000000 00000000 00000001 827cdb30 6a387cb0
[928202.623397]         827cdbc8 00000000 00000000 00006560 00000038 804471f8 00000007 00000000
[928202.632144]         0000013f 19484d4c 0000013e 6d3a2068 827cdb10 80000000 827cdd20 8048705c
[928202.640904]         00000002 00200000 ffffffff 00000025 00000010 8027f154 00000000 80630000
[928202.649658]         ...
[928202.652295] Call Trace:
[928202.652306] [<800b29e4>] 0x800b29e4
[928202.658617] [<80500000>] 0x80500000
[928202.662327] [<804471f8>] 0x804471f8
[928202.666089] [<8027f154>] 0x8027f154
[928202.669781] [<8006a56c>] 0x8006a56c
[928202.673496] [<8006a574>] 0x8006a574
[928202.677265] [<800f638c>] 0x800f638c
[928202.680961] [<800f5674>] 0x800f5674
[928202.684670] [<800f622c>] 0x800f622c
[928202.688365] [<800fa730>] 0x800fa730
[928202.692085] [<800f0fdc>] 0x800f0fdc
[928202.695786] [<800f2f7c>] 0x800f2f7c
[928202.699478] [<802f760c>] 0x802f760c
[928202.703188] [<8011d5dc>] 0x8011d5dc
[928202.706894] [<80119b24>] 0x80119b24
[928202.710654] [<8011dde4>] 0x8011dde4
[928202.714385] [<80071760>] 0x80071760
[928202.718091] [<800a8168>] 0x800a8168
[928202.721800] [<800a886c>] 0x800a886c
[928202.725559] [<800bcc04>] 0x800bcc04
[928202.729264] [<8044915c>] 0x8044915c
[928202.733022] [<802f6108>] 0x802f6108
[928202.736711] [<80155610>] 0x80155610
[928202.740421] [<800770dc>] 0x800770dc
[928202.744181]
[928202.745814] Mem-Info:
[928202.748257] active_anon:290 inactive_anon:9 isolated_anon:0
[928202.748257]  active_file:112 inactive_file:200 isolated_file:0
[928202.748257]  unevictable:0 dirty:0 writeback:0 unstable:0
[928202.748257]  slab_reclaimable:196 slab_unreclaimable:1269
[928202.748257]  mapped:2 shmem:24 pagetables:53 bounce:0
[928202.748257]  free:2046 free_pcp:2 free_cma:0
[928202.781457] Node 0 active_anon:1160kB inactive_anon:36kB active_file:448kB inactive_file:800kB unevictable:0kB isolated(anon):0kB isolated(file):0kB mapped:8kB dirty:0kB writeback:0kB shmem:96kB writeback_tmp:0kB unstable:0kB all_unreclaimable? yes
[928202.804343] Normal free:8184kB min:8192kB low:10240kB high:12288kB active_anon:1160kB inactive_anon:36kB active_file:448kB inactive_file:800kB unevictable:0kB writepending:0kB present:65536kB managed:59560kB mlocked:0kB kernel_stack:312kB pagetables:212kB bounce:0kB free_pcp:8kB local_pcp:8kB free_cma:0kB
[928202.832403] lowmem_reserve[]: 0 0
[928202.835963] Normal: 190*4kB (UE) 118*8kB (UME) 59*16kB (UME) 29*32kB (UME) 12*64kB (ME) 6*128kB (UME) 2*256kB (E) 1*512kB (M) 2*1024kB (UE) 0*2048kB 0*4096kB = 8184kB
[928202.851514] 336 total pagecache pages
[928202.855386] 0 pages in swap cache
[928202.858977] Swap cache stats: add 0, delete 0, find 0/0
[928202.864489] Free swap  = 0kB
[928202.867552] Total swap = 0kB
[928202.870662] 16384 pages RAM
[928202.873657] 0 pages HighMem/MovableOnly
[928202.877850] 1494 pages reserved
[928202.881183] [ pid ]   uid  tgid total_vm      rss nr_ptes nr_pmds swapents oom_score_adj name
[928202.890139] [  530]     0   530      300       16       4       0        0             0 ubusd
[928202.899283] [  531]     0   531      229       10       3       0        0             0 askfirst
[928202.908650] [  548]     0   548      255       12       3       0        0             0 urngd
[928202.917666] [ 1027]   453  1027      337       28       5       0        0             0 dnsmasq
[928202.927097] [ 1060]     0  1060      268       11       3       0        0             0 dropbear
[928202.936812] [ 1117]     0  1117      418       38       4       0        0             0 netifd
[928202.946364] [ 1152]     0  1152      360       27       4       0        0             0 odhcpd
[928202.955659] [ 1179]     0  1179      303       11       3       0        0             0 crond
[928202.965846] [ 1355]     0  1355      302       10       4       0        0             0 udhcpc
[928202.975444] [ 1357]     0  1357      261       13       4       0        0             0 odhcp6c
[928202.985281] [ 1397]     0  1397      303       12       3       0        0             0 ntpd
[928202.994340] [ 1573]     0  1573      440       38       4       0        0             0 hostapd
[928203.003905] [ 1629]     0  1629      440       34       4       0        0             0 hostapd
[928203.013446] Out of memory: Kill process 1117 (netifd) score 2 or sacrifice child
[928203.021599] Killed process 1357 (odhcp6c) total-vm:1044kB, anon-rss:48kB, file-rss:4kB, shmem-rss:0kB
[928204.006881] odhcpd invoked oom-killer: gfp_mask=0x14201ca(GFP_HIGHUSER_MOVABLE|__GFP_COLD), nodemask=(null),  order=0, oom_score_adj=0
[928204.019518] CPU: 0 PID: 1152 Comm: odhcpd Not tainted 4.14.143 #0
[928204.025942] Stack : 00000000 800b29e4 80500000 804ae488 00000000 00000000 00000000 00000000
[928204.034696]         00000000 00000000 00000000 00000000 00000000 00000001 833ffb30 122272e3
[928204.043609]         833ffbc8 00000000 00000000 00007840 00000038 804471f8 00000007 00000000
[928204.052387]         0000017f ba61023f 0000017e 6d3a206f 833ffb10 80000000 833ffd20 8048705c
[928204.061119]         00000002 00200000 ffffffff 00000025 00000008 8027f154 00000000 80630000
[928204.069911]         ...
[928204.072574] Call Trace:
[928204.072587] [<800b29e4>] 0x800b29e4
[928204.078883] [<80500000>] 0x80500000
[928204.082647] [<804471f8>] 0x804471f8
[928204.086454] [<8027f154>] 0x8027f154
[928204.090153] [<8006a56c>] 0x8006a56c
[928204.093868] [<8006a574>] 0x8006a574
[928204.097565] [<800f638c>] 0x800f638c
[928204.101354] [<800f5674>] 0x800f5674
[928204.105055] [<800f622c>] 0x800f622c
[928204.108749] [<800fa730>] 0x800fa730
[928204.112491] [<800f0fdc>] 0x800f0fdc
[928204.116196] [<800f2f7c>] 0x800f2f7c
[928204.119888] [<8011d5dc>] 0x8011d5dc
[928204.123634] [<80119b24>] 0x80119b24
[928204.127332] [<8011dde4>] 0x8011dde4
[928204.131042] [<80071760>] 0x80071760
[928204.134755] [<800a8168>] 0x800a8168
[928204.138455] [<800a886c>] 0x800a886c
[928204.142152] [<800a4150>] 0x800a4150
[928204.145850] [<8044915c>] 0x8044915c
[928204.149549] [<80185668>] 0x80185668
[928204.153249] [<800c9cf4>] 0x800c9cf4
[928204.156936] [<800770dc>] 0x800770dc
[928204.160632]
[928204.162273] Mem-Info:
[928204.164725] active_anon:278 inactive_anon:9 isolated_anon:0
[928204.164725]  active_file:144 inactive_file:201 isolated_file:0
[928204.164725]  unevictable:0 dirty:0 writeback:0 unstable:0
[928204.164725]  slab_reclaimable:196 slab_unreclaimable:1258
[928204.164725]  mapped:5 shmem:24 pagetables:49 bounce:0
[928204.164725]  free:2055 free_pcp:16 free_cma:0
[928204.197969] Node 0 active_anon:1112kB inactive_anon:36kB active_file:576kB inactive_file:804kB unevictable:0kB isolated(anon):0kB isolated(file):0kB mapped:20kB dirty:0kB writeback:0kB shmem:96kB writeback_tmp:0kB unstable:0kB all_unreclaimable? yes

Ktoś miał coś podobnego?

https://openwrt.org/toh/tp-link/archer_c5_v4 - czy ktoś z Was próbował?

Archer C5 v4 https://wikidevi.com/wiki/TP-LINK_Archer_C5_v4.x - jest szansa że będzie to współpracowało z OpenWrt? Ktoś już próbował?

6

(1,918 odpowiedzi, napisanych Oprogramowanie)

Nie jestem na bieżąco w tym co można kupić pod LEDE, potrzebuje routera WAN/LAN Gigabit, wifi w AC z polskiej dystrybucji. Ostatniecznie WAN/LAN po 100mb, internet 100mb/s żeby zbliżona wartość była zbliżona u klientów wifi (da radę Archer C50? któraś z wersji 1043?)

7

(30 odpowiedzi, napisanych Oprogramowanie)

Czy ten art będzie aktualny do Chaos Calmer?

OpenWrt Chaos Calmer 15.05.1 (r49474)
Build time: 2016-11-11 13:54 CET    

root@OpenWRT:~# cat /etc/config/dhcp 

config dnsmasq
    option domainneeded '1'
    option boguspriv '1'
    option localise_queries '1'
    option rebind_protection '1'
    option rebind_localhost '1'
    option local '/lan/'
    option domain 'lan'
    option expandhosts '1'
    option authoritative '1'
    option readethers '1'
    option leasefile '/tmp/dhcp.leases'
    option resolvfile '/tmp/resolv.conf.auto'
    option localservice '1'
    list rebind_domain 'free.aero2.net.pl'
    list addnhosts '/mnt/adblock/hosts.deny'
    option dhcphostsfile '/etc/dhcp.hosts'

config dhcp 'lan'
    option interface 'lan'
    option start '100'
    option limit '150'
    option leasetime '12h'
    option dhcpv6 'server'
    option ra 'server'
    option ra_management '1'
    list options '-O tag:lan2,3,192.168.11.1'
    list options '-O tag:lan2,6,208.67.222.123,208.67.220.123'

config dhcp 'wan'
    option interface 'wan'
    option ignore '1'

root@OpenWRT:~# cat /etc/dhcp.hosts 
fc:92:3b:be:16:1c,set:lan2,192.168.10.230


root@OpenWRT:~# logread
...
Sun Jan 22 12:11:00 2017 daemon.crit dnsmasq[3891]: bad dhcp-range at line 30 of /var/etc/dnsmasq.conf
Sun Jan 22 12:11:00 2017 daemon.crit dnsmasq[3891]: FAILED to start up

Próbuje konfiguracji a logread wypluwa błąd? Dnsmasq nie uruchamia się.

8

(5 odpowiedzi, napisanych Sprzęt)

Ok czyli nazwa SSID taka sama nie jest wymagana. W przypadku gdy będą takie same SSID dla 2,4 i 5 GHz klient łączący się z routerem w trybie ac automatycznie wybierze dla siebie lepsze, szybsze połączenie?

9

(5 odpowiedzi, napisanych Sprzęt)

Poprawnie czyli - jak należy ustawiać SSID w takich routerach? Czy taki sam dla 2,4 i 5 GHz, czy dla obu pasm różne nazwy SSID?

10

(5 odpowiedzi, napisanych Sprzęt)

Witam,

Próbuje doszukać się informacji jaka jest poprawna konfiguracja ap w trybie ac. Sam jeszcze nie miałem okazji testować tego u siebie, dlatego pytam kolegów którzy mieli już do czynienia z takimi routerami.
1. SSID w tej samej nazwie dla 2,4 i 5 GHz np. TEST
2. SSID w o nazwach np. TEST2GHZ i TEST5GHZ

11

(21 odpowiedzi, napisanych Oprogramowanie)

Ładnie przejrzyście i czytelnie, w sumie odświeżenie interfejsu się należało, jak najbardziej jestem za.

12

(9 odpowiedzi, napisanych Oprogramowanie)

Teraz tak, jakiś czas temu był zastój z Twoim obrazami Gargoyle wtedy przeszedłem na Luci, ale teraz się zastanowię.

13

(9 odpowiedzi, napisanych Oprogramowanie)

Ok dzięki, za szybką odpowiedź teraz pozostaje mi dylemat czy Gargoyle czy Luci na czasie...

14

(9 odpowiedzi, napisanych Oprogramowanie)

Odświeże temat, podczas instalacji kmod-macvlan:

OpenWrt Chaos Calmer 15.05.1 (r49398)                        
Build time: 2016-07-09 08:03 CEST  

po opkg update

opkg install kmod-macvlan
Multiple packages (kmod-macvlan and kmod-macvlan) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-macvlan and kmod-macvlan) providing same name marked HOLD or PREFER. Using latest.
Installing kmod-macvlan (3.18.44-1) to root...
Downloading http://dl.eko.one.pl/chaos_calmer/ar71xx/packages/kmod-macvlan_3.18.44-1_ar71xx.ipk.
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-macvlan:
 *     kernel (= 3.18.44-1-c9f2dbe3fcc118da5522e541b22efae5) * 
 * opkg_install_cmd: Cannot install package kmod-macvlan.

Proszę o jakieś podpowiedzi.

15

(385 odpowiedzi, napisanych Oprogramowanie)

Popieram, Cezarego jeśli tak forma statystyk nie odpowiada, zrezygnujcie z Niej. Nie róbcie bałaganu w statystykach.

16

(63 odpowiedzi, napisanych Oprogramowanie)

Chciałem przypisać inną adresacje dla sieci gościnnej. Najpierw wy klikałem włączyłem sieć gościnna ustawiłem nazwę i hasło w GUI dałem zapisz, a później edytowałem ręcznie pliki dhcp network wireless i firewall (tak jak dla luci).
Usunięcie opcji powyżej nie rozwiązało problemu.

17

(63 odpowiedzi, napisanych Oprogramowanie)

Proszę o sprawdzenie w konfiguracji sieci gościnnej, po aktualizacjia z Openwrt Luci do najnowszego Gargoyle, gdzieś zrobiłem błąd skutek tego jest taki ze na sieci gościnnej (Baal/gosc) klient podlacza się pozyskuje adresy ip dla sieci gościnnej ale nie ma dostępu do Internetu.

----------------------------------------------------------------
 |                                                              |
 | Gargoyle PL 1.9.1.1 (55922fb)                                |
 | OpenWrt Chaos Calmer 15.05.1 (r49398)                        |
 | Build time: 2016-07-10 09:17 CEST                            |
 |                                                              |
 | Cezary Jackiewicz (obsy), http://eko.one.pl                  |
 |                                                              |
 ----------------------------------------------------------------
root@Mefisto:~# cat /etc/config/network 

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fdd2:862c:d7de::/48'

config interface 'lan'
    option ifname 'eth0.1'
    option force_link '1'
    option type 'bridge'
    option proto 'static'
    option netmask '255.255.255.0'
    option ip6assign '60'
    option dns '192.168.10.1'
    option ipaddr '192.168.10.1'

config interface 'wan'
    option ifname 'eth0.2'
    option proto 'dhcp'
    option ipv6 '0'

config interface 'wan6'
    option ifname 'eth0.2'
    option proto 'dhcpv6'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '0t 2 3 4 5'

config switch_vlan
    option device 'switch0'
    option vlan '2'
    option ports '0t 1'

config interface 'gosc'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.101.1'
    option netmask '255.255.255.0'

root@Mefisto:~# cat /etc/config/wireless 

config wifi-device 'radio0'
    option type 'mac80211'
    option hwmode '11g'
    option path 'platform/ar934x_wmac'
    option noscan '1'
    option country 'PL'
    option channel '1'
    option htmode 'HT40+'

config wifi-device 'radio1'
    option type 'mac80211'
    option channel '36'
    option hwmode '11a'
    option path 'pci0000:00/0000:00:00.0'
    option noscan '1'
    option country 'PL'
    option htmode 'HT40+'

config wifi-iface 'ap_g'
    option device 'radio0'
    option mode 'ap'
    option network 'lan'
    option disassoc_low_ack '0'
    option ssid 'Mefisto'
    option encryption 'psk2'
    option key '1234567890'

config wifi-iface 'ap_gn_g'
    option device 'radio0'
    option mode 'ap'
    option network 'gosc'
    option disassoc_low_ack '0'
    option is_guest_network '1'
    option macaddr 'b8:f8:d9:2e:fc:fb'
    option ssid 'Baal'
    option isolate '1'
    option encryption 'psk2'
    option key '1234567890'

config wifi-iface 'ap_a'
    option device 'radio1'
    option mode 'ap'
    option network 'lan'
    option disassoc_low_ack '0'
    option ssid 'Diablo'
    option encryption 'psk2'
    option key '1234567890'

root@Mefisto:~# cat /etc/config/firewall 

config defaults
    option syn_flood '1'
    option input 'ACCEPT'
    option output 'ACCEPT'
    option forward 'REJECT'
    option enforce_dhcp_assignments '1'

config zone
    option name 'lan'
    list network 'lan'
    option input 'ACCEPT'
    option output 'ACCEPT'
    option forward 'ACCEPT'

config zone
    option name 'wan'
    list network 'wan'
    list network 'wan6'
    option input 'REJECT'
    option output 'ACCEPT'
    option forward 'REJECT'
    option masq '1'
    option mtu_fix '1'

config forwarding
    option src 'lan'
    option dest 'wan'

config rule
    option name 'Allow-DHCP-Renew'
    option src 'wan'
    option proto 'udp'
    option dest_port '68'
    option target 'ACCEPT'
    option family 'ipv4'

config rule
    option name 'Allow-Ping'
    option src 'wan'
    option proto 'icmp'
    option icmp_type 'echo-request'
    option family 'ipv4'
    option target 'ACCEPT'

config rule
    option name 'Allow-IGMP'
    option src 'wan'
    option proto 'igmp'
    option family 'ipv4'
    option target 'ACCEPT'

config rule
    option name 'Allow-DHCPv6'
    option src 'wan'
    option proto 'udp'
    option src_ip 'fe80::/10'
    option src_port '547'
    option dest_ip 'fe80::/10'
    option dest_port '546'
    option family 'ipv6'
    option target 'ACCEPT'

config rule
    option name 'Allow-MLD'
    option src 'wan'
    option proto 'icmp'
    option src_ip 'fe80::/10'
    list icmp_type '130/0'
    list icmp_type '131/0'
    list icmp_type '132/0'
    list icmp_type '143/0'
    option family 'ipv6'
    option target 'ACCEPT'

config rule
    option name 'Allow-ICMPv6-Input'
    option src 'wan'
    option proto 'icmp'
    list icmp_type 'echo-request'
    list icmp_type 'echo-reply'
    list icmp_type 'destination-unreachable'
    list icmp_type 'packet-too-big'
    list icmp_type 'time-exceeded'
    list icmp_type 'bad-header'
    list icmp_type 'unknown-header-type'
    list icmp_type 'router-solicitation'
    list icmp_type 'neighbour-solicitation'
    list icmp_type 'router-advertisement'
    list icmp_type 'neighbour-advertisement'
    option limit '1000/sec'
    option family 'ipv6'
    option target 'ACCEPT'

config rule
    option name 'Allow-ICMPv6-Forward'
    option src 'wan'
    option dest '*'
    option proto 'icmp'
    list icmp_type 'echo-request'
    list icmp_type 'echo-reply'
    list icmp_type 'destination-unreachable'
    list icmp_type 'packet-too-big'
    list icmp_type 'time-exceeded'
    list icmp_type 'bad-header'
    list icmp_type 'unknown-header-type'
    option limit '1000/sec'
    option family 'ipv6'
    option target 'ACCEPT'

config include
    option path '/etc/firewall.user'
    option reload '1'

config rule
    option src 'wan'
    option dest 'lan'
    option proto 'esp'
    option target 'ACCEPT'

config rule
    option src 'wan'
    option dest 'lan'
    option dest_port '500'
    option proto 'udp'
    option target 'ACCEPT'

config include
    option type 'script'
    option path '/usr/lib/gargoyle_firewall_util/gargoyle_additions.firewall'
    option family 'IPv4'
    option reload '1'

config include 'openvpn_include_file'
    option path '/etc/openvpn.firewall'
    option reload '1'

config zone
    option forward 'REJECT'
    option output 'ACCEPT'
    option name 'gosc'
    option input 'REJECT'
    option network 'gosc'

config forwarding
    option dest 'wan'
    option src 'gosc'

config rule
    option src 'gosc'
    option proto 'udp'
    option src_port '67-68'
    option dest_port '67-68'
    option target 'ACCEPT'
    option family 'ipv4'

config rule
    option src 'gosc'
    option dest_port '53'
    option target 'ACCEPT'
    option family 'ipv4'
    option proto 'tcpudp'

root@Mefisto:~# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.20.1    0.0.0.0         UG    0      0        0 eth0.2
192.168.10.0    0.0.0.0         255.255.255.0   U     0      0        0 br-lan
192.168.20.0    0.0.0.0         255.255.255.0   U     0      0        0 eth0.2
192.168.20.1    0.0.0.0         255.255.255.255 UH    0      0        0 eth0.2
192.168.101.0   0.0.0.0         255.255.255.0   U     0      0        0 br-gosc
root@Mefisto:~# cat /etc/config/dhcp 

config dnsmasq
    option domainneeded '1'
    option boguspriv '1'
    option filterwin2k '0'
    option localise_queries '1'
    option rebind_protection '1'
    option rebind_localhost '1'
    option local '/lan/'
    option domain 'lan'
    option expandhosts '1'
    option nonegcache '0'
    option authoritative '1'
    option readethers '1'
    option leasefile '/tmp/dhcp.leases'
    option resolvfile '/tmp/resolv.conf.auto'
    option localservice '1'
    list rebind_domain 'free.aero2.net.pl'
    list server '/.bit/178.32.31.41'
    list server '/.bit/106.187.47.17'
    list server '/.bit/176.58.118.172'
    list server '/.glue/66.244.95.20'
    list server '/.glue/95.211.32.162'
    list server '/.glue/95.142.171.235'
    list server '/.parody/66.244.95.20'
    list server '/.parody/95.211.32.162'
    list server '/.parody/95.142.171.235'
    list server '/.dyn/66.244.95.20'
    list server '/.dyn/95.211.32.162'
    list server '/.dyn/95.142.171.235'
    list server '/.bbs/66.244.95.20'
    list server '/.bbs/95.211.32.162'
    list server '/.bbs/95.142.171.235'
    list server '/.free/66.244.95.20'
    list server '/.free/95.211.32.162'
    list server '/.free/95.142.171.235'
    list server '/.fur/66.244.95.20'
    list server '/.fur/95.211.32.162'
    list server '/.fur/95.142.171.235'
    list server '/.geek/66.244.95.20'
    list server '/.geek/95.211.32.162'
    list server '/.geek/95.142.171.235'
    list server '/.gopher/66.244.95.20'
    list server '/.gopher/95.211.32.162'
    list server '/.gopher/95.142.171.235'
    list server '/.indy/66.244.95.20'
    list server '/.indy/95.211.32.162'
    list server '/.indy/95.142.171.235'
    list server '/.ing/66.244.95.20'
    list server '/.ing/95.211.32.162'
    list server '/.ing/95.142.171.235'
    list server '/.null/66.244.95.20'
    list server '/.null/95.211.32.162'
    list server '/.null/95.142.171.235'
    list server '/.oss/66.244.95.20'
    list server '/.oss/95.211.32.162'
    list server '/.oss/95.142.171.235'
    list server '/.micro/66.244.95.20'
    list server '/.micro/95.211.32.162'
    list server '/.micro/95.142.171.235'
    list addnhosts '/plugin_root/adblock/block.hosts'

config dhcp 'lan'
    option interface 'lan'
    option start '100'
    option limit '150'
    option leasetime '12h'
    option ignore '0'

config dhcp 'wan'
    option interface 'wan'
    option ignore '1'

config dhcp 'gosc'
    option leasetime '12h'
    option interface 'gosc'
    option start '200'
    option limit '30'

root@Mefisto:~# 

18

(18 odpowiedzi, napisanych Oprogramowanie)

Ok mimo to nadal nie nawiązuje połączenia z VPN.

--
Po reboot ruszyło.

19

(18 odpowiedzi, napisanych Oprogramowanie)

Witam podepnę się bo mam podobny problem, nie chcę łączyć się z VPN PPTP, podczas instalacji nat helper extra wypluwa na końcu:

root@Mefisto:~# opkg install kmod-nf-nathelper-extra
Multiple packages (kmod-nf-nathelper-extra and kmod-nf-nathelper-extra) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-nf-nathelper-extra and kmod-nf-nathelper-extra) providing same name marked HOLD or PREFER. Using latest.
Installing kmod-nf-nathelper-extra (3.18.29-1) to root...
Downloading http://dl.eko.one.pl/chaos_calmer/ar71xx/packages/kmod-nf-nathelper-extra_3.18.29-1_ar71xx.ipk.
Multiple packages (kmod-nf-nat and kmod-nf-nat) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-nf-nat and kmod-nf-nat) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-lib-textsearch and kmod-lib-textsearch) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-lib-textsearch and kmod-lib-textsearch) providing same name marked HOLD or PREFER. Using latest.
Configuring kmod-nf-nathelper-extra.
nf_conntrack_broadcast is already loaded
nf_conntrack_amanda is already loaded
nf_nat_amanda is already loaded
nf_conntrack_proto_gre is already loaded
nf_nat_proto_gre is already loaded
nf_conntrack_h323 is already loaded
nf_nat_h323 is already loaded
nf_conntrack_pptp is already loaded
nf_nat_pptp is already loaded
nf_conntrack_sip is already loaded
nf_nat_sip is already loaded
nf_conntrack_snmp is already loaded
nf_nat_snmp_basic is already loaded
nf_conntrack_tftp is already loaded
nf_nat_tftp is already loaded
nf_conntrack_irc is already loaded
nf_nat_irc is already loaded
Collected errors:
 * pkg_run_script: package "kmod-nf-nathelper-extra" postinst script returned status 255.
 * opkg_configure: kmod-nf-nathelper-extra.postinst returned 255.
root@Mefisto:~# cat /etc/banner

                   _            _____ _____
                  | |          / ____|_   _|
                  | |    _   _| |      | |
                  | |   | | | | |      | |
                  | |___| |_| | |____ _| |_
                  |______\__,_|\_____|_____|

 ----------------------------------------------------------------
 |                                                              |
 | OpenWrt Chaos Calmer 15.05.1 (r49294)                        |
 | Build time: 2016-05-06 14:44 CEST                            |
 |                                                              |
 | Cezary Jackiewicz (obsy), http://eko.one.pl                  |
 |                                                              |
 ----------------------------------------------------------------

20

(385 odpowiedzi, napisanych Oprogramowanie)

Jak dla danego routera z poziomu konsoli odczytać można przypisany do niego token?

21

(1,918 odpowiedzi, napisanych Oprogramowanie)

w Twoich obrazach nie widze go
http://dl.eko.one.pl/luci/chaos_calmer/ar71xx/

22

(1,918 odpowiedzi, napisanych Oprogramowanie)

Najtańszy router wifi N150>, 4 porty lan, bez usb, pod najnowsze openwrt - jaki model?

p.s. dostępny w sprzedaży w Polsce

Zacząłem przygodę z dual band AC i nie mogę nawiązać takiego połączenia. Łączy się tylko po 2,4. Karta Intel® Dual Band Wireless-AC 3160. Testowane pod Windows i Linux. Czy ktoś coś podpowie?

Machine: TP-Link TL-WDR3600 v1 
Gargoyle PL 1.6.2.2 (b70bfc1)
 cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11ng'
        option path 'platform/ar934x_wmac'
        list ht_capab 'LDPC'
        list ht_capab 'SHORT-GI-20'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'TX-STBC'
        list ht_capab 'RX-STBC1'
        list ht_capab 'DSSS_CCK-40'
        option noscan '1'
        option htmode 'HT20'
        option channel '11'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11na'
        option path 'pci0000:00/0000:00:00.0'
        list ht_capab 'LDPC'
        list ht_capab 'SHORT-GI-20'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'TX-STBC'
        list ht_capab 'RX-STBC1'
        list ht_capab 'DSSS_CCK-40'
        option noscan '1'
        option htmode 'HT20'
        option channel '36'

config wifi-iface 'ap_g'
        option device 'radio0'
        option mode 'ap'
        option network 'lan'
        option disassoc_low_ack '0'
        option ssid 'Mefisto'
        option encryption 'psk2'
        option key ' '

config wifi-iface 'ap_a'
        option device 'radio1'
        option mode 'ap'
        option network 'lan'
        option disassoc_low_ack '0'
        option ssid 'Mefisto'
        option encryption 'psk2'
        option key ' '

Ok już doczytałem ten router wdr3600 to nie AC wink

nawtom napisał/a:

To  jest mój skrypt na zbieranie danych z licznika OR-WE-504 może cie zainteresuje ja się komunikuje slotem tcp/ip na i z modułu już rs485

Mógłbyś pokazać jak to masz podłączone do routera/terminala? Zainteresowany tematem, zainstalowałbym sobie coś takiego.

25

(15 odpowiedzi, napisanych Oprogramowanie)

Witam, podepnę się pod temat by nowego nie tworzyć, posiadam dwa routery TL-WR741ND i TL-WR841N oba routery maja tą samą przypadłość podczas uruchamiania świecą się wszystkie prawidłowo, jak uruchomiony zapala się na stałe dioda port 3, gaśnie gdy wsadzisz w nią kabel. Są do odratowania?