1

(252 odpowiedzi, napisanych Oprogramowanie)

Cezary napisał/a:

Chrome 25/28 na ubuntu poprawnie wyświetla to. To tak ot.

Samo http://192.168.1.2:8080/?action=stream musi Ci działać w przeglądarce. Bez tego w okienku magicznie samo się nie wyświetli.

U mnie działało na Chrome 29 do momentu jak przestało działać, sprawdzałem na innych komputerach i działa poprawnie. Więc narazie pewnie to wewnętrzny problem mojej instalacji Chrome. A link http://192.168.1.2:8080/?action=stream nie działa.

2

(252 odpowiedzi, napisanych Oprogramowanie)

Cezary napisał/a:

To masz problem na komputerze że nie wyświetla mjpeg. Jakieś kodeki czy coś.

Faktycznie problem był z mjpeg. Nie rozwiązałem tego do końca ale wynikało to z problemów chrome z wyświetlaniem mjpeg.

https://code.google.com/p/chromium/issu … ?id=135337

Jeszcze nie dopracowałem rozwiązania ale już na stronie wyświetla się obraz poprawnie. Dodałem linię w pliku webcam.sh.

<iframe id="videoframe" scrolling="no" border="0" width="320" height="240" frameBorder="0" src="about:blank" align="center"></iframe>

<img src="http://192.168.1.2:8080/?action=stream">

Pomaga to, obraz się wyświetla ale problem jest taki, że przy zmianie IP i dodaniu hasła nie będzie się zmieniać strona.
Więc narazie to tylko proteza. Może masz pomysł jak ta linijka powinna wyglądać poprawnie.

3

(252 odpowiedzi, napisanych Oprogramowanie)

Cezary napisał/a:

A co wyświetla? Puste okno?

Niedziałający podgląd kamery cd...
Wyświetla się standardowe okno od plugina webcam. Natomiast w miejscu gdzie powinna być wyświetlany obrazek z kamery jest białe pole. Widać w analizie strony, że element występuje ale się nie wyświetla.
Wcześniej po wejściu na stronę plugina webcam strona stale się odświeżała. Teraz po wejściu nie odświeża się. Dodatkowo po wywołaniu linku bezpośredniego nic się nie dzieje.  I w dalszym ciągu biorę tablet i wszystko działa poprawnie?
Czy ktoś ma jakiś pomysł jak to naprawić?
Jeszcze aktualizacja obserwacji: Jeżeli wybiorę stronę bez definicji rodzaju akcji: np.: http://192.168.1.2:8080/ pojawia się do wyboru live oraz static. Wybierając static mogę szybko odświeżając oglądać co się dzieje, natomiast link Live nie otwiera okna, nic się nie dzieje. Ciekawe bo dalej wyświetlanie działa na tablecie i innym komputerze.

4

(252 odpowiedzi, napisanych Oprogramowanie)

Witam,
To mój pierwszy post i drugi już router. Tym razem napotkałem na problem dotyczący plugina webcam. Po całym dniu walki z sterownikami, kamerami itd. wczoraj w nocy udało mi się uruchomić kamerkę. Dziś rano działało. Wyjechałem, wróciłem i ku mojemu zdziwieniu nie działa. Reinstalacja wszystkiego. Dalej nie działa. Walka przez godziny nie pomogła. Wszystko zainstalowane poprawnie. Widać, że kamera pracuje. I teraz najlepsze. W akcie rozpaczy sprawdzam na tablecie - działa, na drugim komputerze - działa. Nie dział tylko na moim kompie, pod Chrome oraz IE.

Czy macie jakiś pomysł co sprawdzić i jakie wykonać testy?