1

(4 odpowiedzi, napisanych Oprogramowanie)

Ja zmieniałem ostatnio CC na LEDE i lekko nie było. Na dzień dobry musiałem skompilować sobie CUPS, bo ktoś zapomniał go przenieść do LEDE. Później walka z ipv6, bo korzystałem jeszcze z radvd i wide-dhcp z oldpackages. Okazało się, że w LEDE jest fajny serwer dhcp do ipv6 ale też odhcpd można łatwo skonfigurować żeby działał jak radvd ( dopisanie jednej linii w konfigu ). Przemęczyłem się i jestem zadowolony. WiFI AC zdaje się działać zdecydowanie szybciej, bo na CC nigdy nie przekroczyłem 55 MB/s, a na LEDE stabilny transfer 60 MB/s nie jest problemem. Max osiągnąłem 64 MB/s. Dodatkowo w LEDE jest fastpath i głównie dlatego się przesiadałem, bo za kilka dni zmieniam łącze na szybsze.

Ładnie to wygląda. Widzę, że niepotrzebnie rozglądam się za nowym routerem, bo mój NBG6716 spokojnie uciągnie łącze 600 mbps. Zawsze kilka stówek w kieszeni smile

3

(1,161 odpowiedzi, napisanych Oprogramowanie)

Ktoś z forum używa ZyXEL NBG6817? Sprzętowo prawie to samo co Netgear R7800. Jak to się sprawuje? Uciągnie łącze 600 mbps?

4

(32 odpowiedzi, napisanych Oprogramowanie)

Jeszcze mi się nie zdarzyło, a w 99% przypadków robię po wifi big_smile

5

(414 odpowiedzi, napisanych Oprogramowanie)

Wszystko jest OK z wyjątkiem sysupgrade. Na tym obrazie też wyrzuca:

root@LEDE:/tmp# sysupgrade -n lede-17.01-snapshot-r3422-b78bcdf-ramips-mt7620-wt
3020-16M-squashfs-sysupgrade.bin
Device wt3020 not supported by this image
Supported devices: wt3020-16M
Image check 'fwtool_check_image' failed.
root@LEDE:/tmp#

Teraz przynajmniej wiem czemu mój Nexx jest jedyny w statystykach big_smile Skopiowałem stare konfigi z CC i dzięki temu switch ożył. Inni wgrali obraz 8M albo zostali na CC big_smile

6

(414 odpowiedzi, napisanych Oprogramowanie)

Dioda miga, konfiguracja switcha jest, sieć działa.

root@LEDE:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd75:0a5d:7047::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device 'lan_dev'
        option name 'eth0.1'
        option macaddr '20:28:18:a1:f0:32'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'

config device 'wan_dev'
        option name 'eth0.2'
        option macaddr '20:28:18:a1:f0:33'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0 6t'

root@LEDE:~#

Upgrade z -F, bo inaczej:

root@LEDE:/tmp# sysupgrade -n lede-17.01-snapshot-r3422-b78bcdf-ramips-mt7620-wt
3020-16M-squashfs-sysupgrade.bin
Sysupgrade is not yet supported on wt3020.
Image check 'platform_check_image' failed.
root@LEDE:/tmp#

7

(414 odpowiedzi, napisanych Oprogramowanie)

root@LEDE:/# cat /tmp/sysinfo/*
wt3020-16M
Nexx WT3020 (16M)
root@LEDE:/#

8

(414 odpowiedzi, napisanych Oprogramowanie)

Cezary napisał/a:

Wgraj te obrazy: http://dl.eko.one.pl/test/ i zobacz.

W dalszym ciągu dioda nie miga podczas uruchamiania, nie ma konfiguracji switcha, nie ma sieci i dodatkowo

 Flash: total: 29.7MB, free: 29.6MB, used: 0%      

Restartowałem dwa razy i za każdym razem to samo.

EDIT:
Po kilku minutach:

 [  320.712643] done.
[  320.716520] jffs2: notice: (896) jffs2_build_xattr_subsystem: complete building xattr subsystem, 0 of xdatum (0 unchecked, 0 orphan) and 0 of xref (0 dead, 0 orphan) found.

z flash wszystko OK ale sieci nie ma.

9

(414 odpowiedzi, napisanych Oprogramowanie)

No tak, próbowałem przez telnet. SSH działa.

10

(414 odpowiedzi, napisanych Oprogramowanie)

Failsafe działa, jest sieć (odpowiada na ping) ale nie można się do niego dostać.

11

(414 odpowiedzi, napisanych Oprogramowanie)

Tak czy siak po dopisaniu konfiguracji switcha sieć się podnosi.

12

(414 odpowiedzi, napisanych Oprogramowanie)

A i jeszcze jedno. Przy próbie wgrania tego samego obrazu mamy komunikat:

root@LEDE:/tmp# sysupgrade -n luci-17.01-snapshot-r3371-79cd141-ramips-mt7620-wt
3020-16M-squashfs-sysupgrade.bin
Device generic not supported by this image
Supported devices: wt3020-16M
Image check 'fwtool_check_image' failed.
root@LEDE:/tmp#

I czy przypadkiem problemem nie jest brak konfiguracji switcha?

root@LEDE:/# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd7d:b5cf:76b8::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device 'lan_dev'
        option name 'eth0.1'
        option macaddr '20:28:18:a1:f0:32'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'

config device 'wan_dev'
        option name 'eth0.2'
        option macaddr '20:28:18:a1:f0:33'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'

root@LEDE:/#

13

(414 odpowiedzi, napisanych Oprogramowanie)

Po restarcie sieci nadal brak.

U-Boot 1.1.3 (Jan  3 2014 - 09:12:42)

MAX Board: Ralink APSoC DRAM:  64 MB
relocate_code Pointer at: 83fb4000
enable ephy clock...done. rf reg 29 = 5
SSC disabled.
spi_wait_nsec: 29
spi device id: ef 40 18 0 0 (40180000)
Warning: un-recognized chip ID, please update bootloader!
raspi_read: from:30000 len:1000
raspi_read: from:30000 len:1000
============================================
Ralink UBoot Version: 4.1.1.0
--------------------------------------------
ASIC 7620_MP (Port5<->None)
DRAM component: 512 Mbits DDR, width 16
DRAM bus: 16 bit
Total memory: 64 MBytes
Flash component: SPI Flash
Date:Jan  3 2014  Time:09:12:42
============================================
icache: sets:512, ways:4, linesz:32 ,total:65536
dcache: sets:256, ways:4, linesz:32 ,total:32768

 ##### The CPU freq = 580 MHZ ####
 estimate memory size =64 Mbytes

Please choose the operation:
   1: Load system code to SDRAM via TFTP.
   2: Load system code then write to Flash via TFTP.
   3: Boot system code via Flash (default).
   4: Entr boot command line interface.
   7: Load Boot Loader code then write to Flash via Serial.
   9: Load Boot Loader code then write to Flash via TFTP.                    0

3: System Boot system code via Flash.
## Booting image at bc050000 ...
raspi_read: from:50000 len:40
   Image Name:   MIPS LEDE Linux-4.4.61
   Image Type:   MIPS Linux Kernel Image (lzma compressed)
   Data Size:    1312277 Bytes =  1.3 MB
   Load Address: 80000000
   Entry Point:  80000000
raspi_read: from:50040 len:140615
   Verifying Checksum ... OK
   Uncompressing Kernel Image ... OK
No initrd
## Transferring control to Linux (at address 80000000) ...
## Giving linux memsize in MB, 64

Starting kernel ...

[    0.000000] Linux version 4.4.61 (cezary@eko.one.pl) (gcc version 5.4.0 (LEDE GCC 5.4.0 r3103-1b51a49) ) #0 Wed May 3 23:03:25 2017
[    0.000000] Board has DDR1
[    0.000000] Analog PMU set to hw control
[    0.000000] Digital PMU set to hw control
[    0.000000] SoC Type: MediaTek MT7620N ver:2 eco:6
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU0 revision is: 00019650 (MIPS 24KEc)
[    0.000000] MIPS: machine is Nexx WT3020 (16M)
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 04000000 @ 00000000 (usable)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x0000000000000000-0x0000000003ffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x0000000000000000-0x0000000003ffffff]
[    0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x0000000003ffffff]
[    0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 16256
[    0.000000] Kernel command line: console=ttyS0,57600 rootfstype=squashfs,jffs2
[    0.000000] PID hash table entries: 256 (order: -2, 1024 bytes)
[    0.000000] Dentry cache hash table entries: 8192 (order: 3, 32768 bytes)
[    0.000000] Inode-cache hash table entries: 4096 (order: 2, 16384 bytes)
[    0.000000] Writing ErrCtl register=0006e47d
[    0.000000] Readback ErrCtl register=0006e47d
[    0.000000] Memory: 60580K/65536K available (3037K kernel code, 142K rwdata, 720K rodata, 188K init, 208K bss, 4956K reserved, 0K cma-reserved)
[    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] NR_IRQS:256
[    0.000000] CPU Clock: 580MHz
[    0.000000] clocksource: systick: mask: 0xffff max_cycles: 0xffff, max_idle_ns: 583261500 ns
[    0.000000] systick: enable autosleep mode
[    0.000000] systick: running - mult: 214748, shift: 32
[    0.000000] clocksource: MIPS: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 6590553264 ns
[    0.000012] sched_clock: 32 bits at 290MHz, resolution 3ns, wraps every 7405115902ns
[    0.015455] Calibrating delay loop... 385.84 BogoMIPS (lpj=1929216)
[    0.080594] pid_max: default: 32768 minimum: 301
[    0.089906] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.102927] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.122086] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
[    0.141576] futex hash table entries: 256 (order: -1, 3072 bytes)
[    0.153820] pinctrl core: initialized pinctrl subsystem
[    0.165358] NET: Registered protocol family 16
[    0.192766] rt2880_gpio 10000600.gpio: registering 24 gpios
[    0.203781] rt2880_gpio 10000600.gpio: registering 24 irq handlers
[    0.216197] rt2880_gpio 10000660.gpio: registering 32 gpios
[    0.227187] rt2880_gpio 10000660.gpio: registering 32 irq handlers
[    0.239592] rt2880_gpio 10000688.gpio: registering 1 gpios
[    0.250390] rt2880_gpio 10000688.gpio: registering 1 irq handlers
[    0.264081] clocksource: Switched to clocksource systick
[    0.276006] NET: Registered protocol family 2
[    0.285576] TCP established hash table entries: 1024 (order: 0, 4096 bytes)
[    0.299343] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
[    0.311937] TCP: Hash tables configured (established 1024 bind 1024)
[    0.324663] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.336195] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.348926] NET: Registered protocol family 1
[    0.361638] rt-timer 10000100.timer: maximum frequency is 1220Hz
[    0.374583] Crashlog allocated RAM at address 0x3f00000
[    0.401307] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.412829] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.435019] io scheduler noop registered
[    0.442672] io scheduler deadline registered (default)
[    0.453187] ralink-usb-phy usbphy: invalid resource
[    0.463412] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
[    0.479451] console [ttyS0] disabled
[    0.486489] 10000c00.uartlite: ttyS0 at MMIO 0x10000c00 (irq = 20, base_baud = 2500000) is a Palmchip BK-3103
[    0.506165] console [ttyS0] enabled
[    0.506165] console [ttyS0] enabled
[    0.519987] bootconsole [early0] disabled
[    0.519987] bootconsole [early0] disabled
[    0.542702] spi spi0.0: force spi mode3
[    0.550928] m25p80 spi0.0: w25q128 (16384 Kbytes)
[    0.560367] 4 ofpart partitions found on MTD device spi0.0
[    0.571297] Creating 4 MTD partitions on "spi0.0":
[    0.580847] 0x000000000000-0x000000030000 : "u-boot"
[    0.592490] 0x000000030000-0x000000040000 : "u-boot-env"
[    0.605016] 0x000000040000-0x000000050000 : "factory"
[    0.616940] 0x000000050000-0x000001000000 : "firmware"
[    1.950247] 2 uimage-fw partitions found on MTD device firmware
[    1.962078] 0x000000050000-0x000000190655 : "kernel"
[    1.973574] 0x000000190655-0x000001000000 : "rootfs"
[    1.985308] mtd: device 5 (rootfs) set to be root filesystem
[    1.996785] 1 squashfs-split partitions found on MTD device rootfs
[    2.009119] 0x00000065f000-0x000001000000 : "rootfs_data"
[    2.024782] mtk_soc_eth 10100000.ethernet: loaded mt7620 driver
[    2.037372] mtk_soc_eth 10100000.ethernet eth0: mediatek frame engine at 0xb0100000, irq 5
[    2.054434] rt2880_wdt 10000120.watchdog: Initialized
[    2.066036] NET: Registered protocol family 10
[    2.079384] NET: Registered protocol family 17
[    2.088403] bridge: automatic filtering via arp/ip/ip6tables has been deprecated. Update your scripts to load br_netfilter if you need this.
[    2.113563] 8021q: 802.1Q VLAN Support v1.8
[    2.136174] VFS: Mounted root (squashfs filesystem) readonly on device 31:5.
[    2.151282] Freeing unused kernel memory: 188K (803d1000 - 80400000)
[    4.566752] init: Console is alive
[    4.573730] init: - watchdog -
[    7.657501] kmodloader: loading kernel modules from /etc/modules-boot.d/*
[    7.795234] usbcore: registered new interface driver usbfs
[    7.806317] usbcore: registered new interface driver hub
[    7.817028] usbcore: registered new device driver usb
[    7.868320] SCSI subsystem initialized
[    7.882723] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    7.897511] ehci-platform: EHCI generic platform driver
[    7.918277] phy phy-usbphy.0: remote usb device wakeup disabled
[    7.930080] phy phy-usbphy.0: UTMI 16bit 30MHz
[    7.938959] ehci-platform 101c0000.ehci: EHCI Host Controller
[    7.950444] ehci-platform 101c0000.ehci: new USB bus registered, assigned bus number 1
[    7.966344] ehci-platform 101c0000.ehci: irq 26, io mem 0x101c0000
[    7.984113] ehci-platform 101c0000.ehci: USB 2.0 started, EHCI 1.00
[    7.997676] hub 1-0:1.0: USB hub found
[    8.005569] hub 1-0:1.0: 1 port detected
[    8.016808] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[    8.030825] ohci-platform: OHCI generic platform driver
[    8.041563] ohci-platform 101c1000.ohci: Generic Platform OHCI controller
[    8.055166] ohci-platform 101c1000.ohci: new USB bus registered, assigned bus number 2
[    8.071026] ohci-platform 101c1000.ohci: irq 26, io mem 0x101c1000
[    8.105727] hub 2-0:1.0: USB hub found
[    8.113646] hub 2-0:1.0: 1 port detected
[    8.128487] usbcore: registered new interface driver usb-storage
[    8.141500] kmodloader: done loading kernel modules from /etc/modules-boot.d/*
[    8.159948] init: - preinit -
[    9.672360] 8021q: adding VLAN 0 to HW filter on device eth0
Press the [f] key and hit [enter] to enter failsafe mode
Press the [1], [2], [3] or [4] key and hit [enter] to select the debug level
[   10.639422] mount_root: loading kmods from internal overlay
[   10.689313] kmodloader: loading kernel modules from //etc/modules-boot.d/*
[   10.704704] kmodloader: done loading kernel modules from //etc/modules-boot.d/*
[   12.633497] jffs2: notice: (375) jffs2_build_xattr_subsystem: complete building xattr subsystem, 0 of xdatum (0 unchecked, 0 orphan) and 0 of xref (0 dead, 0 orphan) found.
[   12.665188] block: attempting to load /tmp/jffs_cfg/upper/etc/config/fstab
[   12.687751] block: extroot: not configured
[   13.977536] jffs2: notice: (372) jffs2_build_xattr_subsystem: complete building xattr subsystem, 0 of xdatum (0 unchecked, 0 orphan) and 0 of xref (0 dead, 0 orphan) found.
[   14.655930] block: attempting to load /tmp/jffs_cfg/upper/etc/config/fstab
[   14.676770] block: extroot: not configured
[   14.686093] mount_root: switching to jffs2 overlay
[   14.711990] urandom-seed: Seeding with /etc/urandom.seed
[   14.863915] procd: - early -
[   14.870430] procd: - watchdog -
[   15.683961] procd: - ubus -
[   15.849699] random: jshn: uninitialized urandom read (4 bytes read, 28 bits of entropy available)
[   16.068468] random: ubusd: uninitialized urandom read (4 bytes read, 28 bits of entropy available)
[   16.086684] random: ubus: uninitialized urandom read (4 bytes read, 28 bits of entropy available)
[   16.151673] random: ubusd: uninitialized urandom read (4 bytes read, 28 bits of entropy available)
[   16.187036] random: ubusd: uninitialized urandom read (4 bytes read, 28 bits of entropy available)
[   16.224857] random: ubusd: uninitialized urandom read (4 bytes read, 28 bits of entropy available)
[   16.264112] random: ubusd: uninitialized urandom read (4 bytes read, 29 bits of entropy available)
[   16.288776] random: jshn: uninitialized urandom read (4 bytes read, 29 bits of entropy available)
[   16.306686] random: ubusd: uninitialized urandom read (4 bytes read, 29 bits of entropy available)
[   16.333880] random: ubusd: uninitialized urandom read (4 bytes read, 29 bits of entropy available)
[   16.352419] procd: - init -
Please press Enter to activate this console.
[   17.442268] kmodloader: loading kernel modules from /etc/modules.d/*
[   17.758778] tun: Universal TUN/TAP device driver, 1.6
[   17.768914] tun: (C) 1999-2004 Max Krasnyansky <maxk@qualcomm.com>
[   17.812569] ip6_tables: (C) 2000-2006 Netfilter Core Team
[   17.854855] Loading modules backported from Linux version wt-2017-01-31-0-ge882dff19e7f
[   17.870878] Backport generated by backports.git backports-20160324-13-g24da7d3c
[   18.060578] u32 classifier
[   18.065970]     input device check on
[   18.073313]     Actions configured
[   18.108790] Mirror/redirect action on
[   18.129348] nf_conntrack version 0.5.0 (949 buckets, 3796 max)
[   18.184662] fuse init (API version 7.23)
[   18.206104] usbcore: registered new interface driver cdc_acm
[   18.217456] cdc_acm: USB Abstract Control Model driver for USB modems and ISDN adapters
[   18.278253] usbcore: registered new interface driver cdc_wdm
[   18.301105] ip_tables: (C) 2000-2006 Netfilter Core Team
[   18.449023] usbcore: registered new interface driver usblp
[   18.492493] usbcore: registered new interface driver usbserial
[   18.504292] usbcore: registered new interface driver usbserial_generic
[   18.517449] usbserial: USB Serial support registered for generic
[   18.643651] xt_time: kernel timezone is -0000
[   18.664753] usbcore: registered new interface driver cdc_ether
[   18.700672] usbcore: registered new interface driver cdc_ncm
[   18.728008] usbcore: registered new interface driver huawei_cdc_ncm
[   18.796001] PPP generic driver version 2.4.2
[   18.829169] NET: Registered protocol family 24
[   18.855008] usbcore: registered new interface driver qmi_wwan
[   18.879571] usbcore: registered new interface driver rndis_host
[   18.955834] rt2800_wmac 10180000.wmac: loaded eeprom from mtd device "factory"
[   18.970315] ieee80211 phy0: rt2x00_set_rt: Info - RT chipset 6352, rev 0500 detected
[   18.985771] ieee80211 phy0: rt2x00_set_rf: Info - RF chipset 7620 detected
[   19.054371] usbcore: registered new interface driver sierra
[   19.065662] usbserial: USB Serial support registered for Sierra USB modem
[   19.112633] usbcore: registered new interface driver sierra_net
[   19.152904] usbcore: registered new interface driver cdc_mbim
[   19.178798] usbcore: registered new interface driver option
[   19.190084] usbserial: USB Serial support registered for GSM modem (1-port)
[   19.242204] usbcore: registered new interface driver qcserial
[   19.253851] usbserial: USB Serial support registered for Qualcomm USB modem
[   19.296417] kmodloader: done loading kernel modules from /etc/modules.d/*
[   30.377819] 8021q: adding VLAN 0 to HW filter on device eth0
[   30.408805] device eth0.1 entered promiscuous mode
[   30.418426] device eth0 entered promiscuous mode
[   30.467557] br-lan: port 1(eth0.1) entered forwarding state
[   30.478761] br-lan: port 1(eth0.1) entered forwarding state
[   32.476592] br-lan: port 1(eth0.1) entered forwarding state

14

(414 odpowiedzi, napisanych Oprogramowanie)

No właśnie, ale sieć nie działa i dioda przy uruchamianiu nie miga.

15

(414 odpowiedzi, napisanych Oprogramowanie)

Cezary napisał/a:

I okazało się że 16 jest więcej niż się przyznaliście smile

No właśnie byłem zdziwiony, bo mój w statystykach pojawił się jako pierwszy.

Wracając do tematu upgrade CC do LEDE. Sprawdziłem temat jeszcze raz i efekt jest taki, że dioda nie miga przy uruchamianiu i nie ma dostępu do sieci. Poniżej log:

root@OpenWrt:/tmp# sysupgrade -n luci-17.01-snapshot-r3371-79cd141-ramips-mt7620
-wt3020-16M-squashfs-sysupgrade.bin
killall: watchdog: no process killed
Sending TERM to remaining processes ... logd rpcd odhcpd uhttpd dnsmasq smbd nmb                                                      d ntpd netifd odhcp6c ubusd
Sending KILL to remaining processes ...
Switching to ramdisk...
Performing system upgrade...
Unlocking firmware ...

Writing from <stdin> to firmware ...
Upgrade completed
Rebooting s[  582.560000] reboot: Restarting system
ystem...


U-Boot 1.1.3 (Jan  3 2014 - 09:12:42)

MAX Board: Ralink APSoC DRAM:  64 MB
relocate_code Pointer at: 83fb4000
enable ephy clock...done. rf reg 29 = 5
SSC disabled.
******************************
Software System Reset Occurred
******************************
spi_wait_nsec: 29
spi device id: ef 40 18 0 0 (40180000)
Warning: un-recognized chip ID, please update bootloader!
raspi_read: from:30000 len:1000
raspi_read: from:30000 len:1000
============================================
Ralink UBoot Version: 4.1.1.0
--------------------------------------------
ASIC 7620_MP (Port5<->None)
DRAM component: 512 Mbits DDR, width 16
DRAM bus: 16 bit
Total memory: 64 MBytes
Flash component: SPI Flash
Date:Jan  3 2014  Time:09:12:42
============================================
icache: sets:512, ways:4, linesz:32 ,total:65536
dcache: sets:256, ways:4, linesz:32 ,total:32768

 ##### The CPU freq = 580 MHZ ####
 estimate memory size =64 Mbytes

Please choose the operation:
   1: Load system code to SDRAM via TFTP.
   2: Load system code then write to Flash via TFTP.
   3: Boot system code via Flash (default).
   4: Entr boot command line interface.
   7: Load Boot Loader code then write to Flash via Serial.
   9: Load Boot Loader code then write to Flash via TFTP.                                                                           0

3: System Boot system code via Flash.
## Booting image at bc050000 ...
raspi_read: from:50000 len:40
   Image Name:   MIPS LEDE Linux-4.4.61
   Image Type:   MIPS Linux Kernel Image (lzma compressed)
   Data Size:    1312277 Bytes =  1.3 MB
   Load Address: 80000000
   Entry Point:  80000000
raspi_read: from:50040 len:140615
   Verifying Checksum ... OK
   Uncompressing Kernel Image ... OK
No initrd
## Transferring control to Linux (at address 80000000) ...
## Giving linux memsize in MB, 64

Starting kernel ...

[    0.000000] Linux version 4.4.61 (cezary@eko.one.pl) (gcc version 5.4.0 (LEDE GCC 5.4.0 r3103-1b51a49) ) #0 Wed May 3 23:03:25 2017
[    0.000000] Board has DDR1
[    0.000000] Analog PMU set to hw control
[    0.000000] Digital PMU set to hw control
[    0.000000] SoC Type: MediaTek MT7620N ver:2 eco:6
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU0 revision is: 00019650 (MIPS 24KEc)
[    0.000000] MIPS: machine is Nexx WT3020 (16M)
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 04000000 @ 00000000 (usable)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x0000000000000000-0x0000000003ffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x0000000000000000-0x0000000003ffffff]
[    0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x0000000003ffffff]
[    0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 16256
[    0.000000] Kernel command line: console=ttyS0,57600 rootfstype=squashfs,jffs2
[    0.000000] PID hash table entries: 256 (order: -2, 1024 bytes)
[    0.000000] Dentry cache hash table entries: 8192 (order: 3, 32768 bytes)
[    0.000000] Inode-cache hash table entries: 4096 (order: 2, 16384 bytes)
[    0.000000] Writing ErrCtl register=0005fe70
[    0.000000] Readback ErrCtl register=0005fe70
[    0.000000] Memory: 60580K/65536K available (3037K kernel code, 142K rwdata, 720K rodata, 188K init, 208K bss, 4956K reserved, 0K cma-reserved)
[    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] NR_IRQS:256
[    0.000000] CPU Clock: 580MHz
[    0.000000] clocksource: systick: mask: 0xffff max_cycles: 0xffff, max_idle_ns: 583261500 ns
[    0.000000] systick: enable autosleep mode
[    0.000000] systick: running - mult: 214748, shift: 32
[    0.000000] clocksource: MIPS: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 6590553264 ns
[    0.000012] sched_clock: 32 bits at 290MHz, resolution 3ns, wraps every 7405115902ns
[    0.015455] Calibrating delay loop... 385.84 BogoMIPS (lpj=1929216)
[    0.080605] pid_max: default: 32768 minimum: 301
[    0.089916] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.102937] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.122097] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
[    0.141586] futex hash table entries: 256 (order: -1, 3072 bytes)
[    0.153831] pinctrl core: initialized pinctrl subsystem
[    0.165369] NET: Registered protocol family 16
[    0.192777] rt2880_gpio 10000600.gpio: registering 24 gpios
[    0.203792] rt2880_gpio 10000600.gpio: registering 24 irq handlers
[    0.216208] rt2880_gpio 10000660.gpio: registering 32 gpios
[    0.227198] rt2880_gpio 10000660.gpio: registering 32 irq handlers
[    0.239602] rt2880_gpio 10000688.gpio: registering 1 gpios
[    0.250401] rt2880_gpio 10000688.gpio: registering 1 irq handlers
[    0.264091] clocksource: Switched to clocksource systick
[    0.276017] NET: Registered protocol family 2
[    0.285587] TCP established hash table entries: 1024 (order: 0, 4096 bytes)
[    0.299354] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
[    0.311948] TCP: Hash tables configured (established 1024 bind 1024)
[    0.324674] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.336205] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.348936] NET: Registered protocol family 1
[    0.361649] rt-timer 10000100.timer: maximum frequency is 1220Hz
[    0.374594] Crashlog allocated RAM at address 0x3f00000
[    0.401319] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.412841] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.435032] io scheduler noop registered
[    0.442685] io scheduler deadline registered (default)
[    0.453200] ralink-usb-phy usbphy: invalid resource
[    0.463425] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
[    0.479464] console [ttyS0] disabled
[    0.486502] 10000c00.uartlite: ttyS0 at MMIO 0x10000c00 (irq = 20, base_baud = 2500000) is a Palmchip BK-3103
[    0.506178] console [ttyS0] enabled
[    0.506178] console [ttyS0] enabled
[    0.520000] bootconsole [early0] disabled
[    0.520000] bootconsole [early0] disabled
[    0.542714] spi spi0.0: force spi mode3
[    0.550940] m25p80 spi0.0: w25q128 (16384 Kbytes)
[    0.560379] 4 ofpart partitions found on MTD device spi0.0
[    0.571308] Creating 4 MTD partitions on "spi0.0":
[    0.580858] 0x000000000000-0x000000030000 : "u-boot"
[    0.592502] 0x000000030000-0x000000040000 : "u-boot-env"
[    0.605027] 0x000000040000-0x000000050000 : "factory"
[    0.616952] 0x000000050000-0x000001000000 : "firmware"
[    1.950249] 2 uimage-fw partitions found on MTD device firmware
[    1.962078] 0x000000050000-0x000000190655 : "kernel"
[    1.973574] 0x000000190655-0x000001000000 : "rootfs"
[    1.985311] mtd: device 5 (rootfs) set to be root filesystem
[    1.996787] 1 squashfs-split partitions found on MTD device rootfs
[    2.009120] 0x00000065f000-0x000001000000 : "rootfs_data"
[    2.024794] mtk_soc_eth 10100000.ethernet: loaded mt7620 driver
[    2.037383] mtk_soc_eth 10100000.ethernet eth0: mediatek frame engine at 0xb0100000, irq 5
[    2.054445] rt2880_wdt 10000120.watchdog: Initialized
[    2.066048] NET: Registered protocol family 10
[    2.079397] NET: Registered protocol family 17
[    2.088417] bridge: automatic filtering via arp/ip/ip6tables has been deprecated. Update your scripts to load br_netfilter if you need this.
[    2.113577] 8021q: 802.1Q VLAN Support v1.8
[    2.136187] VFS: Mounted root (squashfs filesystem) readonly on device 31:5.
[    2.151295] Freeing unused kernel memory: 188K (803d1000 - 80400000)
[    4.567081] init: Console is alive
[    4.574060] init: - watchdog -
[    7.657889] kmodloader: loading kernel modules from /etc/modules-boot.d/*
[    7.796315] usbcore: registered new interface driver usbfs
[    7.807421] usbcore: registered new interface driver hub
[    7.818132] usbcore: registered new device driver usb
[    7.867418] SCSI subsystem initialized
[    7.881798] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    7.896591] ehci-platform: EHCI generic platform driver
[    7.917359] phy phy-usbphy.0: remote usb device wakeup disabled
[    7.929162] phy phy-usbphy.0: UTMI 16bit 30MHz
[    7.938040] ehci-platform 101c0000.ehci: EHCI Host Controller
[    7.949525] ehci-platform 101c0000.ehci: new USB bus registered, assigned bus number 1
[    7.965426] ehci-platform 101c0000.ehci: irq 26, io mem 0x101c0000
[    7.983507] ehci-platform 101c0000.ehci: USB 2.0 started, EHCI 1.00
[    7.997073] hub 1-0:1.0: USB hub found
[    8.004967] hub 1-0:1.0: 1 port detected
[    8.016199] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[    8.030212] ohci-platform: OHCI generic platform driver
[    8.040950] ohci-platform 101c1000.ohci: Generic Platform OHCI controller
[    8.054554] ohci-platform 101c1000.ohci: new USB bus registered, assigned bus number 2
[    8.070413] ohci-platform 101c1000.ohci: irq 26, io mem 0x101c1000
[    8.105114] hub 2-0:1.0: USB hub found
[    8.113033] hub 2-0:1.0: 1 port detected
[    8.127881] usbcore: registered new interface driver usb-storage
[    8.140882] kmodloader: done loading kernel modules from /etc/modules-boot.d/*
[    8.159339] init: - preinit -
[    9.672162] 8021q: adding VLAN 0 to HW filter on device eth0
Press the [f] key and hit [enter] to enter failsafe mode
Press the [1], [2], [3] or [4] key and hit [enter] to select the debug level
[   10.979166] mount_root: loading kmods from internal overlay
[   11.028590] kmodloader: loading kernel modules from //etc/modules-boot.d/*
[   11.044096] kmodloader: done loading kernel modules from //etc/modules-boot.d/*
[   11.701920] block: attempting to load /etc/config/fstab
[   11.714550] block: unable to load configuration (fstab: Entry not found)
[   11.728061] block: no usable configuration
[   11.736968] mount_root: jffs2 not ready yet, using temporary tmpfs overlay
[   11.757253] urandom-seed: Seed file not found (/etc/urandom.seed)
[   11.894468] procd: - early -
[   11.900448] procd: - watchdog -
[   12.762541] procd: - ubus -
[   12.868758] random: jshn: uninitialized urandom read (4 bytes read, 24 bits of entropy available)
[   13.084203] random: ubusd: uninitialized urandom read (4 bytes read, 24 bits of entropy available)
[   13.102721] random: ubusd: uninitialized urandom read (4 bytes read, 24 bits of entropy available)
[   13.120943] random: ubus: uninitialized urandom read (4 bytes read, 24 bits of entropy available)
[   13.138884] random: ubusd: uninitialized urandom read (4 bytes read, 24 bits of entropy available)
[   13.157206] random: ubusd: uninitialized urandom read (4 bytes read, 24 bits of entropy available)
[   13.179039] random: ubusd: uninitialized urandom read (4 bytes read, 24 bits of entropy available)
[   13.197068] random: ubusd: uninitialized urandom read (4 bytes read, 24 bits of entropy available)
[   13.215158] random: ubusd: uninitialized urandom read (4 bytes read, 24 bits of entropy available)
[   13.233272] random: ubusd: uninitialized urandom read (4 bytes read, 24 bits of entropy available)
[   13.251580] procd: - init -
Please press Enter to activate this console.
[   14.448286] kmodloader: loading kernel modules from /etc/modules.d/*
[   14.743497] tun: Universal TUN/TAP device driver, 1.6
[   14.753632] tun: (C) 1999-2004 Max Krasnyansky <maxk@qualcomm.com>
[   14.811314] ip6_tables: (C) 2000-2006 Netfilter Core Team
[   14.842766] Loading modules backported from Linux version wt-2017-01-31-0-ge882dff19e7f
[   14.858782] Backport generated by backports.git backports-20160324-13-g24da7d3c
[   15.040896] u32 classifier
[   15.046288]     input device check on
[   15.053629]     Actions configured
[   15.089756] Mirror/redirect action on
[   15.113008] nf_conntrack version 0.5.0 (949 buckets, 3796 max)
[   15.154703] fuse init (API version 7.23)
[   15.186549] usbcore: registered new interface driver cdc_acm
[   15.197893] cdc_acm: USB Abstract Control Model driver for USB modems and ISDN adapters
[   15.249243] usbcore: registered new interface driver cdc_wdm
[   15.284215] ip_tables: (C) 2000-2006 Netfilter Core Team
[   15.423462] usbcore: registered new interface driver usblp
[   15.469394] usbcore: registered new interface driver usbserial
[   15.481203] usbcore: registered new interface driver usbserial_generic
[   15.494354] usbserial: USB Serial support registered for generic
[   15.620728] xt_time: kernel timezone is -0000
[   15.640074] usbcore: registered new interface driver cdc_ether
[   15.672740] usbcore: registered new interface driver cdc_ncm
[   15.701130] usbcore: registered new interface driver huawei_cdc_ncm
[   15.769896] PPP generic driver version 2.4.2
[   15.801137] NET: Registered protocol family 24
[   15.822294] usbcore: registered new interface driver qmi_wwan
[   15.842765] usbcore: registered new interface driver rndis_host
[   15.911892] rt2800_wmac 10180000.wmac: loaded eeprom from mtd device "factory"
[   15.926367] ieee80211 phy0: rt2x00_set_rt: Info - RT chipset 6352, rev 0500 detected
[   15.941818] ieee80211 phy0: rt2x00_set_rf: Info - RF chipset 7620 detected
[   16.012450] usbcore: registered new interface driver sierra
[   16.023739] usbserial: USB Serial support registered for Sierra USB modem
[   16.072312] usbcore: registered new interface driver sierra_net
[   16.102139] usbcore: registered new interface driver cdc_mbim
[   16.133728] usbcore: registered new interface driver option
[   16.145017] usbserial: USB Serial support registered for GSM modem (1-port)
[   16.196246] usbcore: registered new interface driver qcserial
[   16.207910] usbserial: USB Serial support registered for Qualcomm USB modem
[   16.301822] kmodloader: done loading kernel modules from /etc/modules.d/*
[   30.442304] 8021q: adding VLAN 0 to HW filter on device eth0
[   30.494196] device eth0.1 entered promiscuous mode
[   30.503820] device eth0 entered promiscuous mode
[   30.573433] br-lan: port 1(eth0.1) entered forwarding state
[   30.584635] br-lan: port 1(eth0.1) entered forwarding state
[   32.579673] br-lan: port 1(eth0.1) entered forwarding state
[   54.502174] jffs2_scan_eraseblock(): End of filesystem marker found at 0x0
[   54.516788] jffs2_build_filesystem(): unlocking the mtd device... done.
[   54.530003] jffs2_build_filesystem(): erasing all blocks after the end marker...
[   76.599663] random: nonblocking pool is initialized
[  155.085229] br-lan: port 1(eth0.1) entered disabled state
[  156.863252] br-lan: port 1(eth0.1) entered forwarding state
[  156.874428] br-lan: port 1(eth0.1) entered forwarding state
[  158.869623] br-lan: port 1(eth0.1) entered forwarding state
[  214.333871] br-lan: port 1(eth0.1) entered disabled state
[  217.189141] br-lan: port 1(eth0.1) entered forwarding state
[  217.200321] br-lan: port 1(eth0.1) entered forwarding state
[  219.199625] br-lan: port 1(eth0.1) entered forwarding state
[  279.160089] br-lan: port 1(eth0.1) entered disabled state
[  295.751783] done.
[  295.755661] jffs2: notice: (1736) jffs2_build_xattr_subsystem: complete building xattr subsystem, 0 of xdatum (0 unchecked, 0 orphan) and 0 of xref (0 dead, 0 orphan) found.
[  304.989926] br-lan: port 1(eth0.1) entered forwarding state
[  305.001146] br-lan: port 1(eth0.1) entered forwarding state
[  305.862509] br-lan: port 1(eth0.1) entered forwarding state

16

(414 odpowiedzi, napisanych Oprogramowanie)

U mnie też nie mrugała dioda.

17

(414 odpowiedzi, napisanych Oprogramowanie)

Ja używam ale za pierwszym razem router nie wstał ( nie było dostępu po kablu ). Dostałem się przez UART, odpaliłem wifi i dopiero wtedy się do niego dostałem. Wgrałem LEDE jeszcze raz ( błąd sysupgrade - obraz niby do innego routera ) i dopiero wtedy wstał. Sprawdziłem na innym egzemplarzu ( też 16 MB ) i przy wgrywaniu z oryginalnego softu wstał za pierwszym razem.

18

(414 odpowiedzi, napisanych Oprogramowanie)

Sam sobie odpowiem smile Po podłączeniu konsoli okazało się, że LEDE się uruchamia, ale nie dało się z nim połączyć. W trybie failsafe to samo. Nie zagłębiałem się w logi, bo nie miałem czasu. Wgrałem obraz jeszcze raz i wystartowało. Dlaczego musiałem użyć --force przy sysupgrade? Wyrzucało, że obraz jest do WT3020-16M ale właśnie na takim chciałem go zainstalować.

19

(22 odpowiedzi, napisanych Sprzęt)

tygrysss napisał/a:

Próbowałem wgra soft od kolegi Grubereg ale na nim wgl router nie wstawał (nie ładował się nawet uboot).

Prawdopodobnie źle przylutowałeś kość, bo uboota nie ruszałem. Zmieniłem tylko rozmiar i przeniosłem ART na koniec.

20

(414 odpowiedzi, napisanych Oprogramowanie)

Wrzucał ktoś ostatni obraz LEDE na Nexx WT3020 16MB? Postanowiłem w końcu zrobić upgrade z CC i router już nie wstał. Pierwszy raz taka sytuacja smile. Przypadek czy coś z nim nie tak? Jestem poza domem więc nie mam sprzętu żeby sprawdzić co jest nie tak i postawić go na nowo sad

21

(22 odpowiedzi, napisanych Sprzęt)

Edytor HEX + kalkulator Windows = nic trudnego.
http://www39.zippyshare.com/v/hkxDkM7j/file.html

22

(6 odpowiedzi, napisanych Sprzęt)

Temat który mnie interesuje. Również skłaniam się ku Netgear R7800 ale zastanawiam się jeszcze nad Zyxel nbg6817. Miał ktoś z nim styczność?

23

(31 odpowiedzi, napisanych Oprogramowanie)

r43k3n napisał/a:

Swoją drogą jak to jest, że dl.eko.one.pl potrafi nie działać ale strona i forum wczytują się normalnie?

Są na innych serwerach. dl.eko.one.pl jest w domu u Cezarego, a strona na hostingu zenbox.

24

(28 odpowiedzi, napisanych Oprogramowanie)

Jak ze wsparciem Lede dla tego modelu?

25

(367 odpowiedzi, napisanych Oprogramowanie)

Cezary napisał/a:

Roboty nie, konfiguracja jest bardzo podobna. Lekkie zmiany są w plikach konfiguracyjnych, ale spokojnie odnajdziesz się.

A warto aktualizować czy nie ma sensu się spieszyć? Lecę na CC r48430. Można liczyć na jakąś poprawę wydajności, np wifi AC?