1

(0 odpowiedzi, napisanych Inne)

Do wiadomości, choć pewnie zainteresowani już wiedzą...

The purpose of this letter is to notify you that DtDNS will be ceasing operations on August 1, 2018


DtDNS will be ceasing operations on August 1, 2018.  Many of our customers use our free service, which we have been happy to provide for many years.  Unfortunately, we are unable to continue both the paid and free service as the number of complaints coming from our community DNS and dynamic hosting service have steadily increased over the last couple of years.  Unfortunately the nature of offering a free hosting service opens a business up to abuses — a few bad actors make this type of offering quite challenging to operate.

You are receiving this email because you have an account in our system:


You will need to migrate your DNS hosting to another provider before that date. After that time, we will no longer be available to provide assistance. Thank you for your past business and support. We wish you all the best for your continued success.

Due to the nature of dynamic DNS hosting, we are not able to transfer any dynamic domains nor any dynamic domain hosts to another provider.  All changes in DNS settings should be made at your registrar. There is no need to make any changes on the DtDNS site as your account will automatically be deleted when we cease operations.  We are not able to help with the transfer of any domains to other DNS hosting providers.

June 28th, 2018

Próbowałem już tak.

Jak to ma wyglądać tak:
opkg remove --force-removal-of-dependent-packages libstdcpp

czy tak

opkg remove --force-removal-of-dependent-libstdcpp

żadne z w/w nie działa.

Cezary napisał/a:

opkg remove libstdcpp po prostu. Jeżeli coś od tego zależy to napisze że nie może usunąć i co powoduje problem. Więc i to musisz wcześniej usunąć.

Próbowałem...

root@LEDE:~# opkg remove libstdcpp
        Refusing to remove essential package libstdcpp.
        Removing an essential package may lead to an unusable system, but if
        you enjoy that kind of pain, you can force opkg to proceed against
        its will with the option: --force-removal-of-essential-packages
No packages removed.

a bałagan powstał z instalacji poniżej;

root@LEDE:~# opkg install php7-fastcgi
Installing php7-fastcgi (7.1.1-1) to root...
Downloading http://downloads.lede-project.org/releases/17.01-SNAPSHOT/packages/mips_24kc/packages/php7-fastcgi_7.1.1-1_mips_24kc.ipk
Installing zlib (1.2.11-1) to root...
Downloading http://dl.eko.one.pl/lede/17.01-SNAPSHOT/packages/mips_24kc/base/zlib_1.2.11-1_mips_24kc.ipk
Installing libxml2 (2.9.4-1) to root...
Downloading http://downloads.lede-project.org/releases/17.01-SNAPSHOT/packages/mips_24kc/packages/libxml2_2.9.4-1_mips_24kc.ipk
Installing php7 (7.1.1-1) to root...
Downloading http://downloads.lede-project.org/releases/17.01-SNAPSHOT/packages/mips_24kc/packages/php7_7.1.1-1_mips_24kc.ipk
Installing libstdcpp (5.4.0-1) to root...
Downloading http://dl.eko.one.pl/lede/17.01-SNAPSHOT/targets/ar71xx/generic/packages/libstdcpp_5.4.0-1_mips_24kc.ipk
Installing php7-cgi (7.1.1-1) to root...
Configuring zlib.
Configuring libxml2.
Configuring libstdcpp.
Configuring php7.
Collected errors:
 * verify_pkg_installable: Only have 744kb available on filesystem /overlay, pkg php7-cgi needs 1408
 * opkg_install_cmd: Cannot install package php7-fastcgi.

Witam.

Instalowałem Lighttpd i dużo dodatków, aż zabrakło miejsca we flash.
Więc zacząłem wszystko od końca odinstalowywać.

Jednak jednego pakietu nie mogę odinstalować: libstdcpp

Nie pomaga opkg remove --force-removal-of-dependent-packages libstdcpp
ani
opkg remove --autoremove libstdcpp

chyba że robię to źle?

5

(3 odpowiedzi, napisanych Oprogramowanie)

Cezary napisał/a:

w /var/run/ddns/dns_*.dat i /var/run/ddns/dns_*.err sprawdź co jest.

dns_1.dat
Host edzia.suroot.com now points to 37.190.201.34.

dns_1.err - jest pusty

dns_1.pid
1682

dns_1.update
44

Pozostałe czyli 2 i 3 analogicznie.

Z tym że 3-ci jest z changeip.com i ma tak
dns_3.dat
200 Successful Update

6

(3 odpowiedzi, napisanych Oprogramowanie)

Witam.

System czyste lede-17.01-snapshot-r3566-98c003e-ar71xx-nand-nbg6716 i na nim 3 usługi ddns.
adres IP aktualizuje, usługi ddns działają, lecz w logach widzę błędy?
Pakiet uclient-fetch oraz kmod-nf-nathelper mam zainstalowane.

162219  info : Rerun IP check at 2018-06-10 16:22
 162219       : Detect local IP on 'web'
 162219       : #> /bin/uclient-fetch -q -O /var/run/ddns/dns_1.dat -Y off 'http://checkip.dyndns.com' 2>/var/run/ddns/dns_1.err
 162220       : Local IP '37.190.201.34' detected on web at 'http://checkip.dyndns.com'
 162220       : Waiting 900 seconds (Check Interval)
162231  info : Rerun IP check at 2018-06-10 16:22
 162231       : Detect local IP on 'web'
 162231       : #> /bin/uclient-fetch -q -O /var/run/ddns/dns_2.dat -Y off 'http://checkip.dyndns.com' 2>/var/run/ddns/dns_2.err
 162231       : Local IP '37.190.201.34' detected on web at 'http://checkip.dyndns.com'
 162231       : Waiting 900 seconds (Check Interval)
162201  info : Rerun IP check at 2018-06-10 16:22
 162202       : Detect local IP on 'web'
 162202       : #> /bin/uclient-fetch -q -O /var/run/ddns/dns_3.dat -Y off 'http://checkip.dyndns.com' 2>/var/run/ddns/dns_3.err
 162204       : Local IP '37.190.201.34' detected on web at 'http://checkip.dyndns.com'
 162204       : Waiting 900 seconds (Check Interval)

7

(6 odpowiedzi, napisanych Oprogramowanie)

Cezary napisał/a:

I o kmod-nf-nathelper nie zapomnij.

Nie wiem co to i czy potrzebne jeszcze ponieważ zrobiłem jak pisałem i działa smile Dziękuję!

Instalować jeszcze kmod-nf-nathelper ?

8

(6 odpowiedzi, napisanych Oprogramowanie)

Czy w /etc/proftpd.conf
mam zostawić Port    21
i pod spodem dopisać np:
PassivePorts    34000 34500

Natomiast w /etc/config/firewall
jak zapisać zakres portów, może tak?

config rule
    option name 'proftpd'
    option src 'wan'
    option target 'ACCEPT'
    option proto 'tcp'
    option dest_port '34000:34500'

9

(6 odpowiedzi, napisanych Oprogramowanie)

Witam.

Problem z poprawnym działaniem Proftpd?
1. Sprzęt ZyXEL NBG6716 + Lede-17.01-snapshot-r3566-98c003e + skompilowany Proftpd_1.3.5-1_mips_24kc.ipk
Wszystko niby dobrze skonfigurowane, Proftpd na starcie błędów nie wywala. Sprzęt stoi u siostry, połączenie internet z Multimedia.

2. Ja łączę od siebie siebie z domu, także internet z Multimedia za pomocą Total Commander w trybie pasywnym.
Połączenie udaje się nawiązać jednak Total Commander wywala komunikat 425 unable to build data connection connection refused. Próbowałem połączenie w trybie aktywnym i bez zmian.
Efektem jest że nie listuje mi plików i katalogów. Np. mogę utworzyć ale ich nie widzę.

3. Ciekawe jest to, że jeśli ja do połączenia z siostry ftp nie użyję mojego internetu z multimedia tylko np. LTE Plus to wszystko działa.


Może znalazłem potencjalne rozwiązanie problemu https://forum.slackware.pl/viewtopic.ph … amp;t=3477

"Pozwól na połączenia z portem 20 tcp."
modprobe ip_conntrack_ftp
iptables -I INPUT 1 -m state --state ESTBALISHED,RELATED -j ACCEPT
+ przepuszczenie na port 21 --state NEW
portu 20 nie trzeba ruszac nim zajmie sie juz ip_conntrack_ftp

Tylko nie wiem jak to zastosować na Lede.

10

(1 odpowiedzi, napisanych Oprogramowanie)

Wiem trochę więcej. Jak w komputerze ustawię dns z ręki np. 8.8.4.4 to działa.

Witam.

Świeżo zainstalowany lede-17.01-snapshot-r3876 na ZyXEL NBG6716.

Nie mam już pojęcia dlaczego komputer podłączony do switch ZyXEL NBG6716 nie zawsze ma połączenie z internetem.
Czasami - często wyłączenie z prądu modemu multimedia, routera, komputera i włączenia na nowo pomaga. Lecz nie zawsze za pierwszym razem.

Bootowanie komputera po Lan z serwera PXE - jest na ZyXEL NBG6716 też nie zawsze działa, nie znajduje adresu...

Nigdy z tym nie było problemu, po instalacji wszystko działało.

/etc/config/network

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fdfb:54b5:4437::/48'

config interface 'lan'
    option type 'bridge'
    option ifname 'eth0'
    option proto 'static'
    option ipaddr '192.168.2.1'
    option netmask '255.255.255.0'
    option ip6assign '60'

config interface 'wan'
    option ifname 'eth1'
    option proto 'dhcp'

config interface 'wan6'
    option ifname 'eth1'
    option proto 'dhcpv6'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '1 2 3 4 0'

config switch_vlan
    option device 'switch0'
    option vlan '2'
    option ports '5 6'

/etc/config/dhcp

config dnsmasq
    option domainneeded '1'
    option boguspriv '1'
    option filterwin2k '0'
    option localise_queries '1'
    option rebind_protection '1'
    option rebind_localhost '1'
    option local '/lan/'
    option domain 'lan'
    option expandhosts '1'
    option nonegcache '0'
    option authoritative '1'
    option readethers '1'
    option leasefile '/tmp/dhcp.leases'
    option resolvfile '/tmp/resolv.conf.auto'
    option localservice '1'
    
config dhcp 'lan'
    option interface 'lan'
    option start '10'
    option limit '20'
    option leasetime '12h'
    option dhcpv6 'server'
    option ra 'server'

config dhcp 'wan'
    option interface 'wan'
    option ignore '1'

config odhcpd 'odhcpd'
    option maindhcp '0'
    option leasefile '/tmp/hosts/odhcpd'
    option leasetrigger '/usr/sbin/odhcpd-update'

12

(23 odpowiedzi, napisanych Oprogramowanie)

Plik z logiem powinien być tutaj /tmp/log jaka jego nazwa?
Pewnie teraz go nie będzie bo jestem po reboocie, ale chciałbym wiedzieć gdzie i jakiego pliku szukać.

13

(23 odpowiedzi, napisanych Oprogramowanie)

Masz na myśli /etc/config/acme

config acme
    option debug '1'

14

(23 odpowiedzi, napisanych Oprogramowanie)

Problem z automatyzacją odnawiania certyfikatu

W cron mam odnawianie cyklicznie co miesiąc, lecz nie działa?:

0 0 1 * * /etc/init.d/acme start

Z ręki wykonane to samo polecenie i działa.

Nie wiem czy problem jest po stronie błędnego okresu odnawiania? czy może po samym działaniu cron. Pytam o cron ponieważ mam czyste LEDE i w /etc/crontabs nie było pliku root więc go utworzyłem i wpisałem polecenia do wykonania które potrzebuję.
Potem jak w poradniku:
# /etc/init.d/cron restart
# /etc/init.d/cron enable
# /etc/init.d/cron start

15

(33 odpowiedzi, napisanych Inne)

Cezary napisał/a:

Jeszcze nie. Zastanawiam się nad zwykłym pc z jakimś celeronem typu n3050/n3150.

Jest trochę tego także w wersji mini https://pl.aliexpress.com/item/Eglobal- … autifyAB=0 za 8GB Ram i Celeron N3150 US $176.80 bez dysku.
Jak to jest z dostępnymi programami / pakietami dla Openwrt x86, to co jest dostępne dla ar71xx jest także dla x86 ?

16

(33 odpowiedzi, napisanych Inne)

@Cezary, jak tam wybrałeś / kupiłeś coś dla "siebie"? pytam ponieważ może sprzęt który wybrałeś będzie inspiracją np. dla mnie. W moim poczciwym TL-WDR4300 v1.5 brakuje mi miejsca, a extroota nie chcę.

17

(27 odpowiedzi, napisanych Sprzęt)

Dziękuję, fw wgrane router działa smile.

18

(27 odpowiedzi, napisanych Sprzęt)

Miałem kilka programów np. Digitemp, Proftpd itp skompilowanych pod wersję lede-17.01-snapshot-r3566-98c003e-ar71xx
Mogę teraz wgrać najnowsze LEDE i użyć w/w paczek, będą działać?

19

(27 odpowiedzi, napisanych Sprzęt)

Cezary napisał/a:

Rozwalony jest obraz we flash.

Wgraj jeszcze raz przez bootloader lub tryb awaryjny uboota.

Rozumiem że to się wiąże z instalacją i konfiguracją wszystkiego od nowa?

20

(27 odpowiedzi, napisanych Sprzęt)

Wiec miałem trochę szczęścia, chyba wink
Poniżej log z uruchamiania, widać coś co może być nie tak?

*****************************************
*      U-Boot 1.1.4  (Nov  1 2013)      *
*****************************************

DB120 (AR9344) U-Boot for TL-WDR3600/43x0

DRAM:  128 MB
FLASH: Winbond W25Q128 (16 MB)

LED on during eth initialization...

Hit any key to stop autobooting:  0

Booting image at: 0x9F020000

   Image name:   OpenWrt r3566-98c003
   Image type:   MIPS Linux Kernel Image (lzma compressed)
   Data size:    1359296 Bytes = 1.3 MB
   Load address: 0x80060000
   Entry point:  0x80060000

Uncompressing kernel image... OK!
Starting kernel...

[    0.000000] Linux version 4.4.93 (cezary@eko.one.pl) (gcc version 5.4.0 (LEDE GCC 5.4.0 r3103-1b51a49) ) #0 Wed Oct 18 20:14:25 2017
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU0 revision is: 0001974c (MIPS 74Kc)
[    0.000000] SoC: Atheros AR9344 rev 2
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 08000000 @ 00000000 (usable)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] No valid device tree found, continuing without
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x0000000000000000-0x0000000007ffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x0000000000000000-0x0000000007ffffff]
[    0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x0000000007ffffff]
[    0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 32512
[    0.000000] Kernel command line:  board=TL-WDR4300  console=ttyS0,115200 rootfstype=squashfs,jffs2 noinitrd
[    0.000000] PID hash table entries: 512 (order: -1, 2048 bytes)
[    0.000000] Dentry cache hash table entries: 16384 (order: 4, 65536 bytes)
[    0.000000] Inode-cache hash table entries: 8192 (order: 3, 32768 bytes)
[    0.000000] Writing ErrCtl register=00000000
[    0.000000] Readback ErrCtl register=00000000
[    0.000000] Memory: 124944K/131072K available (3101K kernel code, 163K rwdata, 776K rodata, 304K init, 205K bss, 6128K reserved, 0K cma-reserved)
[    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] NR_IRQS:51
[    0.000000] Clocks: CPU:700.000MHz, DDR:450.000MHz, AHB:225.000MHz, Ref:40.000MHz
[    0.000000] clocksource: MIPS: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 5460744132 ns
[    0.000007] sched_clock: 32 bits at 350MHz, resolution 2ns, wraps every 6135667710ns
[    0.008288] Calibrating delay loop... 348.97 BogoMIPS (lpj=1744896)
[    0.071194] pid_max: default: 32768 minimum: 301
[    0.076210] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.083254] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.092894] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
[    0.103407] futex hash table entries: 256 (order: -1, 3072 bytes)
[    0.110992] NET: Registered protocol family 16
[    0.116969] MIPS: machine is TP-LINK TL-WDR3600/4300/4310
[    0.125257] registering PCI controller with io_map_base unset
[    0.364074] PCI host bridge to bus 0000:00
[    0.368441] pci_bus 0000:00: root bus resource [mem 0x10000000-0x13ffffff]
[    0.375792] pci_bus 0000:00: root bus resource [io  0x0000]
[    0.381715] pci_bus 0000:00: root bus resource [??? 0x00000000 flags 0x0]
[    0.388949] pci_bus 0000:00: No busn resource found for root bus, will use [bus 00-ff]
[    0.397441] pci 0000:00:00.0: invalid calibration data
[    0.403306] pci 0000:00:00.0: BAR 0: assigned [mem 0x10000000-0x1001ffff 64bit]
[    0.411098] pci 0000:00:00.0: BAR 6: assigned [mem 0x10020000-0x1002ffff pref]
[    0.418816] pci 0000:00:00.0: using irq 40 for pin 1
[    0.424858] clocksource: Switched to clocksource MIPS
[    0.431359] NET: Registered protocol family 2
[    0.436779] TCP established hash table entries: 1024 (order: 0, 4096 bytes)
[    0.444197] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
[    0.451006] TCP: Hash tables configured (established 1024 bind 1024)
[    0.457850] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.464074] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.471007] NET: Registered protocol family 1
[    0.479690] Crashlog allocated RAM at address 0x3f00000
[    0.498170] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.504380] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.517044] io scheduler noop registered
[    0.521221] io scheduler deadline registered (default)
[    0.526940] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
[    0.536062] console [ttyS0] disabled
[    0.559942] serial8250.0: ttyS0 at MMIO 0x18020000 (irq = 11, base_baud = 2500000) is a 16550A
[    0.569129] console [ttyS0] enabled
[    0.569129] console [ttyS0] enabled
[    0.576545] bootconsole [early0] disabled
[    0.576545] bootconsole [early0] disabled
[    0.589391] m25p80 spi0.0: found w25q128, expected m25p80
[    0.594931] m25p80 spi0.0: w25q128 (16384 Kbytes)
[    0.600628] 5 tp-link partitions found on MTD device spi0.0
[    0.606320] Creating 5 MTD partitions on "spi0.0":
[    0.611179] 0x000000000000-0x000000020000 : "u-boot"
[    0.617448] 0x000000020000-0x00000016bfc0 : "kernel"
[    0.623851] 0x00000016bfc0-0x000000ff0000 : "rootfs"
[    0.630319] mtd: device 2 (rootfs) set to be root filesystem
[    0.636131] 1 squashfs-split partitions found on MTD device rootfs
[    0.642408] 0x0000003e0000-0x000000ff0000 : "rootfs_data"
[    0.649287] 0x000000ff0000-0x000001000000 : "art"
[    0.655528] 0x000000020000-0x000000ff0000 : "firmware"
[    0.669122] switch0: Atheros AR8327 rev. 2 switch registered on ag71xx-mdio.0
[    1.275797] libphy: ag71xx_mdio: probed
[    1.866242] ag71xx ag71xx.0: connected to PHY at ag71xx-mdio.0:00 [uid=004dd033, driver=Atheros AR8216/AR8236/AR8316]
[    1.877605] eth0: Atheros AG71xx at 0xb9000000, irq 4, mode:RGMII
[    1.885735] NET: Registered protocol family 10
[    1.893450] NET: Registered protocol family 17
[    1.898084] bridge: automatic filtering via arp/ip/ip6tables has been deprecated. Update your scripts to load br_netfilter if you need this.
[    1.910998] 8021q: 802.1Q VLAN Support v1.8
[    1.920377] VFS: Mounted root (squashfs filesystem) readonly on device 31:2.
[    1.928860] Freeing unused kernel memory: 304K
[    2.308206] SQUASHFS error: xz decompression failed, data probably corrupt
[    2.315214] SQUASHFS error: squashfs_read_data failed to read block 0x56efe
[    2.340551] SQUASHFS error: xz decompression failed, data probably corrupt
[    2.347553] SQUASHFS error: squashfs_read_data failed to read block 0x56efe
[    2.354683] Starting init: /etc/preinit exists but couldn't execute it (error -14)
[    2.362560] Starting init: /sbin/init exists but couldn't execute it (error -14)
[    2.370229] Starting init: /bin/sh exists but couldn't execute it (error -14)
[    2.377499] Kernel panic - not syncing: No working init found.  Try passing init= option to kernel. See Linux Documentation/init.txt for guidance.
[    2.391537] Rebooting in 1 seconds..

21

(27 odpowiedzi, napisanych Sprzęt)

hmm, podłączyłem także VCC do VCC mogłem go uwalić ?

22

(27 odpowiedzi, napisanych Sprzęt)

Podłączyłem serial lecz nie mogę dostać się na router.
Nie wiem czy aż tak padł czy zapomniałem jak to się robiło.

1. TX mam podłączyć do RX czy też do TX
2. w Putty wybieram Serial zmieniam na mój COM3 i speed 9600 i coś jeszcze?
3. Jaka jest kolejność czynności do wykonania?
4. Wystarczy zasilanie tylko z adaptera usb czy mam jeszcze podłączyć zasilanie 230V jeśli tak to w którym momencie?

23

(27 odpowiedzi, napisanych Sprzęt)

Router i U-Boot jak w temacie, z luci-17.01-snapshot-r3322-5feb4f0-ar71xx, bez extroot.

Po reboocie z poziomu konsoli nie włącza się. Led od zasilania pali się cały czas a pozostałe ledy w powtarzalnej sekwencji zapalają się i gasną. Mam wrażenie jakby był boot loop.
Nic nie zmieniałem, nie instalowałem lecz jedyne co mi przychodzi na myśl to brak miejsca. Nie pamiętam dokładnie, ale miejsca wolnego było mniej niż 1 MB.

Podłączę się przez serial, zakładam że się uda.
Proszę o przykładowe polecenia, co mogę sprawdzić, zrobić żeby naprawić i nie instalować wszystkiego od nowa? O ile to będzie możliwe.

24

(1 odpowiedzi, napisanych Inne)

Czy w cron można ustawić wykonanie jakiejś czynności np. co 30 sekund. W przykładach znalazłem najmniej 1 min.

25

(5 odpowiedzi, napisanych Inne)

Wysłałem własnie jeszcze raz.