Testowałem, i było to samo, także z Luci. Ale okazało się że to raczej problem z Mikrotik, a konkretnie z Fasttrack - problem zniknął po wyłączeniu Fasttrack (tyle że router działa wolniej...). Może się komuś ta informacja przyda. Napisałem o tym na forum Mikrotika, czekam na odzew.

Dzięki, tak zrobię

Witam,

Ech, zachciało mi się upgrade... i mam za swoje roll. Trzy dni szukam rozwiązania i dalej nic - więc pomyślałem że zapytam mądrzejszych.

Zaczynając od początku: w mojej sieci obecnie głównym routerem jest router Mikrotik, a ponieważ RouterOS nigdy nie wspierał OpenVPN poprzez tun/UDP (a potrzebuję tunelu OpenVPN po UDP do dostępu do sieci firmowej) - do tego celu zaprzągłem Gargoyle na WDR3600.

I na początku działało to całkiem fajnie, na Gargoyle uruchomiłem klienta OpenVPN, na mikrotiku ruch z wyznaczonych podsieci wędrował kabelkiem to TP-Linka, a ja popijałem drinki z palemką cool.

Ale.

Coś mnie podkusiło na upgrade (a dokładniej - problemy z wydajnością sieci), i poprzedniego Mikrotika RB2011 wymieniłem na nowszy lepszy model, czyli RB3011, oraz na WDR 3600 zainstalowałem najnowszego Gargoyle (tunel VPN nie musi być specjalnie wydajny).  Na Gargoyle ponownie uruchomiłem OpenVPN do sieci firmowej, połączenie VPN działa, logując się do TP-Linka nie widzę żadnych problemów z siecią, przesyłanie dużych plików testowych przez VPN też działa ok.

Natomiast problemy zaczynają się po wyjściu pakietów z TP-Linka i wejściu na salony Mikrotika. Wszystkie małe pakiety diagnostyczne śmigają bez problemu: ping, traceroute, etc.

Niestety każda próba przesłania większego pakietu kończy się na tym, że po przesłaniu 3965 bajtów transmisja zdycha, bez żadnego widocznego problemu w logach. Posprawdzałem MTU tam gdzie tylko się dało, wszędzie mam MTU ustawione na 1500 (zarówno w Mikrotiku jak i Gargoyle) - zmieniałem porty, adresy, sprawdzałem też na starszym Mikrotiku (RB2011). I wciąż ten sam efekt....

Stąd byłbym bardzo wdzięczny za poradę - w jakim kierunku powinienem szukać rozwiązania problemu?

4

(66 odpowiedzi, napisanych Oprogramowanie)

spewak napisał/a:

Miałem kiedyś tani hub firmy c**j z opcją zasilania i po podłączeniu do niego zasilacza z ruterem działy się dziwne rzeczy. Pomogło wlutowanie diody na wejściu zasilania od strony routera.

Dokładnie tak. Zrobiłem sobie sam kabel ze wspomaganiem zasilania (do modemu E398) i póki co działa stabilnie. Od strony modemu przeciąłem kabelek +5V i wstawiłem diodę 1A, w końcu ten spadek 0.6V nie ma w tej sytuacji znaczenia. A jako zasilanie dodatkowe - mam mocną ładowarkę USB 2A. Mierzyłem napięcie, daje stabilne 5.01 V, więc powinno być ok. A i jeszcze na kabelku zasilania dodatkowego dałem ferryt, na wszelki wypadek.

... ale uci show qos_gargoyle raczej dotyczy czegoś innego, czyli wpisów FW dla QoS ?

Gdy zmienię przez GUI i zapiszę, to przez uci show firewall pokazuje poprawnie.

Dzisiaj próbowałem powtórzyć ten błąd, restartowałem router, ale działa ok... Bardzo dziwne. Jakie inne skrypty mogą grzebać w ustawieniach firewall?

Złapałem na gorącym uczynku - mam jeden przykład jak podczas restartu routera zmieniane/niszczone są ustawienia firewall (czyli cztery wpisy dla tego samego zakresu IP 10.162.0.60-10.162.0.69).

Na początku mam takie ustawienia:
http://i59.tinypic.com/2ylnt6t.png

Natomiast po restarcie:
http://i57.tinypic.com/2i99qc.png

Po kolejnym restarcie zostanie zmieniony kolejny wpis z zakresem "10.162.0.60-10.162.0.69".
Coś jest skopane w skryptach które to obsługują że poprawnie działa tylko z jednym wpisem danego typu, każdy kolejny odnoszący się do tego samego zakresu adresów jest źle obsługiwany.

Aha, a /etc/config/network wygląda w moim przypadku tak: (dla Orange Everywhere i Play, używam też OpenDNS):

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0.1'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.11.1'
        option dns '208.67.222.222 208.67.220.220'

config interface 'wan'
        option auto '1'
        option proto '3g'
        option service 'umts'
        option mobile_isp 'custom'
        option dns '208.67.222.222 208.67.220.220'
        option peerdns '0'
        option pincode '1234'
        option device '/dev/ttyUSB0'
        option apn 'vpn'
        option metric '1'

config interface 'wan2'
        option auto '1'
        option proto '3g'
        option service 'umts'
        option mobile_isp 'custom'
        option dns '208.67.222.222 208.67.220.220'
        option peerdns '0'
        option pincode '1234'
        option device '/dev/ttyUSB3'
        option apn 'internet'
        option metric '2'

config switch
        option name 'eth0'
        option reset '1'
        option enable_vlan '1'

Oraz w /etc/config/firewall mam między innymi:

config zone
        option name 'lan'
        list network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option conntrack '1'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        option network 'wan'
        option conntrack '1'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        option network 'wan2'
        option conntrack '1'

Całość działa w miarę ok

mk77 napisał/a:

A macie może gotowca mwan3 pod 2 modemy Huawei E3272 Play LTE podpięte do ruterka WDR3600 ?? Chodzi o równomierne wykorzystanie obu modemów.

Instalując pakiet mwan3 z repo masz domyślne pliki konfiguracyjne z trybem "balanced".

9

(4 odpowiedzi, napisanych Oprogramowanie)

Ano nie ma. Mówię o liście dostępnej w Status->Zużycie pasma->Tabela zużycia pasma.
Są tylko IP zewnętrzne - całkiem sporo ich jest, bo zazwyczaj codziennie dynamicznie dostaję nowy IP.

Urządzenia wewnętrzne owszem pojawiają się na liście Status->Połączone urządzenia, ale już nie są rejestrowane w statystykach.

10

(4 odpowiedzi, napisanych Oprogramowanie)

Na liście są tylko IP zewnętrzne, nie ma klienckich. Może to jest związane z tym że Gargoyle nie jest serwerem DHCP w mojej sieci? Poza tym mam kilka adresów statycznych.

Jedyny pomysł jaki mi się nasuwa to tworzenie odrębnych klas w QoS i śledzenie wg nich, ale może jest jakaś inna metoda.

Internet mobilny i Gargoyle, a więc i problem z limitami transferu.
Z tym że w moim przypadku chodzi o wykrycie niesfornego użytkownika (lub co bardziej prawdopodobne - urządzenia) które wymienia zbyt dużą ilość danych z Internetem. Ogólne statystyki są w tym przypadku mało przydatne, więc to chyba musiałby być skrypt lub plugin który okresowo rejestrowałby statystyki zużycia dla każdego podłączonego klienta.

Czy ktoś robił już coś podobnego?

12

(15 odpowiedzi, napisanych Oprogramowanie)

Dobra już wiem - oczywiście mój błąd: w lokalnym katalogu miałem plik o nazwie mwan3 - nie wiedziałem że opkg domyślnie próbuje instalować z pliku lokalnego...

13

(15 odpowiedzi, napisanych Oprogramowanie)

Standardowe, nic nie grzebałem:

attitude_adjustment      http://downloads.openwrt.org/attitude_a … c/packages
eko1                            http://dl.eko.one.pl/attitude_adjustmen … x/packages   
gargoylepl_packages     http://dl.eko.one.pl/gargoyle-pl/attitu … x/packages   
gargoylepl_plugins        http://dl.eko.one.pl/gargoyle-pl/attitu … xx/plugins

14

(15 odpowiedzi, napisanych Oprogramowanie)

Wykonałem upgrade do Gargoyle 1.6.1.1 i mam problem z mwan3.
Mianowicie po pomyślnym 'opkg update', kolejne polecenie 'opkg install mwan3' niestety zwraca mi:

ERROR: mwan3 is not a valid package file, cannot install

Coś się stało z pakietem?

15

(2 odpowiedzi, napisanych Oprogramowanie)

A bez n2n działa?

Wiem wiem skoro nie potrafię określić gdzie dokładnie to można to o kant potłuc...

Ale może na coś się informacja przyda. Gdy mam już po parę wpisów w QoS (konfiguracja firewalla) a zwłaszcza w limitach transferu - dodawanie nowych pozycji w QoS wysyłanie/odbieranie w którymś momencie zaczyna psuć konfigurację. Raz znikają wpisy z /etc/config/firewall, innym razem z z /etc/config/qos_gargoyle.... Właśnie nie wiem dokładnie które pole i kiedy to powoduje, zwyczajnie po paru zmianach w konfiguracji nagle orientuję się że się rozsypało i trzeba odtwarzać pliki z backupu.

Może ktoś inny się z tym spotkał i wspólnie złapiemy buga?

17

(7 odpowiedzi, napisanych Oprogramowanie)

Np. SMS-em uruchamiam sobie zdalny dostęp jak gdzieś wyjeżdżam i chcę zajrzeć do sieci domowej.
Wysyłam SMS-a na numer modemu, ten mi poprzez pakiet smstools3 zmienia konfigurację 3G na VPN i aktualizuje DDNS, i dostęp jest. Na żądanie, żeby było bezpieczniej, i tylko z mojego numeru tel. A i jeszcze SMS-a zwrotnego z potwierdzeniem wysyłam.

18

(7 odpowiedzi, napisanych Oprogramowanie)

Cezary napisał/a:

Zapomnij - przez sieć komórkową nie możesz wystawiać żadnych serwerów.

Za dodatkową opłatą da się, np. w Orange można (nazywa się to usługa VPN, dynamiczny adres zewnętrzny to koszt 5 zł/miesiąc, stały to 15, +vat). Przynajmniej w taryfach biznesowych, nie wiem jak w innych.

19

(3 odpowiedzi, napisanych Oprogramowanie)

Dzięki, faktycznie jest i działa. Po instalacji potrzebny restart routera, inaczej "openssl version" pokazuje starą wersję

20

(3 odpowiedzi, napisanych Oprogramowanie)

Zdaje się że wciąż jest starsza wersja, podatna na Heartbleed. Warto by uaktualnić.

A gdyby warunkiem było ext2 lub ext3?

Cezary pisał że trzeba instalować extroota. Też średnio szczęśliwy jestem z tego powodu, ale nie ja tu decyduję. Przecież ci co mieli problem z pluginami zawsze mogli sobie extrota zrobić, a możliwość instalacji na zewnętrznym nośniku można było zostawić w spokoju...

23

(2 odpowiedzi, napisanych Oprogramowanie)

och żesz... nie wiem dlaczego wyszukiwarka nie znalazła smile

Dziękuje.

---
update: smstools3 działa pięknie

Witam,

Chciałem zapytać szanownych forumowiczów czy ktoś ma doświadczenia ze sterowaniem routera za pomocą SMS? Konkretnie chodzi o wykonywanie komend w zależności od treści SMS-a otrzymanego przez modem 3G podpięty do routera. Przejrzałem forum i nie zauważyłem takiej tematyki - może źle szukałem...

W moim przypadku chodzi o zdalne wymuszenie restartu routera czy przełączenia konfiguracji WAN w sytuacji gdy podłączony jest modem do którego nie można podłączyć się od strony Internetu (np. sieć Play, Orange itp).  Automatyczne skrypty nie bardzo rozwiązują sprawę, chciałbym by było to wykonywane na żądanie.


Znalazłem pakiet smstool3, ale zanim zacznę z nim eksperymentować - chciałem się upewnić że nie ma prostszego sposobu.

25

(15 odpowiedzi, napisanych Oprogramowanie)

Zainstalowałem mwan3 i działa fajnie, ale też przestaje działać QoS - które dla mnie jest podstawowym powodem korzystania z Gargoyle - bo jest zrobione bardzo dobrze.

Tak zastanawiałem się czy zamiast sięgać do WAN - NAT z Gargoyle nie mógłby się odwoływałby się do interfejsu multiwan?
Wówczas sterowanie pakietami powinno działać, po przecież odbywa się to po stronie LAN?